Bug 298448

Summary: Updating a paragraph style does not update already written section
Product: [Applications] calligrawords Reporter: maxime.haselbauer
Component: generalAssignee: Calligra Words Bugs <calligra-words-bugs-null>
Severity: normal CC: cbo, inge
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description maxime.haselbauer 2012-04-19 20:48:03 UTC
1) create a new document with blank template
2) Type paragraph A
3)Type paragraph B
4) Set a on style "Head"
5) Edit the "Head" paragraph style (switch to italic) (not the A paragraph)
6) Set B paragraph to Head

B is italic but A remains in the original style. 
A has not been updated when changing the style of "Head"

Reproducible: Always
Comment 1 Inge Wallin 2012-04-20 19:57:07 UTC
I cannot confirm this particular bug.  The particular case you outlined above worked for me when I tried your approach. But there is something fishy going on there because I saw other strange things. The maintainer should definitely look at it so I'm confirming the bug in general even if that particular behaviour was not observed.

Btw, which version is this? 2.4.0 or 2.5.0alpha?
Comment 2 maxime.haselbauer 2012-04-20 20:00:08 UTC
what strange things do you observe? maybe I can reproduce it
Comment 3 Camilla Boemann 2012-04-20 20:50:37 UTC

*** This bug has been marked as a duplicate of bug 283351 ***
Comment 4 Camilla Boemann 2012-04-21 06:33:38 UTC

*** This bug has been marked as a duplicate of bug 296487 ***