Bug 294766

Summary: Crash when opening samba folders
Product: [Frameworks and Libraries] kdelibs Reporter: Otso Helenius <kde>
Component: kdedAssignee: Unassigned bugs mailing-list <unassigned-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Fedora RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Otso Helenius 2012-02-24 19:05:38 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.7-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
I opened dolphin, navigated to a samba folder, crash assistant pops up (dolphin itself seems to work fine)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kded4), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f71126b0840 (LWP 1283))]

Thread 3 (Thread 0x7f71058c1700 (LWP 1293)):
#0  0x0000003a9f2e6af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003d6ba44fd8 in g_main_context_poll (n_fds=1, fds=0x7f70f8002250, priority=<optimized out>, timeout=-1, context=0x7f70f80009a0) at gmain.c:3402
#2  g_main_context_iterate (context=0x7f70f80009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x0000003d6ba4549c in g_main_context_iteration (context=0x7f70f80009a0, may_block=1) at gmain.c:3152
#4  0x000000397b1a7dc6 in QEventDispatcherGlib::processEvents (this=0x7f70f80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000397b178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000397b1783d7 in QEventLoop::exec (this=0x7f71058c0d10, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000397b078b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000397b157e7f in QInotifyFileSystemWatcherEngine::run (this=0x11b59b0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x000000397b07bb6b in QThreadPrivate::start (arg=0x11b59b0) at thread/qthread_unix.cpp:298
#10 0x0000003a9fa07d90 in start_thread (arg=0x7f71058c1700) at pthread_create.c:309
#11 0x0000003a9f2ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f71060c2700 (LWP 13936)):
#0  0x0000003a9f2e6af3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003d6ba44fd8 in g_main_context_poll (n_fds=1, fds=0x7f7100005160, priority=<optimized out>, timeout=-1, context=0x7f7100003260) at gmain.c:3402
#2  g_main_context_iterate (context=0x7f7100003260, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x0000003d6ba4549c in g_main_context_iteration (context=0x7f7100003260, may_block=1) at gmain.c:3152
#4  0x000000397b1a7dc6 in QEventDispatcherGlib::processEvents (this=0x7f71000047d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000397b178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x000000397b1783d7 in QEventLoop::exec (this=0x7f71060c1d40, flags=...) at kernel/qeventloop.cpp:204
#7  0x000000397b078b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x000000397b07bb6b in QThreadPrivate::start (arg=0x110bab0) at thread/qthread_unix.cpp:298
#9  0x0000003a9fa07d90 in start_thread (arg=0x7f71060c2700) at pthread_create.c:309
#10 0x0000003a9f2ef48d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f71126b0840 (LWP 1283)):
[KCrash Handler]
#6  0x0000003a9f236285 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x0000003a9f237b9b in __GI_abort () at abort.c:91
#8  0x0000003a9f275fae in __libc_message (do_abort=2, fmt=0x3a9f374b98 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:198
#9  0x0000003a9f27c2d6 in malloc_printerr (action=3, str=0x3a9f371b69 "free(): invalid pointer", ptr=<optimized out>) at malloc.c:5021
#10 0x000000397b0c5e5c in QString::free (d=0x3a9f5af700) at tools/qstring.cpp:1232
#11 0x00007f70eb9a7776 in ~QString (this=0x7ffff564d6e0, __in_chrg=<optimized out>) at /usr/include/QtCore/qstring.h:880
#12 QList<QString>::removeAll (this=0x15f3ba0, _t=<optimized out>) at /usr/include/QtCore/qlist.h:773
#13 0x00007f70eb9a54a9 in KPasswdServer::processRequest (this=0x15f3b60) at /usr/src/debug/kde-runtime-4.7.4/kpasswdserver/kpasswdserver.cpp:718
#14 0x00007f70eb9a62c5 in qt_static_metacall (_a=0x15fdbc0, _id=<optimized out>, _o=0x15f3b60, _c=<optimized out>) at /usr/src/debug/kde-runtime-4.7.4/x86_64-redhat-linux-gnu/kpasswdserver/kpasswdserver.moc:89
#15 KPasswdServer::qt_static_metacall (_o=0x15f3b60, _c=<optimized out>, _id=<optimized out>, _a=0x15fdbc0) at /usr/src/debug/kde-runtime-4.7.4/x86_64-redhat-linux-gnu/kpasswdserver/kpasswdserver.moc:70
#16 0x000000397b191f16 in QObject::event (this=0x15f3b60, e=<optimized out>) at kernel/qobject.cpp:1195
#17 0x00000033041c9994 in notify_helper (e=0x160bcc0, receiver=0x15f3b60, this=0xf9f970) at kernel/qapplication.cpp:4550
#18 QApplicationPrivate::notify_helper (this=0xf9f970, receiver=0x15f3b60, e=0x160bcc0) at kernel/qapplication.cpp:4522
#19 0x00000033041ce813 in QApplication::notify (this=0x7ffff564e870, receiver=0x15f3b60, e=0x160bcc0) at kernel/qapplication.cpp:4411
#20 0x0000003305050766 in KApplication::notify (this=0x7ffff564e870, receiver=0x15f3b60, event=0x160bcc0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#21 0x000000397b17904c in QCoreApplication::notifyInternal (this=0x7ffff564e870, receiver=0x15f3b60, event=0x160bcc0) at kernel/qcoreapplication.cpp:876
#22 0x000000397b17cada in sendEvent (event=0x160bcc0, receiver=0x15f3b60) at kernel/qcoreapplication.h:231
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xf6e4d0) at kernel/qcoreapplication.cpp:1500
#24 0x000000397b1a7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#25 postEventSourceDispatch (s=0xfa3380) at kernel/qeventdispatcher_glib.cpp:279
#26 0x0000003d6ba44acd in g_main_dispatch (context=0xfa19e0) at gmain.c:2441
#27 g_main_context_dispatch (context=0xfa19e0) at gmain.c:3011
#28 0x0000003d6ba452c8 in g_main_context_iterate (context=0xfa19e0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3089
#29 0x0000003d6ba4549c in g_main_context_iteration (context=0xfa19e0, may_block=1) at gmain.c:3152
#30 0x000000397b1a7d5f in QEventDispatcherGlib::processEvents (this=0xf6f990, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#31 0x000000330426c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#32 0x000000397b178182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x000000397b1783d7 in QEventLoop::exec (this=0x7ffff564e800, flags=...) at kernel/qeventloop.cpp:204
#34 0x000000397b17cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#35 0x0000003307c08de5 in kdemain (argc=1, argv=0x7ffff564ec48) at /usr/src/debug/kdelibs-4.7.4/kded/kded.cpp:924
#36 0x0000003a9f22169d in __libc_start_main (main=0x400710 <main(int, char**)>, argc=1, ubp_av=0x7ffff564ec48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff564ec38) at libc-start.c:226
#37 0x0000000000400741 in _start ()

Possible duplicates by query: bug 292022, bug 290830, bug 290682, bug 290537, bug 290055.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-24 19:59:45 UTC

*** This bug has been marked as a duplicate of bug 288571 ***