Bug 294709

Summary: Crash on quit
Product: amarok Reporter: Basti <s.hs>
Component: generalAssignee: Amarok Developers <amarok-bugs-dist>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: 2.5.0   
Target Milestone: 2.6   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Basti 2012-02-23 19:43:39 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.0.6-tuxonice x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

I told Amarok to quit while playing a track. It exited successfully but then Konqui was showing Amarok crashed.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7f91028780 (LWP 3455))]

Thread 10 (Thread 0x7f7f4fd96700 (LWP 3457)):
#0  0x00007f7f8b82b44c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7f78a99e50 in ?? () from /usr/lib64/libvlccore.so.4
#2  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#3  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f7f4dc41700 (LWP 3460)):
#0  0x00007f7f8d672353 in poll () from /lib64/libc.so.6
#1  0x00007f7f88168584 in g_main_context_poll (n_fds=1, fds=0x7f7f48002280, timeout=-1, context=0x20a5900, priority=<optimized out>) at gmain.c:3402
#2  g_main_context_iterate (context=0x20a5900, block=1, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x00007f7f88168a41 in g_main_context_iteration (context=0x20a5900, may_block=1) at gmain.c:3152
#4  0x00007f7f8dffa936 in QEventDispatcherGlib::processEvents (this=0x1c1d710, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f7f8dfca7c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7f8dfcaa75 in QEventLoop::exec (this=0x7f7f4dc40dc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f7f8dec80b8 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f7f8dfa9508 in QInotifyFileSystemWatcherEngine::run (this=0x207d360) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f7f8deca72b in QThreadPrivate::start (arg=0x207d360) at thread/qthread_unix.cpp:298
#10 0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#11 0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f7f47939700 (LWP 3469)):
#0  0x00007f7f8b82b44c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7f8decb63b in wait (time=18446744073709551615, this=0x20d2000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b30d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f7f8abdb75e in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f7f8abde213 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f7f8abdcf8f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f7f8abdd018 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f7f8deca72b in QThreadPrivate::start (arg=0x22b3590) at thread/qthread_unix.cpp:298
#8  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#9  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f7f468f3700 (LWP 3479)):
#0  0x00007f7f8b82b44c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7f8decb63b in wait (time=18446744073709551615, this=0x20d2000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b30d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f7f8abdb75e in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f7f8abde213 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f7f8abdcf8f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f7f8abdd018 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f7f8deca72b in QThreadPrivate::start (arg=0x28a3890) at thread/qthread_unix.cpp:298
#8  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#9  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f7f460f2700 (LWP 3480)):
#0  0x00007f7f8b82b44c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7f8decb63b in wait (time=18446744073709551615, this=0x20d2000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b30d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f7f8abdb75e in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f7f8abde213 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f7f8abdcf8f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f7f8abdd018 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f7f8deca72b in QThreadPrivate::start (arg=0x27b5d50) at thread/qthread_unix.cpp:298
#8  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#9  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f7f458f1700 (LWP 3481)):
#0  0x00007f7f8b82b44c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7f8decb63b in wait (time=18446744073709551615, this=0x20d2000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x22b30d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f7f8abdb75e in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f7f8abde213 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f7f8abdcf8f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f7f8abdd018 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f7f8deca72b in QThreadPrivate::start (arg=0x27b6a30) at thread/qthread_unix.cpp:298
#8  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#9  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f7f3ef8f700 (LWP 3482)):
#0  0x00007f7f8b82b44c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7f852d6024 in ?? () from /usr/lib64/qt4/libQtWebKit.so.4
#2  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#3  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f7f3e68e700 (LWP 3483)):
#0  0x00007f7f88190599 in g_thread_self () at gthread.c:2178
#1  0x00007f7f88168a31 in g_main_context_iteration (context=0x2a51780, may_block=1) at gmain.c:3152
#2  0x00007f7f8dffa936 in QEventDispatcherGlib::processEvents (this=0x2a522b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#3  0x00007f7f8dfca7c2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f7f8dfcaa75 in QEventLoop::exec (this=0x7f7f3e68de00, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007f7f8dec80b8 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#6  0x00007f7f8deca72b in QThreadPrivate::start (arg=0x2a52b70) at thread/qthread_unix.cpp:298
#7  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#8  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f7f3d3d7700 (LWP 3488)):
#0  0x00007f7f8d64a6cd in nanosleep () from /lib64/libc.so.6
#1  0x00007f7f8d64a55f in sleep () from /lib64/libc.so.6
#2  0x00007f7f89bd5606 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f7f89bd56a9 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#4  0x00007f7f8b826c5c in start_thread () from /lib64/libpthread.so.0
#5  0x00007f7f8d67afcd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7f91028780 (LWP 3455)):
[KCrash Handler]
#6  0x00007f7f8dfe1bdd in QObject::~QObject (this=0x412dea0, __in_chrg=<optimized out>) at kernel/qobject.cpp:820
#7  0x00007f7f8dfe2449 in QObject::~QObject (this=0x412dea0, __in_chrg=<optimized out>) at kernel/qobject.cpp:940
#8  0x00007f7f8fdb2216 in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:322
#9  qDeleteAll<SmartPointerList<Collections::Collection> > (c=<optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:330
#10 CollectionManager::~CollectionManager (this=0x17525c0, __in_chrg=<optimized out>) at /var/tmp/portage/media-sound/amarok-2.5.0-r2/work/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:137
#11 0x00007f7f8fdb23d9 in CollectionManager::~CollectionManager (this=0x17525c0, __in_chrg=<optimized out>) at /var/tmp/portage/media-sound/amarok-2.5.0-r2/work/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:145
#12 0x00007f7f8fdae326 in CollectionManager::destroy () at /var/tmp/portage/media-sound/amarok-2.5.0-r2/work/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:107
#13 0x00007f7f8ff8e89f in App::~App (this=0x7ffffaeaef80, __in_chrg=<optimized out>) at /var/tmp/portage/media-sound/amarok-2.5.0-r2/work/amarok-2.5.0/src/App.cpp:248
#14 0x000000000040e404 in main (argc=1, argv=0x7ffffaeb1408) at /var/tmp/portage/media-sound/amarok-2.5.0-r2/work/amarok-2.5.0/src/main.cpp:301

This bug may be a duplicate of or related to bug 270918.

Possible duplicates by query: bug 281312, bug 270918.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-02-23 21:10:59 UTC

*** This bug has been marked as a duplicate of bug 285951 ***