Bug 293300

Summary: Crash of Muon Software Center- It didn't open while I click the icon.
Product: muon Reporter: Venkatesan M <mvenkatesancse>
Component: installerAssignee: Jonathan Thomas <echidnaman>
Status: RESOLVED DUPLICATE    
Severity: crash CC: adaptee
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Venkatesan M 2012-02-04 15:19:48 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

Crash of Muon Software Center- It didn't open while I click the icon eventhough i installed all updates and packages.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77cc930 (LWP 1632))]

Thread 2 (Thread 0xb5ae5b70 (LWP 1633)):
#0  0x0065a416 in __kernel_vsyscall ()
#1  0x0086a40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x05f4434b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05f35896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x05f35c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0053eada in QEventDispatcherGlib::processEvents (this=0x8e448b0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#6  0x0050f1dd in QEventLoop::processEvents (this=0xb5ae52b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x0050f421 in QEventLoop::exec (this=0xb5ae52b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0041290b in QThread::exec (this=0x8dfe820) at thread/qthread.cpp:498
#9  0x004efe2d in QInotifyFileSystemWatcherEngine::run (this=0x8dfe820) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x004157b3 in QThreadPrivate::start (arg=0x8dfe820) at thread/qthread_unix.cpp:331
#11 0x00929d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x008790ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77cc930 (LWP 1632)):
[KCrash Handler]
#7  0x00469e11 in QtPrivate::QStringList_contains (that=0xbfeb4234, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfeb4234) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8de8520) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8de8520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeb4454) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00516b7d in metacall (argv=0xbfeb4454, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8de8520) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8de8520, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfeb4454) at kernel/qmetaobject.cpp:232
#13 0x00525a6a in QMetaObject::activate (sender=0x8e841b0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8e841b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8e841b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeb4598) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00516b7d in metacall (argv=0xbfeb4598, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8e841b0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8e841b0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfeb4598) at kernel/qmetaobject.cpp:232
#18 0x00525a6a in QMetaObject::activate (sender=0x8de8520, m=0x80950c0, local_signal_index=0, argv=0xbfeb4598) at kernel/qobject.cpp:3278
#19 0x00d707c5 in MuonMainWindow::backendReady (this=0x8de8520, _t1=0x8de4608) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00d70933 in MuonMainWindow::initObject (this=0x8de8520) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8de8520) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8de8520, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfeb46c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00516b7d in metacall (argv=0xbfeb46c4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8de8520) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8de8520, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfeb46c4) at kernel/qmetaobject.cpp:232
#25 0x00525a6a in QMetaObject::activate (sender=0x8e5d8e0, m=0x646238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0052d375 in QSingleShotTimer::timeout (this=0x8e5d8e0) at .moc/release-shared/qtimer.moc:82
#27 0x0052d42c in QSingleShotTimer::timerEvent (this=0x8e5d8e0) at kernel/qtimer.cpp:308
#28 0x00528994 in QObject::event (this=0x8e5d8e0, e=0xbfeb4abc) at kernel/qobject.cpp:1181
#29 0x065a1d84 in notify_helper (e=0xbfeb4abc, receiver=0x8e5d8e0, this=0x8cfa618) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8cfa618, receiver=0x8e5d8e0, e=0xbfeb4abc) at kernel/qapplication.cpp:4458
#31 0x065a7133 in QApplication::notify (this=0xbfeb4abc, receiver=0x8e5d8e0, e=0xbfeb4abc) at kernel/qapplication.cpp:3886
#32 0x010f8971 in KApplication::notify (this=0xbfeb4dd0, receiver=0x8e5d8e0, event=0xbfeb4abc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0051019e in QCoreApplication::notifyInternal (this=0xbfeb4dd0, receiver=0x8e5d8e0, event=0xbfeb4abc) at kernel/qcoreapplication.cpp:787
#34 0x00540c10 in sendEvent (event=0xbfeb4abc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8cfbf34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0053e122 in timerSourceDispatch (source=0x8cfbf00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x05f3525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x05f35990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05f35c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0053eada in QEventDispatcherGlib::processEvents (this=0x8cdd238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06659e7a in QGuiEventDispatcherGlib::processEvents (this=0x8cdd238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0050f1dd in QEventLoop::processEvents (this=0xbfeb4d34, flags=...) at kernel/qeventloop.cpp:149
#43 0x0050f421 in QEventLoop::exec (this=0xbfeb4d34, flags=...) at kernel/qeventloop.cpp:201
#44 0x0051419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0659f924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 293258, bug 293257, bug 293256, bug 293245, bug 293238.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-04 16:19:17 UTC

*** This bug has been marked as a duplicate of bug 291262 ***