Bug 291432

Summary: plasmoïde error
Product: marble Reporter: Remi1789 <remi.stodolny>
Component: plasmoidAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Remi1789 2012-01-13 11:18:59 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6" (Compiled from sources)
Qt Version: 4.7.1
Operating System: Linux 2.6.37.6-0.9-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
i tried adding the plasmoïde "horloge mondiale" then black screen to finish the screen displayed that an error occur that's all.
just for information my installation of openSUZE is a virtual machine. running 2 core and 1 Go RAM.

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb59a1710 (LWP 2508))]

Thread 3 (Thread 0xa9dd0b70 (LWP 2623)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb619603e in poll () from /lib/libc.so.6
#2  0xb5c1b0bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5c0ac46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5c0afce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6f8a797 in QEventDispatcherGlib::processEvents (this=0x86ef0f8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6f5b29d in QEventLoop::processEvents (this=0xa9dd02b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6f5b4c9 in QEventLoop::exec (this=0xa9dd02b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6e5c7b9 in QThread::exec (this=0x86b4148) at thread/qthread.cpp:490
#9  0xb6f3b21d in QInotifyFileSystemWatcherEngine::run (this=0x86b4148) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6e5f3aa in QThreadPrivate::start (arg=0x86b4148) at thread/qthread_unix.cpp:285
#11 0xb6de3b05 in start_thread () from /lib/libpthread.so.0
#12 0xb61a0d5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa8871b70 (LWP 8031)):
#0  0xb5c0a902 in ?? () from /lib/libglib-2.0.so.0
#1  0xb5c0afce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0xb6f8a797 in QEventDispatcherGlib::processEvents (this=0x8149d18, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0xb6f5b29d in QEventLoop::processEvents (this=0xa88712b0, flags=...) at kernel/qeventloop.cpp:149
#4  0xb6f5b4c9 in QEventLoop::exec (this=0xa88712b0, flags=...) at kernel/qeventloop.cpp:201
#5  0xb6e5c7b9 in QThread::exec (this=0x8ebcfe8) at thread/qthread.cpp:490
#6  0xb6f3b21d in QInotifyFileSystemWatcherEngine::run (this=0x8ebcfe8) at io/qfilesystemwatcher_inotify.cpp:248
#7  0xb6e5f3aa in QThreadPrivate::start (arg=0x8ebcfe8) at thread/qthread_unix.cpp:285
#8  0xb6de3b05 in start_thread () from /lib/libpthread.so.0
#9  0xb61a0d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb59a1710 (LWP 2508)):
[KCrash Handler]
#7  pixel (this=0xa4de9370, x=601, y=0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/StackedTile.cpp:78
#8  Marble::StackedTile::pixel (this=0xa4de9370, x=601, y=0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/StackedTile.cpp:285
#9  0xa7edd257 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0xa9402f50, lon=2.7925268885049559, lat=1.5707963267948966, scanLine=0x957d830) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#10 0xa7edfce3 in Marble::EquirectScanlineTextureMapper::mapTexture (this=0xa9402f50, viewParams=0x8ec6824, texColorizer=0x0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/EquirectScanlineTextureMapper.cpp:180
#11 0xa7edff24 in Marble::EquirectScanlineTextureMapper::mapTexture (this=0xa9402f50, painter=0xbf8c6c20, viewParams=0x8ec6824, dirtyRect=..., texColorizer=0x0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/EquirectScanlineTextureMapper.cpp:52
#12 0xa7ed42e9 in Marble::TextureLayer::paintGlobe (this=0x8ec6844, painter=0xbf8c6c20, viewParams=0x8ec6824, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/TextureLayer.cpp:161
#13 0xa7e46b9d in Marble::MarbleMapPrivate::paintGround (this=0x8ec6818, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#14 0xa7e47a65 in Marble::MarbleMap::paint (this=0x84bd978, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:828
#15 0xa801d168 in Marble::WorldClock::paintInterface (this=0x8be2008, p=0xbf8c6fdc, option=0x8145930, contentsRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/plasmoid/worldclock.cpp:354
#16 0xb4d26138 in Plasma::Applet::paint (this=0x8be2008, painter=0xbf8c6fdc, option=0x8145930, widget=0x0) at /usr/src/debug/kdelibs-4.6.0/plasma/applet.cpp:1443
#17 0xb6af96a5 in _q_paintItem (item=<value optimized out>, painter=0xbf8c6fdc, option=0x8145930, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#18 0xb6af99fa in _q_paintIntoCache (pix=0xbf8c74bc, item=0x8be2010, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#19 0xb6b0eb10 in QGraphicsScenePrivate::drawItemHelper (this=0x81457e0, item=0x8be2010, painter=0xbf8c82f4, option=0x8145930, widget=0x86c4b10, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#20 0xb6b0f47d in QGraphicsScenePrivate::draw (this=0x81457e0, item=0x8be2010, painter=0xbf8c82f4, viewTransform=0x0, transformPtr=0x8ebb258, exposedRegion=0x88e7bc8, widget=0x86c4b10, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4931
#21 0xb6b101ee in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x81457e0, item=0x8be2010, painter=0xbf8c82f4, viewTransform=0x0, exposedRegion=0x88e7bc8, widget=0x86c4b10, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0xb6b0f517 in QGraphicsScenePrivate::draw (this=0x81457e0, item=0x824ea80, painter=0xbf8c82f4, viewTransform=0x0, transformPtr=0x82d7798, exposedRegion=0x88e7bc8, widget=0x86c4b10, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#23 0xb6b101ee in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x81457e0, item=0x824ea80, painter=0xbf8c82f4, viewTransform=0x0, exposedRegion=0x88e7bc8, widget=0x86c4b10, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0xb6b10a77 in QGraphicsScenePrivate::drawItems (this=0x81457e0, painter=0xbf8c82f4, viewTransform=0x0, exposedRegion=0x88e7bc8, widget=0x86c4b10) at graphicsview/qgraphicsscene.cpp:4735
#25 0xb6b319ae in QGraphicsView::paintEvent (this=0x899f370, event=0x259) at graphicsview/qgraphicsview.cpp:3469
#26 0xb64c360a in QWidget::event (this=0x899f370, event=0xbf8c89b4) at kernel/qwidget.cpp:8346
#27 0xb68d1ed5 in QFrame::event (this=0x899f370, e=0xbf8c89b4) at widgets/qframe.cpp:557
#28 0xb69638a1 in QAbstractScrollArea::viewportEvent (this=0x899f370, e=0xbf8c89b4) at widgets/qabstractscrollarea.cpp:1043
#29 0xb6b32dbc in QGraphicsView::viewportEvent (this=0x899f370, event=0xbf8c89b4) at graphicsview/qgraphicsview.cpp:2864
#30 0xb6966196 in viewportEvent (this=0x8670500, o=0x86c4b10, e=0xbf8c89b4) at widgets/qabstractscrollarea_p.h:100
#31 QAbstractScrollAreaFilter::eventFilter (this=0x8670500, o=0x86c4b10, e=0xbf8c89b4) at widgets/qabstractscrollarea_p.h:116
#32 0xb6f5c156 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80bdad8, receiver=0x86c4b10, event=0xbf8c89b4) at kernel/qcoreapplication.cpp:847
#33 0xb64683e4 in QApplicationPrivate::notify_helper (this=0x80bdad8, receiver=0x86c4b10, e=0xbf8c89b4) at kernel/qapplication.cpp:4441
#34 0xb6471174 in QApplication::notify (this=0x80b6fb8, receiver=0x86c4b10, e=0xbf8c89b4) at kernel/qapplication.cpp:4324
#35 0xb75b61f1 in KApplication::notify (this=0x80b6fb8, receiver=0x86c4b10, event=0xbf8c89b4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#36 0xb6f5bfbe in QCoreApplication::notifyInternal (this=0x80b6fb8, receiver=0x86c4b10, event=0xbf8c89b4) at kernel/qcoreapplication.cpp:732
#37 0xb64c02a2 in sendSpontaneousEvent (this=0x86d68f0, pdev=0x89ad7dc, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x83ff298) at ../../src/corelib/kernel/qcoreapplication.h:218
#38 QWidgetPrivate::drawWidget (this=0x86d68f0, pdev=0x89ad7dc, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x83ff298) at kernel/qwidget.cpp:5433
#39 0xb66ae627 in QWidgetBackingStore::sync (this=0x83ff298) at painting/qbackingstore.cpp:1325
#40 0xb64b503b in QWidgetPrivate::syncBackingStore (this=0x88e7878) at kernel/qwidget.cpp:1816
#41 0xb64c40da in QWidget::event (this=0x899f370, event=0x88e1c60) at kernel/qwidget.cpp:8493
#42 0xb68d1ed5 in QFrame::event (this=0x899f370, e=0x88e1c60) at widgets/qframe.cpp:557
#43 0xb6965624 in QAbstractScrollArea::event (this=0x899f370, e=0x88e1c60) at widgets/qabstractscrollarea.cpp:996
#44 0xb6b25578 in QGraphicsView::event (this=0x899f370, event=0x88e1c60) at graphicsview/qgraphicsview.cpp:2741
#45 0xb6468414 in QApplicationPrivate::notify_helper (this=0x80bdad8, receiver=0x899f370, e=0x88e1c60) at kernel/qapplication.cpp:4445
#46 0xb6471174 in QApplication::notify (this=0x80b6fb8, receiver=0x899f370, e=0x88e1c60) at kernel/qapplication.cpp:4324
#47 0xb75b61f1 in KApplication::notify (this=0x80b6fb8, receiver=0x899f370, event=0x88e1c60) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#48 0xb6f5bfbe in QCoreApplication::notifyInternal (this=0x80b6fb8, receiver=0x899f370, event=0x88e1c60) at kernel/qcoreapplication.cpp:732
#49 0xb6f5fd4c in sendEvent (receiver=0x899f370, event_type=77, data=0x80582a0) at kernel/qcoreapplication.h:215
#50 QCoreApplicationPrivate::sendPostedEvents (receiver=0x899f370, event_type=77, data=0x80582a0) at kernel/qcoreapplication.cpp:1373
#51 0xb6f5fe9c in QCoreApplication::sendPostedEvents (receiver=0x899f370, event_type=77) at kernel/qcoreapplication.cpp:1266
#52 0xb6b06ace in dispatchPendingUpdateRequests (this=0x81457e0) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x81457e0) at graphicsview/qgraphicsscene.cpp:510
#54 0xb6b06ee3 in QGraphicsScene::qt_metacall (this=0x8146d68, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x8c28060) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0xb4d5b1a2 in Plasma::Corona::qt_metacall (this=0x8146d68, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8c28060) at /usr/src/debug/kdelibs-4.6.0/build/plasma/corona.moc:109
#56 0xb2605f62 in DesktopCorona::qt_metacall (this=0x8146d68, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8c28060) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/desktop/shell/desktopcorona.moc:101
#57 0xb6f628ad in QMetaObject::metacall (object=0x8146d68, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x8c28060) at kernel/qmetaobject.cpp:237
#58 0xb6f6d385 in QMetaCallEvent::placeMetaCall (this=0x8b3e240, object=0x8146d68) at kernel/qobject.cpp:534
#59 0xb6f7158f in QObject::event (this=0x8146d68, e=0x8b3e240) at kernel/qobject.cpp:1211
#60 0xb6b14750 in QGraphicsScene::event (this=0x8146d68, event=0x8b3e240) at graphicsview/qgraphicsscene.cpp:3544
#61 0xb6468414 in QApplicationPrivate::notify_helper (this=0x80bdad8, receiver=0x8146d68, e=0x8b3e240) at kernel/qapplication.cpp:4445
#62 0xb64710c7 in QApplication::notify (this=0x80b6fb8, receiver=0x8146d68, e=0x8b3e240) at kernel/qapplication.cpp:3845
#63 0xb75b61f1 in KApplication::notify (this=0x80b6fb8, receiver=0x8146d68, event=0x8b3e240) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#64 0xb6f5bfbe in QCoreApplication::notifyInternal (this=0x80b6fb8, receiver=0x8146d68, event=0x8b3e240) at kernel/qcoreapplication.cpp:732
#65 0xb6f5fd4c in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#66 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1373
#67 0xb6f5fe9c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#68 0xb6f8a5c4 in sendPostedEvents (s=0x80bff00) at kernel/qcoreapplication.h:220
#69 postEventSourceDispatch (s=0x80bff00) at kernel/qeventdispatcher_glib.cpp:277
#70 0xb5c0a509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#71 0xb5c0ad10 in ?? () from /lib/libglib-2.0.so.0
#72 0xb5c0afce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#73 0xb6f8a74b in QEventDispatcherGlib::processEvents (this=0x80bd610, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#74 0xb651e55a in QGuiEventDispatcherGlib::processEvents (this=0x80bd610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#75 0xb6f5b29d in QEventLoop::processEvents (this=0xbf8c9e34, flags=...) at kernel/qeventloop.cpp:149
#76 0xb6f5b4c9 in QEventLoop::exec (this=0xbf8c9e34, flags=...) at kernel/qeventloop.cpp:201
#77 0xb6f5ff70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#78 0xb6466104 in QApplication::exec () at kernel/qapplication.cpp:3719
#79 0xb260d8aa in kdemain (argc=1, argv=0x80a8f50) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#80 0x0804e531 in _start ()

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2012-01-13 13:20:53 UTC
Please upgrade to KDE 4.6.4 or later and reopen if it's still crashing there.

*** This bug has been marked as a duplicate of bug 265599 ***