Bug 291138

Summary: When folderview is configured to display a directory mounted over the network, the default gear icons are used instead of the icons specified in the .desktop files in that directory
Product: plasma4 Reporter: krienke
Component: widget-folderviewAssignee: Ignat Semenov <i.semenov.kde>
Status: RESOLVED DUPLICATE    
Severity: normal CC: adaptee, bob.davis, ed, gernot.zechner, hpj, i.semenov.kde, kwilson, mail, marco.dr, nicholsman, plasma-bugs, ron.coit, ruairi.hickey
Priority: NOR    
Version: 4.7.4   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:
Bug Depends on: 178678    
Bug Blocks:    

Description krienke 2012-01-10 09:30:42 UTC
Version:           unspecified (using KDE 4.7.4) 
OS:                Linux

Since KDE 4.7.4 there is a problem with icons on the desktop when using "folder view" instead og KDEs default desktop. All icons on desktop appear as grey gear icons. Before 4.7.4 the icons that appeared on the desktop were the application specific icons.
When I select a icon and show the properties, I see the correct icon in the properties dialog. The desktop icons are after all .desktop files in my Desktop folder I choose to view.

When I change my Desktop from folderview to the default Desktop, I can open dolphin and go to my Desktop folder and then drop the .desktop files on my desktop and they appear correctly. So something seems to be broken with folder view.

Here is an example of one of the .desktop files in my ~/Desktop folder  that appear as a grey gears icons in 2folder view" mode. The icon /export/data/Linux/src/eclipse/icon.xpm is ok and readable:

[Desktop Entry]
Comment[de]=
Comment=
Exec=/export/data/Linux/src/eclipse/eclipse
GenericName[de]=
GenericName=
Icon=/export/data/Linux/src/eclipse/icon.xpm
MimeType=
Name[de]=Eclipse
Name=Eclipse
Path=
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-DBUS-ServiceName=
X-DBUS-StartupType=
X-KDE-SubstituteUID=false
X-KDE-Username=
X-SuSE-translate=true



Reproducible: Didn't try

Steps to Reproduce:
In folder view add a new link to a program

Actual Results:  
An icon appears but it has a grey gears icon

Expected Results:  
The choosen application icon should appear on the desktop
Comment 1 krienke 2012-01-18 12:25:08 UTC
I found out more:

First I installed KDE 4.8 RC on another system also running 12.1 but in contrast to the first computer only with local filesystems (no NFS). On this computer it works as expected. I even  copied this working .desktop files on the system where it did *not* work and here the icons for these desktop files are still displayed as grey gears.

Another symptom of this bug is that the desktop folder selected in plasma settings is displayed using an icon for a regular folder by dolphin allthough it contains a .directory file containing the line "Icon=user-desktop". On a system where the bug is not visible the desktop directory has the same .directory file but dolphin shows a special desktop icon instead of a regular folder icon. 

By playing around a lot and installing several systems the only difference between a system that shows the bug and a working system was, that if the users HOME directory is on a local filesystem everything is ok, but if the users HOME is on a NFS share then the bug is visible. 

Another test I tried also indicated that NFS might be the trigger for this bug. I copied the whole HOME directory of a user on NFS to a local directory that is the HOME directory on the same system. Allthough the user on NFS does not see his desktop icons correctly, the local user does see them correctly allthough all files in his HOME (including all dot files and (dot) directotries)  are identical. The only difference is the filesystem (NFS) they are on.
Comment 2 krienke 2012-01-18 12:32:17 UTC
I found out more:

First I installed KDE 4.8 RC on another system also running 12.1 but in contrast to the first computer only with local filesystems (no NFS). On this computer it works as expected. I even  copied this working .desktop files on the system where it did *not* work and here the icons for these desktop files are still displayed as grey gears.

Another symptom of this bug is that the desktop folder selected in plasma settings is displayed using an icon for a regular folder by dolphin allthough it contains a .directory file containing the line "Icon=user-desktop". On a system where the bug is not visible the desktop directory has the same .directory file but dolphin shows a special desktop icon instead of a regular folder icon. 

By playing around a lot and installing several systems the only difference between a system that shows the bug and a working system was, that if the users HOME directory is on a local filesystem everything is ok, but if the users HOME is on a NFS share then the bug is visible. 

Another test I tried also indicated that NFS might be the trigger for this bug. I copied the whole HOME directory of a user on NFS to a local directory that is the HOME directory on the same system. Allthough the user on NFS does not see his desktop icons correctly, the local user does see them correctly allthough all files in his HOME (including all dot files and (dot) directotries)  are identical. The only difference is the filesystem (NFS) they are on.
Comment 3 krienke 2012-01-26 10:06:30 UTC
This bug is still there in the initial release of KDE 4.8
Comment 4 Kevin Wilson 2012-01-30 21:42:38 UTC
Hello,

I can confirm this bug. I first saw it in KDE 4.7.4 after upgrading from 4.7.3 on Gentoo. Two different machines exhibit the same symptoms: *.desktop files have the default icon for the application/x-desktop filetype and do not seem to override that with their own icon, even if one is selected.

Both of these machines mount user home directories over the network with nfs4, via automount.

The bug indeed is still present in KDE 4.8.0 and in all of the betas and RCs for 4.8.

Please let me know if additional information is desired.
Comment 5 Thomas Boerkel 2012-01-31 12:36:47 UTC
Me too. Booting via PXE -> /home is on NFS. Gentoo, KDE 4.7.4.
Comment 6 Ron Coit 2012-02-08 18:34:01 UTC
I have the same problem with Arch Linux 32bit KDE 4.8.0 PXE boot NFS Root
Comment 7 Ruairi Hickey 2012-03-21 22:55:38 UTC
Also affecting kubuntu 12:04 kde 4.8.1
Comment 8 David Nichols 2012-04-10 08:39:03 UTC
affects fedora 16 with kde 4.8.1 - we have all our home directories in our office mounted over NFS from a SAN and nobody using KDE can see their desktop icons properly presumably due to this bug
Comment 9 David Nichols 2012-04-11 07:51:07 UTC
I can confirm this bug is the cause of our problems - if I copy my Desktop folder to a local directory and symlink to it from $HOME/Desktop - then the icons appear correctly.  Only when the Desktop directory is mounted from the nfs share do I get the gear problem.

Desktop icons created by linking menu items to the desktop still appear correctly even when displaying the nfs-mounted desktop directory; only icons representing local files have this problem.
Comment 10 krienke 2012-05-07 08:44:08 UTC
4.8.3 still has this bug
Comment 11 Christian Schneider 2012-07-27 12:02:41 UTC
In see the exact same problem on my Kubuntu 12.04 machine (KDE 4.8.4) with NFS mounted home.
Comment 12 Jekyll Wu 2012-08-30 13:13:25 UTC
*** Bug 306030 has been marked as a duplicate of this bug. ***
Comment 13 gernot.zechner 2012-08-31 04:51:18 UTC
This bug is still active with kde 4.9.00.
I testes it with Kubuntu 12.04
Comment 14 Hans-Peter Jansen 2012-09-23 00:25:13 UTC
*** This bug has been confirmed by popular vote. ***
Comment 15 Hans-Peter Jansen 2012-10-04 21:01:03 UTC
4.9.2 still suffer from this (openSUSE 12.2/x86_64 with KDE:Release:49 repo).

I wonder how big of a problem is this?
Comment 16 Bob Davis 2012-11-22 17:13:16 UTC
Hi, 

Just thought i would add some feedback, 

I have just been working on an auto-installer for openSUSE 12.2, and this bug is still there.

we use NIS for NFS mounts for users, although i have also tested on our in testing LDAP server with the same results.

The desktop is okay if the NFS home mount is on the same machine, but if the NFS home mount is on a remote machine, i.e. you are not logging in at your "home" machine,  then the icons in the desktop appear as grey cogs.  

I have also experienced some stability issues with KDE on the remote home mounts which we are not present in 11.4 openSUSE or KDE on RHEL 6.3.

 In answer to "I wonder how big of a problem is this?" for me, not really 99% of my users have an NFS mounted home on their main computer but it did bake my noddle while i was testing the build as of course the machine I was testing on is not where my personal user home is.

So I suppose once you know its its a known bug that's fine, however it wasn't until i goggled
 
"home on remote nfs mount grey desktop icons"

That I found this thread .. and Bug

Bob
Comment 17 Ignat Semenov 2012-12-30 15:41:33 UTC

*** This bug has been marked as a duplicate of bug 290666 ***