Bug 291017

Summary: column view forgets preferred icon size after switching view mode
Product: [Applications] dolphin Reporter: reescf
Component: view-engine: columns modeAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: 1.7   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description reescf 2012-01-09 04:32:34 UTC
Version:           1.7 (using KDE 4.7.4) 
OS:                Linux

I prefer to have quite small icons in column mode, which I use most of the time. For the default view, I have them as small as possible. For preview view, I use 22 pixels.

In icon mode, I have larger icons for both views. I use this mode from time to time. Dolphin correctly remembers my preferred sizes and changes sizes when I switch to icon view.

When I switch back to column view, however, it retains the sizes from icon view mode and I must once again configure my preferred sizes for column viewing.

Reproducible: Didn't try

Steps to Reproduce:
1. Choose different preferred sizes for icon view and column view through "Configure Dolphin" under Settings. For example, keep the defaults for icon view but set the smallest possible for "Default" view under column mode and 22 pixels for "Preview" view under column mode.
2. Use column view for a bit.
3. Switch to icon view for a bit.
4. Switch back to column view.

Actual Results:  
Column view icon sizes are not reset to the preferred values. Instead, the preferred values are set to those for icon mode.

Expected Results:  
The configured sizes for column mode should be reapplied when I switch back to column mode just as the configured sizes for icon mode are applied when I switch to icon mode.
Comment 1 reescf 2012-01-09 04:34:02 UTC
It says I didn't try to reproduce but actually this keeps happening. I didn't see the option for that, apparently. It is highly reproducible!
Comment 2 Peter Penz 2012-01-09 08:50:30 UTC

*** This bug has been marked as a duplicate of bug 290747 ***