Bug 287413

Summary: Plasma crashed when resuming from sleep
Product: [Plasma] plasma4 Reporter: Emil Volcheck <volcheck>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: asraniel, corentin.chary
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:
Attachments: New crash information added by DrKonqi

Description Emil Volcheck 2011-11-23 23:25:02 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Laptop awoke from sleep with screen lock.  Entered password and the crash window was already there.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb1e64b20 (LWP 3605))]

Thread 3 (Thread 0xab16eb70 (LWP 3609)):
#0  0xb2f3ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb63257d5 in do_gettime (frac=0xab16e010, sec=0xab16e008) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63f84b6 in QTimerInfoList::updateCurrentTime (this=0xaa801abc) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb63f880a in QTimerInfoList::timerWait (this=0xaa801abc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb63f7053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xab16e11c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb63f70ed in timerSourcePrepare (source=0xaa801a88, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2e7f88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2e80637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2e80c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb63f7b37 in QEventDispatcherGlib::processEvents (this=0xaa800468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63c81dd in QEventLoop::processEvents (this=0xab16e2a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63c8421 in QEventLoop::exec (this=0xab16e2a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62cb90b in QThread::exec (this=0x89db230) at thread/qthread.cpp:498
#14 0xb63a8e2d in QInotifyFileSystemWatcherEngine::run (this=0x89db230) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62ce7b3 in QThreadPrivate::start (arg=0x89db230) at thread/qthread_unix.cpp:331
#16 0xb2f9ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb75aa0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa9695b70 (LWP 3610)):
#0  0xb2f3ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb63257d5 in do_gettime (frac=0xa9695010, sec=0xa9695008) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63f84b6 in QTimerInfoList::updateCurrentTime (this=0xaa801e44) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb63f880a in QTimerInfoList::timerWait (this=0xaa801e44, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb63f7053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa969511c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb63f70ed in timerSourcePrepare (source=0xaa801e10, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb2e7f88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2e80637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2e80c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb63f7b37 in QEventDispatcherGlib::processEvents (this=0x8b0a6e0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb63c81dd in QEventLoop::processEvents (this=0xa96952a0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63c8421 in QEventLoop::exec (this=0xa96952a0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb62cb90b in QThread::exec (this=0x86e9810) at thread/qthread.cpp:498
#14 0xb63a8e2d in QInotifyFileSystemWatcherEngine::run (this=0x86e9810) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb62ce7b3 in QThreadPrivate::start (arg=0x86e9810) at thread/qthread_unix.cpp:331
#16 0xb2f9ad31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb75aa0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb1e64b20 (LWP 3605)):
[KCrash Handler]
#7  0x00000001 in ?? ()
#8  0xb3688426 in ~QExplicitlySharedDataPointer (this=0x94d9424, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qshareddata.h:161
#9  Solid::Device::~Device (this=0x94d9424, __in_chrg=<optimized out>) at ../../../solid/solid/device.cpp:87
#10 0xaa67130a in ~QHashNode (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#11 deleteNode2 (node=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:519
#12 deleteNode (node=<optimized out>, this=0x8e2a684) at /usr/include/qt4/QtCore/qhash.h:507
#13 QHash<QString, Solid::Device>::remove (this=0x8e2a684, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#14 0xaa67146a in remove (akey=..., this=0x8e2a684) at /usr/include/qt4/QtCore/qhash.h:784
#15 HotplugEngine::onDeviceRemoved (this=0x8e2a670, udi=...) at ../../../../../plasma/generic/dataengines/hotplug/hotplugengine.cpp:241
#16 0xaa673b23 in HotplugEngine::qt_metacall (this=0x8e2a670, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff97168) at ./hotplugengine.moc:81
#17 0xb63cfb7d in metacall (argv=0xbff97168, idx=25, cl=QMetaObject::InvokeMetaMethod, object=0x8e2a670) at kernel/qmetaobject.cpp:237
#18 QMetaObject::metacall (object=0x8e2a670, cl=QMetaObject::InvokeMetaMethod, idx=25, argv=0xbff97168) at kernel/qmetaobject.cpp:232
#19 0xb63dea6a in QMetaObject::activate (sender=0x89ecd18, m=0xb373af98, local_signal_index=1, argv=0xbff97168) at kernel/qobject.cpp:3278
#20 0xb3689a65 in Solid::DeviceNotifier::deviceRemoved (this=0x89ecd18, _t1=...) at ./devicenotifier.moc:94
#21 0xb368adb4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (this=0x89ecd18, udi=...) at ../../../solid/solid/devicemanager.cpp:207
#22 0xb368b5b3 in Solid::DeviceManagerPrivate::qt_metacall (this=0x89ecd18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff972e8) at ./devicemanager_p.moc:80
#23 0xb63cfb7d in metacall (argv=0xbff972e8, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x89ecd18) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x89ecd18, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbff972e8) at kernel/qmetaobject.cpp:232
#25 0xb63dea6a in QMetaObject::activate (sender=0x89de008, m=0xb373c06c, local_signal_index=1, argv=0xbff972e8) at kernel/qobject.cpp:3278
#26 0xb36a0cd5 in Solid::Ifaces::DeviceManager::deviceRemoved (this=0x89de008, _t1=...) at ./ifaces/devicemanager.moc:94
#27 0xb36ea548 in slotDeviceRemoved (opath=<optimized out>, this=0x89de008) at ../../../solid/solid/backends/upower/upowermanager.cpp:164
#28 Solid::Backends::UPower::UPowerManager::qt_metacall (this=0x89de008, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff9754c) at ./backends/upower/upowermanager.moc:78
#29 0xb63cfb7d in metacall (argv=0xbff9754c, idx=7, cl=QMetaObject::InvokeMetaMethod, object=0x89de008) at kernel/qmetaobject.cpp:237
#30 QMetaObject::metacall (object=0x89de008, cl=QMetaObject::InvokeMetaMethod, idx=7, argv=0xbff9754c) at kernel/qmetaobject.cpp:232
#31 0xb63dea6a in QMetaObject::activate (sender=0x89de014, m=0x89edc50, local_signal_index=4, argv=0xbff9754c) at kernel/qobject.cpp:3278
#32 0xb6538110 in QDBusInterfacePrivate::metacall (this=0x89de370, c=QMetaObject::InvokeMetaMethod, id=4, argv=0xbff9754c) at qdbusinterface.cpp:278
#33 0xb6522d87 in QDBusConnectionPrivate::deliverCall (this=0x8325f38, object=0x89de014, msg=..., metaTypes=..., slotIdx=-1434425008) at qdbusintegrator.cpp:942
#34 0xb652cc26 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8f15468, object=0x89de014) at qdbusintegrator_p.h:103
#35 0xb63e1b52 in QObject::event (this=0x89de014, e=0x8f15468) at kernel/qobject.cpp:1217
#36 0xb58f4d54 in notify_helper (e=0x8f15468, receiver=0x89de014, this=0x8262600) at kernel/qapplication.cpp:4486
#37 QApplicationPrivate::notify_helper (this=0x8262600, receiver=0x89de014, e=0x8f15468) at kernel/qapplication.cpp:4458
#38 0xb58fa103 in QApplication::notify (this=0x8f15468, receiver=0x89de014, e=0x8f15468) at kernel/qapplication.cpp:3886
#39 0xb6a2e681 in KApplication::notify (this=0x8255508, receiver=0x89de014, event=0x8f15468) at ../../kdeui/kernel/kapplication.cpp:311
#40 0xb63c919e in QCoreApplication::notifyInternal (this=0x8255508, receiver=0x89de014, event=0x8f15468) at kernel/qcoreapplication.cpp:787
#41 0xb63ccf93 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x82142e0) at kernel/qcoreapplication.cpp:1428
#43 0xb63cd0ec in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1321
#44 0xb63f76a4 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#45 postEventSourceDispatch (s=0x8265a80) at kernel/qeventdispatcher_glib.cpp:277
#46 0xb2e8025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0xb2e80990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0xb2e80c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#49 0xb63f7ada in QEventDispatcherGlib::processEvents (this=0x8215218, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#50 0xb59ace3a in QGuiEventDispatcherGlib::processEvents (this=0x8215218, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0xb63c81dd in QEventLoop::processEvents (this=0xbff97be4, flags=...) at kernel/qeventloop.cpp:149
#52 0xb63c8421 in QEventLoop::exec (this=0xbff97be4, flags=...) at kernel/qeventloop.cpp:201
#53 0xb63cd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#54 0xb58f28f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#55 0xb76a618b in kdemain (argc=1, argv=0xbff97de4) at ../../../../plasma/desktop/shell/main.cpp:120
#56 0x0804850b in main (argc=1, argv=0xbff97de4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 286583.

Possible duplicates by query: bug 286583, bug 286434, bug 286318, bug 286237, bug 285340.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-11-24 08:00:14 UTC

*** This bug has been marked as a duplicate of bug 278141 ***
Comment 2 Corentin Chary 2011-12-05 06:12:21 UTC
Created attachment 66386 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:
Resuming the from suspend using the power button.

-- Backtrace (Reduced):
#7  0x00007f5d3e8faee1 in ~QHashNode (this=0x1d854c0, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:216
#8  deleteNode2 (node=0x1d854c0) at /usr/include/qt4/QtCore/qhash.h:519
#9  deleteNode (node=0x1d854c0, this=0x20beeb8) at /usr/include/qt4/QtCore/qhash.h:507
#10 QHash<QString, Solid::Device>::remove (this=0x20beeb8, akey=<optimized out>) at /usr/include/qt4/QtCore/qhash.h:795
#11 0x00007f5d3e8fb03c in remove (akey=..., this=0x20beeb8) at /usr/include/qt4/QtCore/qhash.h:784