Bug 285350

Summary: Pressing Esc on empty workspace opens KRunner with space character
Product: krunner Reporter: Kai Uwe Broulik <kde>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: minor CC: annma, kollix
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 4.8.3

Description Kai Uwe Broulik 2011-10-30 20:10:45 UTC
Version:           unspecified (using KDE 4.7.2) 
OS:                Linux

Since KDE 4.7 krunner automatically opens when pressing any key on an empty workspace.
Pressing Escape however opens KRunner still (which is fine) but it has a space character (or the Escape character not being displayed?) inside.

Reproducible: Always

Steps to Reproduce:
1. On your empty workspace without a window focussed press Escape

Actual Results:  
KRunner opens (which is nice) with a space character in the input field

Expected Results:  
Either KRunner does not open at all because Esc is not an actual "letter", or it opens with an empty field.
Comment 1 Jekyll Wu 2012-01-04 08:54:33 UTC
*** Bug 290565 has been marked as a duplicate of this bug. ***
Comment 2 Anne-Marie Mahfouf 2012-01-04 09:00:35 UTC
Reproducable in 4.8 RC2, the space prevents input to be recognized.
Comment 3 Kai Uwe Broulik 2012-04-07 13:30:54 UTC
Git commit 48d18241a5e89f9055db1c3d0aa3eee3a285336c by Kai Uwe Broulik.
Committed on 07/04/2012 at 15:29.
Pushed by broulik into branch 'master'.

Only printable characters may trigger KRunner, otherwise a white-space character
is introduced and the term you've entered is not recognized.
REVIEW: 104497
FIXED-IN: 4.8.3

M  +3    -1    plasma/desktop/containments/desktop/desktop.cpp

http://commits.kde.org/kde-workspace/48d18241a5e89f9055db1c3d0aa3eee3a285336c
Comment 4 Kai Uwe Broulik 2012-04-07 13:32:50 UTC
Git commit ccbe34ffd038546ebd0f7803c73232e451bb915b by Kai Uwe Broulik.
Committed on 07/04/2012 at 15:29.
Pushed by broulik into branch 'KDE/4.8'.

Only printable characters may trigger KRunner, otherwise a white-space character
is introduced and the term you've entered is not recognized.
REVIEW: 104497
FIXED-IN: 4.8.3
(cherry picked from commit 48d18241a5e89f9055db1c3d0aa3eee3a285336c)

M  +3    -1    plasma/desktop/containments/desktop/desktop.cpp

http://commits.kde.org/kde-workspace/ccbe34ffd038546ebd0f7803c73232e451bb915b
Comment 5 Kai Uwe Broulik 2012-04-07 13:32:54 UTC
Git commit 68c222a1effd446a55556d269be0f8a12fb4f5fa by Kai Uwe Broulik.
Committed on 07/04/2012 at 15:26.
Pushed by broulik into branch 'plasma/sreich/tasks-qml'.

Only printable characters may trigger KRunner, otherwise a white-space is introduced
and the term you've entered is not recognized.
REVIEW: 104497
FIXED-IN: 4.8.3

M  +3    -1    plasma/desktop/containments/desktop/desktop.cpp

http://commits.kde.org/kde-workspace/68c222a1effd446a55556d269be0f8a12fb4f5fa