Bug 282934

Summary: crash on session logout
Product: plasma4 Reporter: Valentin Rusu <valir>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: ht990332
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Valentin Rusu 2011-09-27 21:16:55 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.0.3-41-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was closing my KDE session when crash occurred.
Please note I'm using Qt 4.8

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2dd34c1760 (LWP 29714))]

Thread 3 (Thread 0x7f2dabc25700 (LWP 29715)):
#0  0x00007f2dd181167e in __pthread_mutex_unlock_usercnt (mutex=0x1898248, decr=<value optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007f2dcbff2678 in g_main_context_iteration (context=0x1898240, may_block=<value optimized out>) at gmain.c:3155
#2  0x00007f2dd1c3a104 in QEventDispatcherGlib::processEvents (this=0x16fcce0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#3  0x00007f2dd1bfada6 in QEventLoop::processEvents (this=0x7f2dabc24d80, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f2dd1bfaf30 in QEventLoop::exec (this=0x7f2dabc24d80, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007f2dd1ac7ca1 in QThread::exec (this=0x188a790) at thread/qthread.cpp:501
#6  0x00007f2dd1bd59ac in QInotifyFileSystemWatcherEngine::run (this=0x188a790) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f2dd1aca626 in QThreadPrivate::start (arg=0x188a790) at thread/qthread_unix.cpp:298
#8  0x00007f2dd180da3f in start_thread (arg=0x7f2dabc25700) at pthread_create.c:297
#9  0x00007f2dcfb5a67d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2d9c122700 (LWP 29852)):
#0  0x00007f2dcfb51503 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2dcbff2114 in g_main_context_poll (context=0x1b73a60, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3404
#2  g_main_context_iterate (context=0x1b73a60, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3086
#3  0x00007f2dcbff2650 in g_main_context_iteration (context=0x1b73a60, may_block=1) at gmain.c:3154
#4  0x00007f2dd1c3a104 in QEventDispatcherGlib::processEvents (this=0x1808970, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f2dd1bfada6 in QEventLoop::processEvents (this=0x7f2d9c121db0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f2dd1bfaf30 in QEventLoop::exec (this=0x7f2d9c121db0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f2dd1ac7ca1 in QThread::exec (this=0x1bdf020) at thread/qthread.cpp:501
#8  0x00007f2dc82bfd98 in Plasma::StorageThread::run (this=0x1bdf020) at /home/kde/work/kdelibs/plasma/private/storagethread.cpp:326
#9  0x00007f2dd1aca626 in QThreadPrivate::start (arg=0x1bdf020) at thread/qthread_unix.cpp:298
#10 0x00007f2dd180da3f in start_thread (arg=0x7f2d9c122700) at pthread_create.c:297
#11 0x00007f2dcfb5a67d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2dd34c1760 (LWP 29714)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f2dc823a012 in qDeleteAll<QList<Plasma::Applet*>::const_iterator> (begin=..., end=...) at /home/kde/include/QtCore/qalgorithms.h:322
#8  0x00007f2dc8237839 in qDeleteAll<QList<Plasma::Applet*> > (c=...) at /home/kde/include/QtCore/qalgorithms.h:330
#9  0x00007f2dc82373f6 in Plasma::ContainmentPrivate::~ContainmentPrivate (this=0xcc83d0, __in_chrg=<value optimized out>) at /home/kde/work/kdelibs/plasma/private/containment_p.h:70
#10 0x00007f2dc8226e51 in Plasma::Containment::~Containment (this=0xd6aaf0, __in_chrg=<value optimized out>) at /home/kde/work/kdelibs/plasma/containment.cpp:148
#11 0x00007f2db7007c9a in Panel::~Panel (this=0xd6aaf0, __in_chrg=<value optimized out>) at /home/kde/src/kde-workspace/plasma/desktop/containments/panel/panel.cpp:127
#12 0x00007f2db7007cd8 in Panel::~Panel (this=0xd6aaf0, __in_chrg=<value optimized out>) at /home/kde/src/kde-workspace/plasma/desktop/containments/panel/panel.cpp:129
#13 0x00007f2dc824a255 in qDeleteAll<QList<Plasma::Containment*>::const_iterator> (begin=..., end=...) at /home/kde/include/QtCore/qalgorithms.h:322
#14 0x00007f2dc8248370 in qDeleteAll<QList<Plasma::Containment*> > (c=...) at /home/kde/include/QtCore/qalgorithms.h:330
#15 0x00007f2dc824445a in Plasma::CoronaPrivate::~CoronaPrivate (this=0x6f9f80, __in_chrg=<value optimized out>) at /home/kde/work/kdelibs/plasma/corona.cpp:805
#16 0x00007f2dc8241065 in Plasma::Corona::~Corona (this=0x857b20, __in_chrg=<value optimized out>) at /home/kde/work/kdelibs/plasma/corona.cpp:82
#17 0x00007f2dbef695d6 in DesktopCorona::~DesktopCorona (this=0x857b20, __in_chrg=<value optimized out>) at /home/kde/src/kde-workspace/plasma/desktop/shell/desktopcorona.cpp:70
#18 0x00007f2dbef69608 in DesktopCorona::~DesktopCorona (this=0x857b20, __in_chrg=<value optimized out>) at /home/kde/src/kde-workspace/plasma/desktop/shell/desktopcorona.cpp:73
#19 0x00007f2dbef9544f in PlasmaApp::cleanup (this=0x6d99e0) at /home/kde/src/kde-workspace/plasma/desktop/shell/plasmaapp.cpp:381
#20 0x00007f2dbef9c39e in PlasmaApp::qt_static_metacall (_o=0x6d99e0, _c=QMetaObject::InvokeMetaMethod, _id=15, _a=0x7fffe35c5c60) at /home/kde/src/superbuild/kdebase/build/Build/kde-workspace/plasma/desktop/shell/plasmaapp.moc:120
#21 0x00007f2dd1c1bcb7 in QMetaObject::activate (sender=0x6d99e0, m=0x7f2dd1faf700, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3546
#22 0x00007f2dd1c7daff in QCoreApplication::aboutToQuit (this=0x6d99e0) at .moc/debug-shared/moc_qcoreapplication.cpp:145
#23 0x00007f2dd1bfdc27 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1153
#24 0x00007f2dd0a34524 in QApplication::exec () at kernel/qapplication.cpp:3779
#25 0x00007f2dbef7987c in kdemain (argc=1, argv=0x68e5e0) at /home/kde/src/kde-workspace/plasma/desktop/shell/main.cpp:120
#26 0x00000000004073d5 in launch (argc=1, _name=0x682808 "/home/kde/bin/plasma-desktop", args=0x682825 "", cwd=0x0, envc=0, envs=0x68282d "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40d8dd "0") at /home/kde/work/kdelibs/kinit/kinit.cpp:734
#27 0x000000000040850b in handle_launcher_request (sock=8, who=0x40db74 "launcher") at /home/kde/work/kdelibs/kinit/kinit.cpp:1226
#28 0x0000000000408dbf in handle_requests (waitForPid=0) at /home/kde/work/kdelibs/kinit/kinit.cpp:1419
#29 0x000000000040a8a7 in main (argc=4, argv=0x7fffe35c6bd8, envp=0x7fffe35c6c00) at /home/kde/work/kdelibs/kinit/kinit.cpp:1907

Possible duplicates by query: bug 259639, bug 258867.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-26 14:58:50 UTC

*** This bug has been marked as a duplicate of bug 284989 ***