Bug 280747

Summary: Plasma crashed while quitting KAlarm.
Product: plasma4 Reporter: Roland <bugs.kde.org>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Roland 2011-08-24 23:11:29 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I right clicked on the KAlarm icon and chose quit.  A dialog opened up and asked me to confirm.  I chose yes (don't ask again) but the icon remained in the system tray.  I right clicked on it again and Plasma crashed.  I'm not sure if the second right click had any effect or if it was just taking a while to crash.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb714c3b7c0 (LWP 3712))]

Thread 4 (Thread 0x7fb6f7c1c700 (LWP 3713)):
#0  0x00007fb71452ff03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb708f12104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb708f12639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb71173e446 in QEventDispatcherGlib::processEvents (this=0x12f2510, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fb711712882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb711712abc in QEventLoop::exec (this=0x7fb6f7c1bcd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fb711629924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fb7116f4c2f in QInotifyFileSystemWatcherEngine::run (this=0x12f1120) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb71162c175 in QThreadPrivate::start (arg=0x12f1120) at thread/qthread_unix.cpp:320
#9  0x00007fb706f97853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007fb709815d8c in start_thread (arg=0x7fb6f7c1c700) at pthread_create.c:304
#11 0x00007fb71453d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb6f49c2700 (LWP 3715)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fb6f49c19e0 in ?? ()
#2  0x00007fffc2dff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7fb6e8f59700 (LWP 3720)):
#0  0x00007fb708f11f19 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb708f129f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb6ea070c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#3  0x00007fb708f393e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb706f97853 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#5  0x00007fb709815d8c in start_thread (arg=0x7fb6e8f59700) at pthread_create.c:304
#6  0x00007fb71453d04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb714c3b7c0 (LWP 3712)):
[KCrash Handler]
#6  0x00007fb7123725df in QString (this=0x1b40075, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x1b40075, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007fb712377feb in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007fb71237ed03 in KIconLoader::loadIcon (this=0x1a14be0, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007fb712376c99 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007fb710b7ddd5 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007fb71411f099 in Plasma::IconWidgetPrivate::decoration (this=0x1b1cc30, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007fb714124e51 in Plasma::IconWidget::paint (this=0x1b138d0, painter=0x7fffc2d447c0, option=0xe242b8, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007fb6f9b683e9 in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#15 0x00007fb7110c419d in _q_paintItem (item=<value optimized out>, painter=0x7fffc2d447c0, option=0xe242b8, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007fb7110c44b0 in _q_paintIntoCache (pix=0x7fffc2d44cf0, item=0x1b138e0, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0xe242b8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007fb7110d7ce8 in QGraphicsScenePrivate::drawItemHelper (this=0xe24090, item=0x1b138e0, painter=0x7fffc2d46d00, option=0xe242b8, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#18 0x00007fb7110d88ba in QGraphicsScenePrivate::draw (this=0xe24090, item=0x1b138e0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, transformPtr=0x7fffc2d453b0, exposedRegion=0x13e9180, widget=0x17936f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#19 0x00007fb7110d9565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xe24090, item=0x1b138e0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, exposedRegion=0x13e9180, widget=0x17936f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007fb7110d8730 in QGraphicsScenePrivate::draw (this=0xe24090, item=0x109ead0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, transformPtr=0x7fffc2d459b0, exposedRegion=0x13e9180, widget=0x17936f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#21 0x00007fb7110d9565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xe24090, item=0x109ead0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, exposedRegion=0x13e9180, widget=0x17936f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007fb7110d8730 in QGraphicsScenePrivate::draw (this=0xe24090, item=0x10658f0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, transformPtr=0x7fffc2d45fb0, exposedRegion=0x13e9180, widget=0x17936f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#23 0x00007fb7110d9565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xe24090, item=0x10658f0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, exposedRegion=0x13e9180, widget=0x17936f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007fb7110d8730 in QGraphicsScenePrivate::draw (this=0xe24090, item=0xf56cc0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, transformPtr=0x7fffc2d465b0, exposedRegion=0x13e9180, widget=0x17936f0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#25 0x00007fb7110d9565 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0xe24090, item=0xf56cc0, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, exposedRegion=0x13e9180, widget=0x17936f0, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007fb7110d9d94 in QGraphicsScenePrivate::drawItems (this=0xe24090, painter=0x7fffc2d46d00, viewTransform=0x7fffc2d46a90, exposedRegion=0x13e9180, widget=0x17936f0) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007fb7110f6bd2 in QGraphicsView::paintEvent (this=<value optimized out>, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007fb710b25c6a in QWidget::event (this=0x12fe860, event=0x7fffc2d47620) at kernel/qwidget.cpp:8405
#29 0x00007fb710ed5a66 in QFrame::event (this=0x12fe860, e=0x7fffc2d47620) at widgets/qframe.cpp:557
#30 0x00007fb7110f7e8b in QGraphicsView::viewportEvent (this=0x12fe860, event=0x7fffc2d47620) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007fb711713627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x17936f0, event=0x7fffc2d47620) at kernel/qcoreapplication.cpp:846
#32 0x00007fb710ad49b1 in QApplicationPrivate::notify_helper (this=0xe1cc20, receiver=0x17936f0, e=0x7fffc2d47620) at kernel/qapplication.cpp:4458
#33 0x00007fb710ad93aa in QApplication::notify (this=<value optimized out>, receiver=0x17936f0, e=0x7fffc2d47620) at kernel/qapplication.cpp:4341
#34 0x00007fb7123cb866 in KApplication::notify (this=0xde9f50, receiver=0x17936f0, event=0x7fffc2d47620) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007fb71171349c in QCoreApplication::notifyInternal (this=0xde9f50, receiver=0x17936f0, event=0x7fffc2d47620) at kernel/qcoreapplication.cpp:731
#36 0x00007fb710b22abd in sendSpontaneousEvent (this=0x177ec10, pdev=0x178c5d8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1407050) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x177ec10, pdev=0x178c5d8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1407050) at kernel/qwidget.cpp:5492
#38 0x00007fb710b236d2 in QWidgetPrivate::paintSiblingsRecursive (this=0x13e8cf0, pdev=0x178c5d8, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1407050) at kernel/qwidget.cpp:5699
#39 0x00007fb710b2358a in QWidgetPrivate::paintSiblingsRecursive (this=0x13e8cf0, pdev=0x178c5d8, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x1407050) at kernel/qwidget.cpp:5686
#40 0x00007fb710b227fc in QWidgetPrivate::drawWidget (this=0x13e8cf0, pdev=0x178c5d8, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x1407050) at kernel/qwidget.cpp:5545
#41 0x00007fb710ce72fb in QWidgetBackingStore::sync (this=0x1407050) at painting/qbackingstore.cpp:1333
#42 0x00007fb710b18f50 in QWidgetPrivate::syncBackingStore (this=0x13e8cf0) at kernel/qwidget.cpp:1842
#43 0x00007fb710b26184 in QWidget::event (this=0x12fe860, event=0x1a14be0) at kernel/qwidget.cpp:8552
#44 0x00007fb710ed5a66 in QFrame::event (this=0x12fe860, e=0x1a14be0) at widgets/qframe.cpp:557
#45 0x00007fb710f571fb in QAbstractScrollArea::event (this=0x12fe860, e=0x1a14be0) at widgets/qabstractscrollarea.cpp:996
#46 0x00007fb71482efe6 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#47 0x00007fb710ad49e4 in QApplicationPrivate::notify_helper (this=0xe1cc20, receiver=0x12fe860, e=0x1a14be0) at kernel/qapplication.cpp:4462
#48 0x00007fb710ad93aa in QApplication::notify (this=<value optimized out>, receiver=0x12fe860, e=0x1a14be0) at kernel/qapplication.cpp:4341
#49 0x00007fb7123cb866 in KApplication::notify (this=0xde9f50, receiver=0x12fe860, event=0x1a14be0) at ../../kdeui/kernel/kapplication.cpp:311
#50 0x00007fb71171349c in QCoreApplication::notifyInternal (this=0xde9f50, receiver=0x12fe860, event=0x1a14be0) at kernel/qcoreapplication.cpp:731
#51 0x00007fb711716c25 in sendEvent (receiver=0x12fe860, event_type=77, data=0xd5ab60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x12fe860, event_type=77, data=0xd5ab60) at kernel/qcoreapplication.cpp:1372
#53 0x00007fb7110d088a in dispatchPendingUpdateRequests (this=0xe24090) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#54 QGraphicsScenePrivate::_q_processDirtyItems (this=0xe24090) at graphicsview/qgraphicsscene.cpp:510
#55 0x00007fb7110d0caa in QGraphicsScene::qt_metacall (this=0xe1c1c0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x1cd0bb0) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#56 0x00007fb714072b65 in Plasma::Corona::qt_metacall (this=0xe1c1c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x1cd0bb0) at ./corona.moc:109
#57 0x00007fb714823065 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#58 0x00007fb71172749a in QObject::event (this=0xe1c1c0, e=<value optimized out>) at kernel/qobject.cpp:1226
#59 0x00007fb7110dd58b in QGraphicsScene::event (this=0xe1c1c0, event=0x1b436f0) at graphicsview/qgraphicsscene.cpp:3544
#60 0x00007fb710ad49e4 in QApplicationPrivate::notify_helper (this=0xe1cc20, receiver=0xe1c1c0, e=0x1b436f0) at kernel/qapplication.cpp:4462
#61 0x00007fb710ad93aa in QApplication::notify (this=<value optimized out>, receiver=0xe1c1c0, e=0x1b436f0) at kernel/qapplication.cpp:4341
#62 0x00007fb7123cb866 in KApplication::notify (this=0xde9f50, receiver=0xe1c1c0, event=0x1b436f0) at ../../kdeui/kernel/kapplication.cpp:311
#63 0x00007fb71171349c in QCoreApplication::notifyInternal (this=0xde9f50, receiver=0xe1c1c0, event=0x1b436f0) at kernel/qcoreapplication.cpp:731
#64 0x00007fb711716c25 in sendEvent (receiver=0x0, event_type=0, data=0xd5ab60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#65 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xd5ab60) at kernel/qcoreapplication.cpp:1372
#66 0x00007fb71173e253 in sendPostedEvents (s=0xe1f5c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#67 postEventSourceDispatch (s=0xe1f5c0) at kernel/qeventdispatcher_glib.cpp:277
#68 0x00007fb708f11bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#69 0x00007fb708f123a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#70 0x00007fb708f12639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#71 0x00007fb71173e3ef in QEventDispatcherGlib::processEvents (this=0xd5a340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#72 0x00007fb710b7bdfe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#73 0x00007fb711712882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#74 0x00007fb711712abc in QEventLoop::exec (this=0x7fffc2d49780, flags=...) at kernel/qeventloop.cpp:201
#75 0x00007fb711716ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#76 0x00007fb714829897 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#77 0x00007fb714475eff in __libc_start_main (main=0x400740 <_start+256>, argc=1, ubp_av=0x7fffc2d49b48, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffc2d49b38) at libc-start.c:226
#78 0x0000000000400669 in _start ()

Possible duplicates by query: bug 280548, bug 280233, bug 279930, bug 279925, bug 279921.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-30 22:51:04 UTC

*** This bug has been marked as a duplicate of bug 258706 ***