Bug 280318

Summary: phonon-gst equalizer doesn't provide descriptive labels in Phonon::EffectParameter::name() anymore
Product: phonon-backend-gstreamer Reporter: Corrado Mella <corrado.mella>
Component: generalAssignee: Harald Sitter <sitter>
Status: CLOSED UNMAINTAINED    
Severity: normal CC: b.gedzior, dev.dliw, germano.massullo, hein, jss, kde, matej, myriam, romain.perier, sam, tdfischer, thatwaschrislee, victor.conti79, vorpal, zmogas
Priority: NOR    
Version: 4.6.2   
Target Milestone: 4.7   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: Equalizer window snapshot

Description Corrado Mella 2011-08-18 08:53:15 UTC
Created attachment 62929 [details]
Equalizer window snapshot

Version:           2.4.0 (using KDE 4.4.6) 
OS:                Linux

The equalizer frequencies and gain labels are missing (labels are replaced with N/A).
Translation problem?
My system locale is English GB.

Reproducible: Always

Steps to Reproduce:
Open [Tools] - [Equalizer]

Actual Results:  
Equalizer misses the frequencies labels.

Expected Results:  
Some numbers appearing ???

OS: Linux (i686) release 2.6.39-020639rc6-generic
Compiler: cc
Comment 1 Myriam Schweingruber 2011-08-18 19:57:49 UTC
Could you please upgrade to Amarok 2.4.3 and see if this still happens?
Comment 2 Myriam Schweingruber 2011-09-13 10:59:36 UTC
Closing for lack of feedback. Feel free to reopen this report if you can provide the necessary information.
Comment 3 Kai Uwe Broulik 2011-09-16 11:38:30 UTC
Please reopen this. I am experiencing this bug with Amarok 2.4.3 on KDE 4.7.0
Comment 4 Sam Lade 2011-09-16 11:41:07 UTC
Confirm that this is still occurring with latest Amarok git.
Comment 5 Corrado Mella 2012-02-02 13:44:03 UTC
(In reply to comment #1)
> Could you please upgrade to Amarok 2.4.3 and see if this still happens?

No, I can't. This is the version that comes with my distro (Kubuntu 11.10), and it's what is in the repo.

If there's a bugfix please backport.
Comment 6 Kai Uwe Broulik 2012-02-02 14:02:36 UTC
Still valid in 2.5.0 on Kubuntu 12.04
Comment 7 dev.dliw 2012-05-10 13:35:27 UTC
I can confirm this bug with amarok 2.5.0, too.

(openSUSE 12.1; KDE 4.8.3)
Comment 8 Valdas 2012-05-20 18:19:29 UTC
My locale is LT and I also see this "N/A" label.
Comment 9 Myriam Schweingruber 2012-09-28 18:50:56 UTC
*** Bug 307523 has been marked as a duplicate of this bug. ***
Comment 10 chris lee 2012-11-16 04:06:56 UTC
Like to confirm this is happened to me too.

Amarok
Version 2.4.3
Using KDE 4.7.4 (4.7.4)
Comment 11 Matěj Laitl 2012-11-16 14:50:49 UTC
Git commit 1684e855bac3769728d6cc9f3d38b81a47b250c6 by Matěj Laitl.
Committed on 16/11/2012 at 15:02.
Pushed by laitl into branch 'master'.

EngineController: fall-back to Phonon's equalizer band names on parse error

We used to parse equalizer band names as returned by phonon, but it
seems that at least some phonon backeds now just return "band0",
"band1" etc. Fallback to phonon names to expose the bug and let
Phonomials do something with it.

Note that there's one unrelated bug: Amarok doesn't recognise phonon
equalizer doesn't support pre-amplifier and misaligns labels by one.

M  +2    -6    src/EngineController.cpp

http://commits.kde.org/amarok/1684e855bac3769728d6cc9f3d38b81a47b250c6
Comment 12 Matěj Laitl 2012-11-16 14:55:28 UTC
Reassigning to phonon-gstreamer.

Phonomials, this is how to reproduce:
1. Use Amarok git 1684e855bac3769728d6cc9f3d38 or later
2. Use phonon-gst backend
3. Open Amarok equalizer, see non-descriptive band names.

See above commit for evidence we use the phonon names, also for notes about unrelated bug.
Comment 13 Harald Sitter 2013-11-12 23:41:08 UTC
IIRC pgst needs a string mapping... gstreamer actually calls the properties band1,2,3... the actualy frequency must be manually mapped to each band (frequencies as per gst equalizer element documentation).

As for the missing pre-amp... gst's equalizer has no built in pre-amp so I think we concluded on IRC that a volume elements needs to become part of the equalizer bin. Until pgst grows support for it you can check for a property "pre-amp" if it is not present then there is no pre-amp. IIRC you actually already have code that assumes that pre-amp always must be called pre-amp which is why pvlc adopted that scheme [1].

http://quickgit.kde.org/?p=phonon-vlc.git&a=blob&h=47d171a773282f73d1034d986a43e77d95d5eb27&hb=d8615e73a1ac9b5d7c744966f3653311334f7e32&f=src%2Fequalizereffect.cpp
Comment 14 Myriam Schweingruber 2014-08-10 09:40:28 UTC
Since this is not about the same libraires that are current now, I close this report. Please open a new one for phonon-backend-gstreamer 4.7.2 or later, using the gstreamer 1.x libraires and plugins if this still applies.
Comment 15 John 2015-02-24 10:46:52 UTC
For at least 3 1/2 years, the amarok gstreamer equalizer has had no proper frequency values on the sliders, and Myriam can't even run Amarok, and open the equalizer to see if the bug has been fixed. But she can close a perfectly valid bug.

Great work.
Comment 16 John 2015-02-24 11:44:04 UTC
The problem here is this:
  gstreamer stores "bandX" in the "name" field for each of the bands
  gstreamer stores the frequency in the "nick" (nickname) field
  phonon EffectParameter doesn't provide access to nickname field, but does give access to "name"
  amarok uses phonon EffectParameter to fill in the frequency values using the "name" field.
So amarok labels the bands "band0" to "band9"

To fix this, the followign needs to happen:
1) modify Phonon EffectParameter so it can also return the "nick" field
2) modify amarok to label bands using "nick" field, instead of "name" field.

THIS IS TRIVIAL TO FIX, THERE IS NO EXCUSE FOR LEAVING THIS UNIMPLEMENTED FOR NEARLY 3 YEARS.
Comment 17 Harald Sitter 2015-02-24 11:50:31 UTC
PATCHES WELCOME.
Comment 18 John 2015-02-24 11:54:43 UTC
(In reply to Harald Sitter from comment #17)
> PATCHES WELCOME.

I'm not a "senior software engineer working on Phonon", so how can I possibly be qualified to submit a humble patch?
Comment 19 John 2015-02-24 11:58:54 UTC
I love you Harald.

In bug https://bugs.kde.org/show_bug.cgi?id=311193 you refuse to contemplate a fix in Amarok, saying it has to be done in the gstreamer backend. Thus you block the bug from being fixed for years.

Here, all we need is a trivial enhancement to Phonon, and you're a "senior software engineer working on Phonon", but you can't get off your ass and fix it.

Great work buddy.
Comment 20 Harald Sitter 2015-02-24 12:00:50 UTC
pay me and I'll fix it. otherwise STFU
Comment 21 John 2015-02-24 12:05:49 UTC
(In reply to Harald Sitter from comment #20)
> pay me and I'll fix it. otherwise STFU

Oh, sorry, I didn't realise, KDE.org was holding Amarok users to ransom for fixing important, but easily fixed bugs.

I'll get a KickStarter up and running ASAP.

How much you want to fix this? $1000? $10,000?
Name your price.
Comment 22 Myriam Schweingruber 2015-02-24 12:39:51 UTC
(In reply to John from comment #21)
> (In reply to Harald Sitter from comment #20)
> > pay me and I'll fix it. otherwise STFU
> 
> Oh, sorry, I didn't realise, KDE.org was holding Amarok users to ransom for
> fixing important, but easily fixed bugs.
> 
> I'll get a KickStarter up and running ASAP.
> 
> How much you want to fix this? $1000? $10,000?
> Name your price.

John, what you don't realize is the following: you get this software for free, we do it for free in our spare time and we all have a full time job that does NOT include Phonon or Amarok. So unless you have money to spare AND time or a developer at hand who has time, please stay polite or do as Harald already suggested.

Free Software comes with absolutely ZERO obligation from the developers to scratch other people's itches.

And next time you think you have to insult people without even the slightest idea what you are talking about: read again exactly what I said when I closed this bug, I never said it was fixed, I closed this because the version is totally outdated and based on old gstreamer 0.10.x libraries, and we do NOT work on this branch anymore, since quite some time! Closed!
Comment 23 Germano Massullo 2015-02-24 12:47:26 UTC
Bugreport cloned to a newer Phonon-backend version 
https://bugs.kde.org/show_bug.cgi?id=344526
Comment 24 John 2015-02-24 13:03:20 UTC
Myriam, what you don't understand, is that you have demonstrated a pathological inability to understand the simplest things that people say to you.

You closed this bug in 2011, saying the reporter should test a new Amarok, and see if the bug is still there. Are you incapable of running Amarok yourself and opening the equalizer, to see for yourself that it was still there in 2011, and is still there now, in 2015?

And then, after it was reopened you closed it again in 2014, and your excuse for that is that the bug is about old gstreamer libraries!

The bug is NOTHING TO DO WITH GSTREAMER. Where is gstreamer mentioned in the title of this bug? Nowhere. The bug is about a problem with the functionality of Amarok. 

Now you can blame it on the gstreamer libraries, and ignore the bug for years, and then, of course, the gstreamer libraries will change. That has nothing to do with this bug. 

The original problem, which this bug was created to track, WHATEVER THE UNDERLYING CAUSE, is, that the equalizer has no frequency values on the bands. That is still the case, nothing has changed, in this respect, in the 3 1/2 years since this bug was created.

And now you're lecturing me about getting the software for free, and the developers have no obligation to fix things! Developers develop, and fix things. THATS WHAT THEY DO. And this is a bugreport in a bugtracker. This bugreport is here to track bugs. 

THE KDE BUGTRACKER IS NOT A FORUM FOR DEVELOPERS TO ABUSE, BLACKMAIL, and IGNORE USERS WHO REPORT BUGS.

I understand things perfectly Myruiam. If developers don't have time to fix a low priority bug, then fine. They don't fix it. AND IF THEY DOINT FIX IT, THE BUG STAYS OPEN, until it is fixed, or no longer relevant.

THIS BUG IS STILL PRESENT. IT IS STILL RELEVANT.

IT WAS NOT YOUR JOB TO CLOSE THIS BUG, HOWEVER, SEEING AS YOU DID SO, IT IS YOUR JOB TO REOPEN THIS BUG, even if you do nothing to fix it.
Comment 25 John 2015-02-24 13:06:02 UTC
(In reply to Germano Massullo from comment #23)
> Bugreport cloned to a newer Phonon-backend version 
> https://bugs.kde.org/show_bug.cgi?id=344526

Thanks Germano.
Comment 26 John 2015-02-24 13:09:51 UTC
(In reply to John from comment #24)

Ok ignore what i said about this bug not having anything to do with gstreamer. I started writing most of that ranty comment thinking of bug https://bugs.kde.org/show_bug.cgi?id=311193

Nevertheless, Myriam. Your attitude is appalling, and your incompetence is staggering.
Comment 27 Eike Hein 2015-02-24 13:22:58 UTC
John, your behavior here is unacceptable even if you're acting agitated out of frustration. Please read https://www.kde.org/code-of-conduct/ and take it to heart, or I will disable your Bugzilla account.
Comment 28 bartek 2015-02-24 20:59:01 UTC
For my point of view reason to close this bug is correct. Phonon moves to newer gstreamer, so lets fix it for new gstreamer - it's logic. However, taking into consideration complexity of amarok and KDE as a whole it's strange why such a bug is still present. By the time it's fixed I'll stay with Clementine. Sorry Amarok, you're not superior to it...