Bug 280233

Summary: closing amarok music player
Product: plasma4 Reporter: David <timlighty>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, dlfroe
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description David 2011-08-17 02:06:33 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

closing Amarok Music Player and the plasma shell crashed.  it happens occasionally.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78bead0 (LWP 1252))]

Thread 3 (Thread 0xb56a4b70 (LWP 1253)):
#0  0x001ee5e1 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0x01d15752 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01d1603a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01d16524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x025c0577 in QEventDispatcherGlib::processEvents (this=0x8954300, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x02592289 in QEventLoop::processEvents (this=0xb56a4280, flags=...) at kernel/qeventloop.cpp:149
#6  0x02592522 in QEventLoop::exec (this=0xb56a4280, flags=...) at kernel/qeventloop.cpp:201
#7  0x0249c2a0 in QThread::exec (this=0x87afd28) at thread/qthread.cpp:492
#8  0x02573fdb in QInotifyFileSystemWatcherEngine::run (this=0x87afd28) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0249eda2 in QThreadPrivate::start (arg=0x87afd28) at thread/qthread_unix.cpp:320
#10 0x01cc1e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xae65ab70 (LWP 1255)):
#0  0x001ee651 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x01d15648 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01d1603a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01d16524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x025c0577 in QEventDispatcherGlib::processEvents (this=0x88bac38, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x02592289 in QEventLoop::processEvents (this=0xae65a280, flags=...) at kernel/qeventloop.cpp:149
#6  0x02592522 in QEventLoop::exec (this=0xae65a280, flags=...) at kernel/qeventloop.cpp:201
#7  0x0249c2a0 in QThread::exec (this=0x88b9538) at thread/qthread.cpp:492
#8  0x02573fdb in QInotifyFileSystemWatcherEngine::run (this=0x88b9538) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0249eda2 in QThreadPrivate::start (arg=0x88b9538) at thread/qthread_unix.cpp:320
#10 0x01cc1e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x001e073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb78bead0 (LWP 1252)):
[KCrash Handler]
#7  0x01170454 in QString (this=0x92c0061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x92c0061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01176352 in KIconLoaderPrivate::makeCacheKey (this=0x92c004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x0117d398 in KIconLoader::loadIcon (this=0x9264dc8, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x01174d76 in KIconEngine::pixmap (this=0x93661e8, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0x03929712 in QIcon::pixmap (this=0x9263de4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0x009dd969 in Plasma::IconWidgetPrivate::decoration (this=0x9263d40, option=0x859ca70, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#14 0x009e421d in Plasma::IconWidget::paint (this=0x9265200, painter=0xbfd5ce6c, option=0x859ca70, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1128
#15 0x030880dd in ?? () from /usr/lib/kde4/plasma_applet_systemtray.so
#16 0x03ed247c in _q_paintItem (item=<value optimized out>, painter=0x859ca70, option=0x859ca70, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0x03ed2782 in _q_paintIntoCache (pix=0xbfd5d33c, item=0x9265208, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x859ca70, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#18 0x03ee6490 in QGraphicsScenePrivate::drawItemHelper (this=0x859c920, item=0x9265208, painter=0xbfd5eb24, option=0x859ca70, widget=0x8e35140, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0x03ee7152 in QGraphicsScenePrivate::draw (this=0x859c920, item=0x9265208, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, transformPtr=0xbfd5d720, exposedRegion=0x8fe2818, widget=0x8e35140, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0x03ee7e92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859c920, item=0x9265208, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, exposedRegion=0x8fe2818, widget=0x8e35140, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0x03ee6f7c in QGraphicsScenePrivate::draw (this=0x859c920, item=0x8703e68, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, transformPtr=0xbfd5dbc0, exposedRegion=0x8fe2818, widget=0x8e35140, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0x03ee7e92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859c920, item=0x8703e68, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, exposedRegion=0x8fe2818, widget=0x8e35140, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0x03ee6f7c in QGraphicsScenePrivate::draw (this=0x859c920, item=0x86d2d98, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, transformPtr=0xbfd5e060, exposedRegion=0x8fe2818, widget=0x8e35140, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0x03ee7e92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859c920, item=0x86d2d98, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, exposedRegion=0x8fe2818, widget=0x8e35140, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0x03ee6f7c in QGraphicsScenePrivate::draw (this=0x859c920, item=0x86256f8, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, transformPtr=0xbfd5e500, exposedRegion=0x8fe2818, widget=0x8e35140, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0x03ee7e92 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x859c920, item=0x86256f8, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, exposedRegion=0x8fe2818, widget=0x8e35140, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0x03ee8696 in QGraphicsScenePrivate::drawItems (this=0x859c920, painter=0xbfd5eb24, viewTransform=0xbfd5e90c, exposedRegion=0x8fe2818, widget=0x8e35140) at graphicsview/qgraphicsscene.cpp:4735
#28 0x03f07931 in QGraphicsView::paintEvent (this=0x8fe0f30, event=0xbfd5f234) at graphicsview/qgraphicsview.cpp:3469
#29 0x002ae484 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#30 0x038c918e in QWidget::event (this=0x8fe0f30, event=0xbfd5f234) at kernel/qwidget.cpp:8405
#31 0x03cbd9f3 in QFrame::event (this=0x8fe0f30, e=0xbfd5f234) at widgets/qframe.cpp:557
#32 0x03d4c062 in QAbstractScrollArea::viewportEvent (this=0x8fe0f30, e=0xbfd5f234) at widgets/qabstractscrollarea.cpp:1043
#33 0x03f08dff in QGraphicsView::viewportEvent (this=0x8fe0f30, event=0xbfd5f234) at graphicsview/qgraphicsview.cpp:2864
#34 0x03d4e965 in viewportEvent (this=0x8fb21d0, o=0x8e35140, e=0xbfd5f234) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x8fb21d0, o=0x8e35140, e=0xbfd5f234) at widgets/qabstractscrollarea_p.h:116
#36 0x0259325a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x84f4408, receiver=0x8e35140, event=0xbfd5f234) at kernel/qcoreapplication.cpp:846
#37 0x03870d00 in QApplicationPrivate::notify_helper (this=0x84f4408, receiver=0x8e35140, e=0xbfd5f234) at kernel/qapplication.cpp:4458
#38 0x0387597b in QApplication::notify (this=0x84eb760, receiver=0x8e35140, e=0xbfd5f234) at kernel/qapplication.cpp:4427
#39 0x011cf3ca in KApplication::notify (this=0x84eb760, receiver=0x8e35140, event=0xbfd5f234) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x025930bb in QCoreApplication::notifyInternal (this=0x84eb760, receiver=0x8e35140, event=0xbfd5f234) at kernel/qcoreapplication.cpp:731
#41 0x038c5f0c in sendSpontaneousEvent (this=0x89ecab0, pdev=0x8e45f5c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8d00f60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x89ecab0, pdev=0x8e45f5c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8d00f60) at kernel/qwidget.cpp:5492
#43 0x038c6b7c in QWidgetPrivate::paintSiblingsRecursive (this=0x8fe24c8, pdev=0x8e45f5c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8d00f60) at kernel/qwidget.cpp:5699
#44 0x038c6a42 in QWidgetPrivate::paintSiblingsRecursive (this=0x8fe24c8, pdev=0x8e45f5c, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8d00f60) at kernel/qwidget.cpp:5686
#45 0x038c5c80 in QWidgetPrivate::drawWidget (this=0x8fe24c8, pdev=0x8e45f5c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8d00f60) at kernel/qwidget.cpp:5545
#46 0x03aa4398 in QWidgetBackingStore::sync (this=0x8d00f60) at painting/qbackingstore.cpp:1333
#47 0x038bb843 in QWidgetPrivate::syncBackingStore (this=0x8fe24c8) at kernel/qwidget.cpp:1842
#48 0x038c97e5 in QWidget::event (this=0x8fe0f30, event=0x9264dc8) at kernel/qwidget.cpp:8552
#49 0x03cbd9f3 in QFrame::event (this=0x8fe0f30, e=0x9264dc8) at widgets/qframe.cpp:557
#50 0x03d4ddcf in QAbstractScrollArea::event (this=0x8fe0f30, e=0x9264dc8) at widgets/qabstractscrollarea.cpp:996
#51 0x03efc116 in QGraphicsView::event (this=0x8fe0f30, event=0x9264dc8) at graphicsview/qgraphicsview.cpp:2741
#52 0x002ae7c3 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#53 0x03870d24 in QApplicationPrivate::notify_helper (this=0x84f4408, receiver=0x8fe0f30, e=0x9264dc8) at kernel/qapplication.cpp:4462
#54 0x0387597b in QApplication::notify (this=0x84eb760, receiver=0x8fe0f30, e=0x9264dc8) at kernel/qapplication.cpp:4427
#55 0x011cf3ca in KApplication::notify (this=0x84eb760, receiver=0x8fe0f30, event=0x9264dc8) at ../../kdeui/kernel/kapplication.cpp:311
#56 0x025930bb in QCoreApplication::notifyInternal (this=0x84eb760, receiver=0x8fe0f30, event=0x9264dc8) at kernel/qcoreapplication.cpp:731
#57 0x02596c79 in sendEvent (receiver=0x8fe0f30, event_type=77, data=0x849df50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#58 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8fe0f30, event_type=77, data=0x849df50) at kernel/qcoreapplication.cpp:1372
#59 0x02596e0d in QCoreApplication::sendPostedEvents (receiver=0x8fe0f30, event_type=77) at kernel/qcoreapplication.cpp:1265
#60 0x03edec46 in dispatchPendingUpdateRequests (this=0x859c920) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#61 QGraphicsScenePrivate::_q_processDirtyItems (this=0x859c920) at graphicsview/qgraphicsscene.cpp:510
#62 0x03edf026 in QGraphicsScene::qt_metacall (this=0x84f4fa0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x940d988) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#63 0x00920a9a in Plasma::Corona::qt_metacall (this=0x84f4fa0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x940d988) at ./corona.moc:109
#64 0x002a120a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#65 0x025996ba in QMetaObject::metacall (object=0x84f4fa0, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x940d988) at kernel/qmetaobject.cpp:237
#66 0x025a3e16 in QMetaCallEvent::placeMetaCall (this=0x945c500, object=0x84f4fa0) at kernel/qobject.cpp:535
#67 0x025a83b7 in QObject::event (this=0x84f4fa0, e=0x945c500) at kernel/qobject.cpp:1226
#68 0x03eebe44 in QGraphicsScene::event (this=0x84f4fa0, event=0x945c500) at graphicsview/qgraphicsscene.cpp:3544
#69 0x03870d24 in QApplicationPrivate::notify_helper (this=0x84f4408, receiver=0x84f4fa0, e=0x945c500) at kernel/qapplication.cpp:4462
#70 0x038758ce in QApplication::notify (this=0x84eb760, receiver=0x84f4fa0, e=0x945c500) at kernel/qapplication.cpp:3862
#71 0x011cf3ca in KApplication::notify (this=0x84eb760, receiver=0x84f4fa0, event=0x945c500) at ../../kdeui/kernel/kapplication.cpp:311
#72 0x025930bb in QCoreApplication::notifyInternal (this=0x84eb760, receiver=0x84f4fa0, event=0x945c500) at kernel/qcoreapplication.cpp:731
#73 0x02596c79 in sendEvent (receiver=0x0, event_type=0, data=0x849df50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x849df50) at kernel/qcoreapplication.cpp:1372
#75 0x02596e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#76 0x025c03c4 in sendPostedEvents (s=0x84f4548) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=0x84f4548) at kernel/qeventdispatcher_glib.cpp:277
#78 0x01d15aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#79 0x01d16270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#80 0x01d16524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#81 0x025c053c in QEventDispatcherGlib::processEvents (this=0x849daa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#82 0x039271e5 in QGuiEventDispatcherGlib::processEvents (this=0x849daa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x02592289 in QEventLoop::processEvents (this=0xbfd60b64, flags=...) at kernel/qeventloop.cpp:149
#84 0x02592522 in QEventLoop::exec (this=0xbfd60b64, flags=...) at kernel/qeventloop.cpp:201
#85 0x02596ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#86 0x0386e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#87 0x002a85a5 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#88 0x080485cb in _start ()

Possible duplicates by query: bug 279930, bug 279925, bug 279921, bug 279719, bug 279196.

Reported using DrKonqi
Comment 1 Dario Andres 2011-08-17 13:40:18 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***
Comment 2 dlfroe 2011-09-07 14:04:57 UTC
Created attachment 63485 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- Custom settings of the application:

Using "Sleepy" plugin to close Amarok after so many minutes have expired. Occasionally, when Amarok closes, as programmed, the crash occurs. It doesn't happen all of the time ... possibly 20% of the time.

-- Backtrace (Reduced):
#7  0x01130454 in QString (this=0x9ec0061, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x9ec0061, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#9  0x01136352 in KIconLoaderPrivate::makeCacheKey (this=0x9ec004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#10 0x0113d398 in KIconLoader::loadIcon (this=0x9f88320, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#11 0x01134d76 in KIconEngine::pixmap (this=0x9c62d30, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93