Bug 277806

Summary: do not hide parent folders, i.e do not maximise column width/scroll automatically
Product: [Applications] dolphin Reporter: S. Burmeister <sven.burmeister>
Component: view-engine: columns modeAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: wishlist    
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description S. Burmeister 2011-07-14 23:47:12 UTC
Version:           unspecified (using Devel) 
OS:                Linux

I used the columns-view on a Mac today and noticed that it felt a lot more comfortable. The reason is pretty simple, there is less scrolling needed and the view is not that "nervous", i.e. does not move constantly.

The reason is that the columns on the Mac do not try to be as wide as the longest file name but simply adapt the file name to the column width. This makes sense because most often the number of long file names is a lot smaller than the number of file names that would fit in a less wide column.

So if one regards space that is not needed for a file name as wasted, a single long file can increase the wasted space a lot, simply because it adds wasted space to every row in the column. One file name rules them all. :) It makes more sense to let the majority rule the one file name. Tooltips on hovering shortened file names should help to recognise the file name.

A Mac shortens the middle of the file name i.e. really_long_filename_indeed.jpg becomes really_...deed.jpg.

But it's not only the wasted space that one would get rid of with fixed column widths but also a very "nervous" UI. Currently, opening a second column can already lead to automatic scrolling to the right, i.e. move the first of the two columns to the left.

Now if the user wants to pick any of the parent folders he cannot, because the folders have already been scrolled out of his sight. So he has to scroll the whole view to the left in order to be able to click on another folder. Clicking on that folder will again scroll the whole view to the right and hide the parent folders. And this is only with two columns, it gets worse with every column added.

With fixed column widths this would not happen, i.e. the parent folders are always accessible and never scrolled out of the user's view.

Do determine the columns' width one can simply divide the available width by the number of columns. Maybe even provide a setting for the maximum number of columns i.e. the depth shown. So if the max. number of columns is set to 2 and the user moves three folder levels the first column shows the 2 level.

I think a default of four columns would be ok. on a 1280px screen it would leave ~200px for each column if dolphin has two side panes enabled.

Reproducible: Always

Steps to Reproduce:
open folders with long file names in columns-view

Actual Results:  
a lot of automatic scrolling
hidden parent folders

Expected Results:  
no automatic scrolling
not hiding parent folders
Comment 1 S. Burmeister 2011-07-22 21:52:34 UTC
I tested it a bit further. On a 1400 pixel width monitor the file manager defaults to a column width of 200px. That column width is always kept no matter how many columns are open – thus the interface is very stable and calm.

If a new column does not fit into the window everything is moved to the left.

Columns' width can be changed by dragging the border between them.

The 200px might seem narrow but actually most files fit very well into that width and it gives room for 5-6 columns, i.e. folder hierarchies. That depth fits most hierarchies/folder depths.
Comment 2 Peter Penz 2012-01-05 21:53:13 UTC

*** This bug has been marked as a duplicate of bug 290747 ***