Bug 277354

Summary: Renaming a VPN connection resets advanced PPTP settings
Product: Network Management Reporter: Sergiu Bivol <sergiu>
Component: PPTPAssignee: Will Stephenson <wstephenson>
Status: RESOLVED FIXED    
Severity: minor CC: jfrantzius
Priority: NOR    
Version: 0.9   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Sergiu Bivol 2011-07-08 10:21:47 UTC
Version:           0.9 (using KDE 4.6.4) 
OS:                Linux

When renaming a PPTP connection, the VPN username and password are retained, but all the advanced options get reset to their default values.

Reproducible: Always

Steps to Reproduce:
– Create a new PPTP connection for Network Manager, for example „Work”;
– In PPTP Settings->Advanced, disable MSCHAP, set the encryption method and check Stateful MPPE;
– Save. Log off and log on;
– Rename the PPTP connection to „VPN Work”. Save;
– Open the connection again, check the advanced PPTP options.

Actual Results:  
The advanced options are reset to their default values: MSCHAP is enabled and the encryption is disabled.
The plasma widget does not update displayed the connection name.

Expected Results:  
Plasma widget picks up the new connection name and keeps all its settings.
Comment 1 Ilia Kats 2011-07-19 03:54:29 UTC
Git commit 3582237e508ab9dc2d56a80111a7faf6e652f97a by Ilia Kats.
Committed on 19/07/2011 at 03:58.
Pushed by iliakats into branch 'nm09'.

Port all VPN-Plugins which support this to the new secrets flags system.
Add auth-dialogs for OpenVPN and PTTP.
Fix some minor bugs

BUG: 269951
BUG: 277354
CCBUG: 274930

M  +108  -76   vpnplugins/pptp/pptpwidget.cpp
M  +0    -1    vpnplugins/vpnc/vpncauth.h
M  +0    -1    kded/settingsnm08/vpnpersistence.cpp
M  +9    -0    vpnplugins/openvpn/openvpnwidget.h
M  +1    -0    vpnplugins/openvpn/openvpn.h
M  +6    -0    vpnplugins/pptp/pptp.cpp
C  +11   -12   vpnplugins/openvpn/openvpnauth.h [from: vpnplugins/vpnc/vpncauth.h - 072% similarity]     [License: GPL]
M  +2    -1    vpnplugins/pptp/CMakeLists.txt
M  +1    -49   libs/internals/settings/vpn.h
M  +2    -4    vpnplugins/vpnc/vpncwidget.h
M  +21   -39   vpnplugins/vpnc/vpncwidget.cpp
M  +20   -18   vpnplugins/vpnc/vpncauth.cpp
M  +3    -3    vpnplugins/vpnc/vpncauth.ui
M  +3    -4    libs/internals/settings/vpnsecrets.cpp
M  +177  -66   vpnplugins/openvpn/openvpnprop.ui
M  +183  -69   vpnplugins/openvpn/openvpnwidget.cpp
C  +11   -12   vpnplugins/pptp/pptpauth.h [from: vpnplugins/vpnc/vpncauth.h - 072% similarity]     [License: GPL]
M  +0    -11   libs/internals/settings/vpn.cpp
M  +4    -1    vpnplugins/pptp/pptpwidget.h
M  +76   -94   vpnplugins/pptp/pptpauth.ui
M  +3    -7    libs/ui/vpnpreferences.cpp
A  +68   -0    vpnplugins/pptp/pptpauth.cpp     [License: GPL]
M  +28   -1    vpnplugins/pptp/pptpprop.ui
A  +172  -0    vpnplugins/openvpn/openvpnauth.cpp     [License: GPL]
M  +1    -0    vpnplugins/openvpn/CMakeLists.txt
M  +9    -15   vpnplugins/vpnc/vpnc.cpp
M  +1    -0    vpnplugins/pptp/pptp.h
M  +6    -0    vpnplugins/openvpn/openvpn.cpp

http://commits.kde.org/networkmanagement/3582237e508ab9dc2d56a80111a7faf6e652f97a
Comment 2 Ilia Kats 2011-07-19 12:29:41 UTC
*** Bug 251841 has been marked as a duplicate of this bug. ***