Bug 276484

Summary: kde crash after closing stellarium
Product: [Plasma] kwin Reporter: Roman Brunka <rbrunka>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Roman Brunka 2011-06-25 22:32:17 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:

I have closed Stellarium. It happens always after closing Stellarium in full screen mode.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f15e8b707a0 (LWP 2189))]

Thread 3 (Thread 0x7f15c92e1700 (LWP 2210)):
#0  0x00007f15e83ba143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f15e479832c in qt_safe_select (nfds=15, fdread=0x13609f0, fdwrite=0x1360c88, fdexcept=0x1360f20, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f15e479d3d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x1360830, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f15e479e04a in QEventDispatcherUNIX::processEvents (this=0x26a8470, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f15e476f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f15e476fabc in QEventLoop::exec (this=0x7f15c92e0db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f15e4686924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f15e4751c2f in QInotifyFileSystemWatcherEngine::run (this=0x1322330) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f15e4689175 in QThreadPrivate::start (arg=0x1322330) at thread/qthread_unix.cpp:320
#9  0x00007f15ded7cd8c in start_thread (arg=0x7f15c92e1700) at pthread_create.c:304
#10 0x00007f15e83c204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f15c8ae0700 (LWP 2211)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f15e72212a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f15e753a180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f15e72212d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f15e7548254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f15ded7cd8c in start_thread (arg=0x7f15c8ae0700) at pthread_create.c:304
#4  0x00007f15e83c204d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f15e8b707a0 (LWP 2189)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x1408030, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f15d01296c2 in intelClearWithBlit (ctx=0x1408030, mask=2) at intel_blit.c:262
#8  0x00007f15d012bd2a in intelClear (ctx=0x1408030, mask=2) at intel_clear.c:177
#9  0x00007f15e8738ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f15e873088f in KWin::Scene::paintGenericScreen (this=0x1403220, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007f15e872dc7a in KWin::Scene::finalPaintScreen (this=0x1403220, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f15e874bf19 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f15cb0c15a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x25b3190, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f15cb06844d in KWin::LogoutEffect::paintScreen (this=0x2737350, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f15cb08357b in KWin::ShadowEffect::paintScreen (this=0x2931990, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f15cb095e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f15cb06cfbd in KWin::PresentWindowsEffect::paintScreen (this=0x28c7130, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f15cb054365 in KWin::DesktopGridEffect::paintScreen (this=0x257bd90, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f15cb089b8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f15cb04dbad in KWin::BoxSwitchEffect::paintScreen (this=0x25b60c0, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f15cb0a4256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f15cb09cd86 in KWin::CoverSwitchEffect::paintScreen (this=0x2955950, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f15e680ba18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f15cb09339b in KWin::ZoomEffect::paintScreen (this=0x2696900, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f15e874bfa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x2539460, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f15e87300af in KWin::Scene::paintScreen (this=0x1403220, mask=0x7fff51eb888c, region=0x7fff51eb8950) at ../../kwin/scene.cpp:137
#56 0x00007f15e8743ef3 in KWin::SceneOpenGL::paint (this=0x1403220, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f15e872b396 in KWin::Workspace::performCompositing (this=0x1734a60) at ../../kwin/composite.cpp:448
#58 0x00007f15e47841c9 in QObject::event (this=0x1734a60, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f15e3b319e4 in QApplicationPrivate::notify_helper (this=0x12e2850, receiver=0x1734a60, e=0x7fff51eb90e0) at kernel/qapplication.cpp:4462
#60 0x00007f15e3b363aa in QApplication::notify (this=<value optimized out>, receiver=0x1734a60, e=0x7fff51eb90e0) at kernel/qapplication.cpp:4341
#61 0x00007f15e7ebd866 in KApplication::notify (this=0x7fff51eb94e0, receiver=0x1734a60, event=0x7fff51eb90e0) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f15e477049c in QCoreApplication::notifyInternal (this=0x7fff51eb94e0, receiver=0x1734a60, event=0x7fff51eb90e0) at kernel/qcoreapplication.cpp:731
#63 0x00007f15e479df12 in sendEvent (this=0x12e3f30) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x12e3f30) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f15e479e05b in QEventDispatcherUNIX::processEvents (this=0x1287340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f15e3bd9c0c in QEventDispatcherX11::processEvents (this=0x1287340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f15e476f882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f15e476fabc in QEventLoop::exec (this=0x7fff51eb9420, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f15e4773ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f15e86c91ec in kdemain (argc=<value optimized out>, argv=0x7fff51eb9b78) at ../../kwin/main.cpp:542
#71 0x00007f15e82faeff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff51eb9b78, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff51eb9b68) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 276152, bug 275741, bug 275525, bug 275478, bug 275202.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-06-25 22:39:51 UTC
driver bug, to workaround either really suspend compositing before going fullscreen (shift+alt+f12) or disable suspension for fullscreen window (yes, sounds weird ;-) in "kcmshell4 kwincompositing" (3rd tab)

*** This bug has been marked as a duplicate of bug 252817 ***