Bug 276063

Summary: nspluginviewer crashes when attempting to display flash content
Product: akregator Reporter: Robert Simmons <rsimmons0>
Component: internal browserAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: brianrenehan
Priority: NOR    
Version: 1.6.6   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Robert Simmons 2011-06-19 18:06:57 UTC
Version:           1.6.6 (using KDE 4.6.4) 
OS:                Linux

If you load a feed, and the articles that the feed points to on the web contain flash content, the plugin, nspluginviewer, that Akregator uses to display that flash content crashes every time it tries to display the content.

For example most all of the articles on this feed have flash content that crashes the plugin:
http://exiledonline.com/feed/rss/

Also of note is that it does not crash immediately if the flash content is not initially visible in the display window.  It only crashes when you scroll down and make the flash content visible.

I have the flash plugin from Adobe installed, perhaps there should be a way to choose to use it rather than this one that is crashing?

Reproducible: Always

Steps to Reproduce:
Open Akregator
Load this feed:
http://exiledonline.com/feed/rss/
Follow one of the articles to the website using the link in the feed article.
If the flash content is not visible, scroll down the page, when it is visible the plugin will crash.

Actual Results:  
Segmentation fault every time

Expected Results:  
Properly displayed flash content

Here is the output of the backtrace:


Application: nspluginviewer (nspluginviewer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7859710 (LWP 4587))]

Thread 2 (Thread 0xb4851b70 (LWP 4591)):
#0  0x003f3416 in __kernel_vsyscall ()
#1  0x00980834 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0x07521454 in __pthread_cond_timedwait (cond=0x8cf7340, mutex=0x8cf7328, abstime=0xb48512a0) at forward.c:152
#3  0x00a403e5 in wait (this=0x8cf728c, mutex=0x8cf7288, time=30000) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8cf728c, mutex=0x8cf7288, time=30000) at thread/qwaitcondition_unix.cpp:160
#5  0x00a338f1 in QThreadPoolThread::run (this=0x8cf73d8) at concurrent/qthreadpool.cpp:140
#6  0x00a3fda2 in QThreadPrivate::start (arg=0x8cf73d8) at thread/qthread_unix.cpp:320
#7  0x0097be99 in start_thread (arg=0xb4851b70) at pthread_create.c:304
#8  0x0751373e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7859710 (LWP 4587)):
[KCrash Handler]
#7  0xb4e628ab in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#8  0xb4f93a67 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#9  0xb4cb3c36 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#10 0xb4cbb0cc in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#11 0x08051765 in NSPluginInstance::NPDestroyStream (this=0x8c998e0, stream=0x8d21350, reason=0) at ../../../nsplugins/viewer/nsplugin.cpp:1189
#12 0x08053b48 in NSPluginStreamBase::finish (this=0x8d21150, err=false) at ../../../nsplugins/viewer/nsplugin.cpp:1817
#13 0x08054e74 in NSPluginInstance::javascriptResult (this=0x8c998e0, id=0, result=...) at ../../../nsplugins/viewer/nsplugin.cpp:1124
#14 0x080614ab in InstanceAdaptor::qt_metacall (this=0x8c99a10, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfb0370c) at instanceadaptor.moc:129
#15 0x00247acd in QDBusConnectionPrivate::deliverCall (this=0x8bf8c90, object=0x8c99a10, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:942
#16 0x00248bb2 in QDBusConnectionPrivate::activateCall (this=0x8bf8c90, object=0x8c99a10, flags=273, msg=...) at qdbusintegrator.cpp:845
#17 0x002491ac in QDBusConnectionPrivate::activateObject (this=0x8bf8c90, node=..., msg=..., pathStartPos=11) at qdbusintegrator.cpp:1430
#18 0x0024962a in QDBusActivateObjectEvent::placeMetaCall (this=0x8d21090) at qdbusintegrator.cpp:1524
#19 0x00b493b7 in QObject::event (this=0x8c998e0, e=0x8d21090) at kernel/qobject.cpp:1226
#20 0x0248ed24 in QApplicationPrivate::notify_helper (this=0x8badee8, receiver=0x8c998e0, e=0x8d21090) at kernel/qapplication.cpp:4462
#21 0x024938ce in QApplication::notify (this=0xbfb041c8, receiver=0x8c998e0, e=0x8d21090) at kernel/qapplication.cpp:3862
#22 0x0102836a in KApplication::notify (this=0xbfb041c8, receiver=0x8c998e0, event=0x8d21090) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00b340bb in QCoreApplication::notifyInternal (this=0xbfb041c8, receiver=0x8c998e0, event=0x8d21090) at kernel/qcoreapplication.cpp:731
#24 0x00b37c79 in sendEvent (receiver=0x0, event_type=0, data=0x8b60f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8b60f50) at kernel/qcoreapplication.cpp:1372
#26 0x00b37e0d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#27 0x00b613c4 in sendPostedEvents (s=0x8bb0300) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x8bb0300) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00dafaa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0x00db0270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0x00db0524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0x00b6153c in QEventDispatcherGlib::processEvents (this=0x8b60aa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#33 0x02542775 in QGuiEventDispatcherGlib::processEvents (this=0x8b60aa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00b33289 in QEventLoop::processEvents (this=0xbfb04034, flags=...) at kernel/qeventloop.cpp:149
#35 0x00b33522 in QEventLoop::exec (this=0xbfb04034, flags=...) at kernel/qeventloop.cpp:201
#36 0x00b37ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#37 0x0248c8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#38 0x0805adca in main (argc=) at ../../../nsplugins/viewer/viewer.cpp:144
Comment 1 Christophe Giboudeaux 2011-07-07 21:58:33 UTC
I cannot reproduce the crash with the articles with some flash content
Comment 2 Brian 2011-07-14 16:21:47 UTC
I have the same issue, nspluginviewer segmentation fault and crash on every load of a youtube (or any) flash object in Konqueror.  I am using a fresh install of Kubuntu 10.04 with only the recommended packages suggested on the first load of Konqueror ( the auto recommended packages you might be prompted to install on first load of konqueror, amarok etc ).  The computer is a brand new HP Probook 4525s, amd 64.  I am pasting the crash details below.

Actual results: Crash every time

Expected results: Display flash content


Application: nspluginviewer ()
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-28-generic i686
Distribution: Ubuntu 10.04.2 LTS

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>

The crash can be reproduced every time.

 -- Backtrace:
Application: nspluginviewer (nspluginviewer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76e9930 (LWP 2691))]

Thread 6 (Thread 0xb5fbbb70 (LWP 2695)):
#0  0x00f52422 in __kernel_vsyscall ()
#1  0x00966015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00da29dd in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x064ec087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0x065fe6c5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0x064ec18d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0x064ec816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x0096196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x00d95a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xb57bab70 (LWP 2696)):
#0  0x00f52422 in __kernel_vsyscall ()
#1  0x00966015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00da29dd in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x064ec087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0x065fe6c5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0x064ec18d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0x064ec816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x0096196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x00d95a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xb4fb9b70 (LWP 2697)):
#0  0x00f52422 in __kernel_vsyscall ()
#1  0x00966015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00da29dd in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x064ec087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0x065fe6c5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0x064ec18d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0x064ec816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x0096196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x00d95a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xb47b8b70 (LWP 2698)):
#0  0x00f52422 in __kernel_vsyscall ()
#1  0x00966015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00da29dd in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x064ec087 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#4  0x065fe6c5 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#5  0x064ec18d in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#6  0x064ec816 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x0096196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x00d95a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb3e4db70 (LWP 2724)):
#0  0x00f52422 in __kernel_vsyscall ()
#1  0x00966342 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00da2a34 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x02f0b20f in QWaitConditionPrivate::wait (this=0x9506b74, mutex=0x9506b70, time=30000) at thread/qwaitcondition_unix.cpp:85
#4  QWaitCondition::wait (this=0x9506b74, mutex=0x9506b70, time=30000) at thread/qwaitcondition_unix.cpp:159
#5  0x02eff2eb in QThreadPoolThread::run (this=0x9506cc0) at concurrent/qthreadpool.cpp:140
#6  0x02f0a32e in QThreadPrivate::start (arg=0x9506cc0) at thread/qthread_unix.cpp:248
#7  0x0096196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0x00d95a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb76e9930 (LWP 2691)):
[KCrash Handler]
#6  0x066828bb in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#7  0x067b3837 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#8  0x064d3c36 in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#9  0x064db0cc in ?? () from /usr/lib/firefox/plugins/flashplugin-alternative.so
#10 0x08051490 in NSPluginInstance::NPDestroyStream (this=0x95770f8, stream=0x95770f8, reason=-5748) at ../../../../apps/nsplugins/viewer/nsplugin.cpp:1189
#11 0x08057da8 in NSPluginStreamBase::finish (this=0x9577778, err=false) at ../../../../apps/nsplugins/viewer/nsplugin.cpp:1817
#12 0x080590f1 in NSPluginInstance::javascriptResult (this=0x9471798, id=0, result=...) at ../../../../apps/nsplugins/viewer/nsplugin.cpp:1124
#13 0x080641c9 in InstanceAdaptor::javascriptResult (this=0x94ed2d0, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfd2ed0c) at instanceadaptor.cpp:51
#14 InstanceAdaptor::qt_metacall (this=0x94ed2d0, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0xbfd2ed0c) at instanceadaptor.moc:129
#15 0x009a8b34 in QDBusConnectionPrivate::deliverCall (this=0x9386a98, object=0x94ed2d0, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:904
#16 0x009a9ddf in QDBusConnectionPrivate::activateCall (this=0x9386a98, object=0x94ed2d0, flags=273, msg=...) at qdbusintegrator.cpp:809
#17 0x009aa880 in QDBusConnectionPrivate::activateObject (this=0x9386a98, node=..., msg=..., pathStartPos=11) at qdbusintegrator.cpp:1364
#18 0x009aab1a in QDBusActivateObjectEvent::placeMetaCall (this=0x9577718) at qdbusintegrator.cpp:1477
#19 0x0301d3fe in QObject::event (this=0x9471798, e=0x9577718) at kernel/qobject.cpp:1248
#20 0x014404dc in QApplicationPrivate::notify_helper (this=0x9356f90, receiver=0x9471798, e=0x9577718) at kernel/qapplication.cpp:4300
#21 0x0144705e in QApplication::notify (this=0xbfd2f818, receiver=0x9471798, e=0x9577718) at kernel/qapplication.cpp:3704
#22 0x0113340a in KApplication::notify (this=0xbfd2f818, receiver=0x9471798, event=0x9577718) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x0300ca3b in QCoreApplication::notifyInternal (this=0xbfd2f818, receiver=0x9471798, event=0x9577718) at kernel/qcoreapplication.cpp:704
#24 0x0300f473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x93422c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x93422c0) at kernel/qcoreapplication.cpp:1345
#26 0x0300f5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#27 0x03038adf in QCoreApplication::sendPostedEvents (s=0x9359310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x9359310) at kernel/qeventdispatcher_glib.cpp:276
#29 0x0014b5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x0014f2d8 in ?? () from /lib/libglib-2.0.so.0
#31 0x0014f4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x030385d5 in QEventDispatcherGlib::processEvents (this=0x93424a0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#33 0x01500135 in QGuiEventDispatcherGlib::processEvents (this=0x93424a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x0300b059 in QEventLoop::processEvents (this=0xbfd2f684, flags=) at kernel/qeventloop.cpp:149
#35 0x0300b4aa in QEventLoop::exec (this=0xbfd2f684, flags=...) at kernel/qeventloop.cpp:201
#36 0x0300f69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#37 0x01440577 in QApplication::exec () at kernel/qapplication.cpp:3579
#38 0x0805ce55 in main (argc=3, argv=0xbfd2f954) at ../../../../apps/nsplugins/viewer/viewer.cpp:144
Comment 3 Christophe Giboudeaux 2011-07-14 21:03:27 UTC

*** This bug has been marked as a duplicate of bug 273609 ***