Bug 274934

Summary: Plasma crashed on resume from suspend
Product: plasma4 Reporter: Nick Leverton <nick>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian unstable   
OS: Linux   
Latest Commit: Version Fixed In:

Description Nick Leverton 2011-06-04 20:38:29 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.3 (4.6.3)
Qt Version: 4.7.3
Operating System: Linux 2.6.39-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
KDE suspended to RAM, and whilst suspended power was changed to battery.  Whilst resuming, AC power was resumed (not sure of exact ordering, possible race ?).  When desktop resumed, plasma crash event was on the screen already.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9e64f6e780 (LWP 2322))]

Thread 2 (Thread 0x7f9e46503700 (LWP 2325)):
#0  0x00007f9e6485a663 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9e589939e4 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f9e58993f1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f9e61a19636 in QEventDispatcherGlib::processEvents (this=0x1fe44e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9e619edb82 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e619edd7f in QEventLoop::exec (this=0x7f9e46502dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9e6190581f in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f9e619d0b6f in QInotifyFileSystemWatcherEngine::run (this=0x1fe7680) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9e61908235 in QThreadPrivate::start (arg=0x1fe7680) at thread/qthread_unix.cpp:320
#9  0x00007f9e596a2b40 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f9e6486528d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e64f6e780 (LWP 2322)):
[KCrash Handler]
#6  QString (this=0x2b5005c, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:728
#7  KIconEffect::fingerprint (this=0x2b5005c, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:169
#8  0x00007f9e6267b8f9 in KIconLoaderPrivate::makeCacheKey (this=<value optimized out>, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at ../../kdeui/icons/kiconloader.cpp:782
#9  0x00007f9e62682b7e in KIconLoader::loadIcon (this=0x2af0bf0, _name=<value optimized out>, group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1226
#10 0x00007f9e6267a589 in KIconEngine::pixmap (this=<value optimized out>, size=..., mode=<value optimized out>, state=<value optimized out>) at ../../kdeui/icons/kiconengine.cpp:93
#11 0x00007f9e60e4d6b5 in QIcon::pixmap (this=<value optimized out>, size=<value optimized out>, mode=<value optimized out>, state=<value optimized out>) at image/qicon.cpp:676
#12 0x00007f9e644597d4 in Plasma::IconWidgetPrivate::decoration (this=0x2b4f5f0, option=<value optimized out>, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:812
#13 0x00007f9e6445f701 in Plasma::IconWidget::paint (this=0x2b4f170, painter=0x7fffee621830, option=0x1c006c8, widget=<value optimized out>) at ../../plasma/widgets/iconwidget.cpp:1128
#14 0x00007f9e48444b79 in SystemTray::DBusSystemTrayWidget::paint (this=0x2b4f170, painter=0x7fffee621830, option=0x1c006c8, widget=<value optimized out>) at ../../../../../plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#15 0x00007f9e61386f2d in _q_paintItem (item=<value optimized out>, painter=0x7fffee621830, option=0x1c006c8, widget=0x0, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#16 0x00007f9e61387b1a in _q_paintIntoCache (pix=0x7fffee621dc0, item=0x2b4f180, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x1c006c8, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4352
#17 0x00007f9e6139fe98 in QGraphicsScenePrivate::drawItemHelper (this=0x1c004a0, item=0x2b4f180, painter=0x7fffee623d80, option=0x1c006c8, widget=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4673
#18 0x00007f9e613a084d in QGraphicsScenePrivate::draw (this=0x1c004a0, item=0x2b4f180, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, transformPtr=0x7fffee622350, exposedRegion=0x2377e80, widget=0x1feaa90, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#19 0x00007f9e613a1615 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1c004a0, item=0x2b4f180, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, exposedRegion=0x2377e80, widget=0x1feaa90, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4836
#20 0x00007f9e613a0900 in QGraphicsScenePrivate::draw (this=0x1c004a0, item=0x1f32320, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, transformPtr=0x7fffee622940, exposedRegion=0x2377e80, widget=0x1feaa90, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#21 0x00007f9e613a1615 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1c004a0, item=0x1f32320, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, exposedRegion=0x2377e80, widget=0x1feaa90, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4836
#22 0x00007f9e613a0900 in QGraphicsScenePrivate::draw (this=0x1c004a0, item=0x1f63830, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, transformPtr=0x7fffee622f30, exposedRegion=0x2377e80, widget=0x1feaa90, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#23 0x00007f9e613a1615 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1c004a0, item=0x1f63830, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, exposedRegion=0x2377e80, widget=0x1feaa90, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4836
#24 0x00007f9e613a0900 in QGraphicsScenePrivate::draw (this=0x1c004a0, item=0x1d91ed0, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, transformPtr=0x7fffee623520, exposedRegion=0x2377e80, widget=0x1feaa90, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#25 0x00007f9e613a1615 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x1c004a0, item=0x1d91ed0, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, exposedRegion=0x2377e80, widget=0x1feaa90, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4836
#26 0x00007f9e613a1e31 in QGraphicsScenePrivate::drawItems (this=0x1c004a0, painter=0x7fffee623d80, viewTransform=0x7fffee623a50, exposedRegion=0x2377e80, widget=0x1feaa90) at graphicsview/qgraphicsscene.cpp:4718
#27 0x00007f9e613bab20 in QGraphicsView::paintEvent (this=0x1fee0f0, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007f9e60df7ce8 in QWidget::event (this=0x1fee0f0, event=0x7fffee624720) at kernel/qwidget.cpp:8405
#29 0x00007f9e61199006 in QFrame::event (this=0x1fee0f0, e=0x7fffee624720) at widgets/qframe.cpp:557
#30 0x00007f9e613bbe7b in QGraphicsView::viewportEvent (this=0x1fee0f0, event=0x7fffee624720) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007f9e619eeb08 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1feaa90, event=0x7fffee624720) at kernel/qcoreapplication.cpp:846
#32 0x00007f9e60da769f in notify_helper (this=0x1b15930, receiver=0x1feaa90, e=0x7fffee624720) at kernel/qapplication.cpp:4463
#33 QApplicationPrivate::notify_helper (this=0x1b15930, receiver=0x1feaa90, e=0x7fffee624720) at kernel/qapplication.cpp:4439
#34 0x00007f9e60dac561 in QApplication::notify (this=0x1b04840, receiver=0x1feaa90, e=0x7fffee624720) at kernel/qapplication.cpp:4346
#35 0x00007f9e626d2fb6 in KApplication::notify (this=0x1b04840, receiver=0x1feaa90, event=0x7fffee624720) at ../../kdeui/kernel/kapplication.cpp:311
#36 0x00007f9e619ee97c in QCoreApplication::notifyInternal (this=0x1b04840, receiver=0x1feaa90, event=0x7fffee624720) at kernel/qcoreapplication.cpp:731
#37 0x00007f9e60df4bf6 in sendSpontaneousEvent (this=0x1f96c50, pdev=0x1eb8298, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26b9250) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#38 QWidgetPrivate::drawWidget (this=0x1f96c50, pdev=0x1eb8298, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26b9250) at kernel/qwidget.cpp:5492
#39 0x00007f9e60df57d0 in QWidgetPrivate::paintSiblingsRecursive (this=0x23779f0, pdev=0x1eb8298, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x26b9250) at kernel/qwidget.cpp:5699
#40 0x00007f9e60df492c in QWidgetPrivate::drawWidget (this=0x23779f0, pdev=0x1eb8298, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x26b9250) at kernel/qwidget.cpp:5545
#41 0x00007f9e60fb1ba2 in QWidgetBackingStore::sync (this=0x26b9250) at painting/qbackingstore.cpp:1333
#42 0x00007f9e60deb440 in QWidgetPrivate::syncBackingStore (this=0x23779f0) at kernel/qwidget.cpp:1842
#43 0x00007f9e60df81fc in QWidget::event (this=0x1fee0f0, event=0x25a3510) at kernel/qwidget.cpp:8552
#44 0x00007f9e61199006 in QFrame::event (this=0x1fee0f0, e=0x25a3510) at widgets/qframe.cpp:557
#45 0x00007f9e6121a713 in QAbstractScrollArea::event (this=0x1fee0f0, e=0x25a3510) at widgets/qabstractscrollarea.cpp:996
#46 0x00007f9e64b59c16 in PanelView::event (this=0x1fee0f0, event=0x25a3510) at ../../../../plasma/desktop/shell/panelview.cpp:1604
#47 0x00007f9e60da76d4 in notify_helper (this=0x1b15930, receiver=0x1fee0f0, e=0x25a3510) at kernel/qapplication.cpp:4467
#48 QApplicationPrivate::notify_helper (this=0x1b15930, receiver=0x1fee0f0, e=0x25a3510) at kernel/qapplication.cpp:4439
#49 0x00007f9e60dac561 in QApplication::notify (this=0x1b04840, receiver=0x1fee0f0, e=0x25a3510) at kernel/qapplication.cpp:4346
#50 0x00007f9e626d2fb6 in KApplication::notify (this=0x1b04840, receiver=0x1fee0f0, event=0x25a3510) at ../../kdeui/kernel/kapplication.cpp:311
#51 0x00007f9e619ee97c in QCoreApplication::notifyInternal (this=0x1b04840, receiver=0x1fee0f0, event=0x25a3510) at kernel/qcoreapplication.cpp:731
#52 0x00007f9e619f1cc4 in sendEvent (receiver=0x1fee0f0, event_type=77, data=0x1a92860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#53 QCoreApplicationPrivate::sendPostedEvents (receiver=0x1fee0f0, event_type=77, data=0x1a92860) at kernel/qcoreapplication.cpp:1372
#54 0x00007f9e61396e3a in dispatchPendingUpdateRequests (this=0x1c004a0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:189
#55 QGraphicsScenePrivate::_q_processDirtyItems (this=0x1c004a0) at graphicsview/qgraphicsscene.cpp:510
#56 0x00007f9e6139725a in QGraphicsScene::qt_metacall (this=0x1b0fc20, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x28cc440) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#57 0x00007f9e643a5e15 in Plasma::Corona::qt_metacall (this=0x1b0fc20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x28cc440) at ./corona.moc:109
#58 0x00007f9e64b4dc15 in DesktopCorona::qt_metacall (this=0x1b0fc20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x28cc440) at ./desktopcorona.moc:101
#59 0x00007f9e61a0519a in QObject::event (this=0x1b0fc20, e=<value optimized out>) at kernel/qobject.cpp:1217
#60 0x00007f9e6139db09 in QGraphicsScene::event (this=0x1b0fc20, event=0x2beb9a0) at graphicsview/qgraphicsscene.cpp:3544
#61 0x00007f9e60da76d4 in notify_helper (this=0x1b15930, receiver=0x1b0fc20, e=0x2beb9a0) at kernel/qapplication.cpp:4467
#62 QApplicationPrivate::notify_helper (this=0x1b15930, receiver=0x1b0fc20, e=0x2beb9a0) at kernel/qapplication.cpp:4439
#63 0x00007f9e60dac561 in QApplication::notify (this=0x1b04840, receiver=0x1b0fc20, e=0x2beb9a0) at kernel/qapplication.cpp:4346
#64 0x00007f9e626d2fb6 in KApplication::notify (this=0x1b04840, receiver=0x1b0fc20, event=0x2beb9a0) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00007f9e619ee97c in QCoreApplication::notifyInternal (this=0x1b04840, receiver=0x1b0fc20, event=0x2beb9a0) at kernel/qcoreapplication.cpp:731
#66 0x00007f9e619f1cc4 in sendEvent (receiver=0x0, event_type=0, data=0x1a92860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#67 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1a92860) at kernel/qcoreapplication.cpp:1372
#68 0x00007f9e61a19173 in sendPostedEvents (s=0x1b13560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#69 postEventSourceDispatch (s=0x1b13560) at kernel/qeventdispatcher_glib.cpp:277
#70 0x00007f9e589934a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#71 0x00007f9e58993c80 in ?? () from /lib/libglib-2.0.so.0
#72 0x00007f9e58993f1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
#73 0x00007f9e61a195cf in QEventDispatcherGlib::processEvents (this=0x1a93f50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#74 0x00007f9e60e4b70e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#75 0x00007f9e619edb82 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#76 0x00007f9e619edd7f in QEventLoop::exec (this=0x7fffee626670, flags=...) at kernel/qeventloop.cpp:201
#77 0x00007f9e619f1f57 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#78 0x00007f9e64b54583 in kdemain (argc=1, argv=0x7fffee626a58) at ../../../../plasma/desktop/shell/main.cpp:120
#79 0x00007f9e647aeead in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffee626a48) at libc-start.c:228
#80 0x00000000004006a1 in _start ()

Possible duplicates by query: bug 274932, bug 274898, bug 274864, bug 274830, bug 274781.

Reported using DrKonqi
Comment 1 Nick Leverton 2011-06-04 21:43:15 UTC
Correction, AC was not restored, system was still on battery during resume.
Comment 2 Dario Andres 2011-06-05 15:41:25 UTC
[Comment from a bug triager]
The bug is fixed for KDE SC 4.6.4. The issue was being tracked at bug 258706, merging.
Thanks

*** This bug has been marked as a duplicate of bug 258706 ***