Bug 270472

Summary: 'Copy' from message text produces HTML
Product: [Applications] kmail Reporter: o_O_Tync <ootync>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: samuel.brack
Priority: NOR    
Version: 1.13.5   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In: KdePIM 4.4.10

Description o_O_Tync 2011-04-09 01:30:16 UTC
Version:           1.13.5 (using KDE 4.6.2) 
OS:                Linux

When I copy anything from the received HTML message — I don't get plaintext

Reproducible: Didn't try

Steps to Reproduce:
Copy something from a received HTML message

Actual Results:  
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd">
<body>This HTML message may contain external references </body>

Expected Results:  
"This HTML message may contain external references" in the paste buffer
Comment 1 Samuel Brack 2011-04-10 14:40:28 UTC
I can't confirm this bug (using KMail 1.13.6), so I've got a few questions to investigate when exactly this bug occurs:
Do you copy with Ctrl-C or with the context menu? Are you copying from the HTML view or from plaintext view with the HTML tags not rendered? Are you encountering this problem when copying the entire mail (perhaps with embedded images?) or even when you copy just a random piece of text from anywhere in the mail?
Thank you for your report.
Comment 2 o_O_Tync 2011-04-10 22:14:35 UTC
I copy both with Ctrl-C and Menu->Copy: same result, from both HTML view and Text view (when there's no HTML message enclosed in the email). I'm selecting just a few words: not the whole letter or images.

Same bug here: http://forum.nginx.org/read.php?30,163044
Comment 3 Samuel Brack 2011-04-10 22:53:47 UTC
According to your linked discussion (comment #2) on that mailing list, this bug will be fixed in KDEPIM 4.4.10 (which I'm using right now - so I can't reproduce this bug). 
If anyone encounters that bug in a version of KDEPIM (the version number of KMail stays as it is) greater than 4.4.10, feel free to reopen this bug again. Closed.
Comment 4 Christophe Marin 2011-04-10 23:46:11 UTC
choose the appropriate resolution

*** This bug has been marked as a duplicate of bug 259468 ***