Bug 269758

Summary: Application Launcher Freezes when Samba Drive Shut Down
Product: [Plasma] plasma4 Reporter: anderlia <alain.anderlini>
Component: widget-kickoffAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: kdebugs, rifter0x0000, rlerallut
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description anderlia 2011-03-30 11:12:24 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

I have a Samba network drive that is mounted at boot time in fstab as follows:
*//192.168.1.2/Public /media/LaCie-d2/Public cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
*//192.168.1.2/Share /media/LaCie-d2/Share cifs credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

Ihave set up this network drive to enter some kind of deep sleep mode every night, from 12h00 am till 7h00 am. In deep sleep mode, the network drive is no longer responsive to any Samba commands.

If my network drive is mounted successfully at boot time, and then enters the aforementioned deep sleep mode, the Kickoff menu no longer works: the Kickoff panel pops up, but freezes and is no longer responsive. I cannot access any of my favorite application shorcuts, neither the other tabs "Computer", "Leave", etc. If I hover the mouse over any tab, nothing gets animated. Also, the whole desktop animation is frozen as well: I cannot switch desktop, the widget animations freeze, etc. Yet, I can still focus on already open application windows and interact with them.

If I re-enable my network drive and leaves the deep sleep mode, then the problem immediately disappears: the Kickoff menu unfreezes, and applications shorcuts are available again. The problem seems very much related to the "Recent Documents" entries that point towards the network drive, such as a recent video which I watched on this network drive.

I was advised to remove write access to ~/.kde4/share/apps/RecentDocuments/ in this post, yet I won't be able to use the Recent Documents anymore, which is not acceptable.

This problem does not appear with Lancelot launcher. This problem is 100% reproducible, and did not happen for previous KDE releases ( <= 4.5.x).

I am available for any trace you would like to run to investigate this issue further.

Reproducible: Always

Steps to Reproduce:
See details above.

Actual Results:  
See details above.

Expected Results:  
See details above.
Comment 1 Romain 2011-04-04 13:21:28 UTC
Could be the same thing as bug 202309
Comment 2 Peter Lemieux 2011-04-17 21:30:20 UTC
I posted this on the forum discussion then saw this bug had been posted.

Kubuntu 10.10 with backports to 4.6.2

I've had the problem of the standard launcher freezing.  It was a problem in both 4.6.1 and 4.6.2; I don't recall whether it occurred with 4.6.0. I've not encountered this in earlier KDE 4 versions. I also don't have any problem using either Lancelot (which I find too busy) or the traditional KDE 3.x-styled launcher (which I find too ugly). I'm using Lancelot at the moment, but I'd much prefer to return to the original launcher.

Once the launcher freezes, all of plasma does so as well. The panel and the desktop become as unresponsive as the menu. It's rather difficult to identify when the menu will freeze. Today it happened with only a Konsole open on my desktop. I could bring up the launcher but could not click on any icons. Alt-F4 still allowed me to select the terminal window, and I could launch applications from the prompt. However the menu stayed on-screen throughout and could not be forced behind the open applications.

I've tried many different fixes like killing plasma-desktop from the prompt and starting it again.  I've recreated my .kde directory from scratch on numerous occasions.  The launcher works correctly immediately after I do this, but freezes soon thereafter.

On the forum there were a couple of inquiries about possible causes that don't seem to apply in my case.  I have no external drive shortcuts. I mount an external USB drive and an NFS share at boot. These are both owned by root, not me. I'm running a quad-core machine that rarely has a load average above one. At the moment, with Firefox and Konsole open, my load average is about 0.05-0.10.
Comment 3 anderlia 2011-12-05 13:31:15 UTC
Hi Guy,

Could please let me now in which version of KDE the problem is expected to
be fixed. Thanks.

Regards,
Alain

On Sat, Dec 3, 2011 at 12:35 PM, Aaron J. Seigo <aseigo@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=269758
>
>
> Aaron J. Seigo <aseigo@kde.org> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |RESOLVED
>         Resolution|                            |FIXED
>
>
>
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 4 rifter0x0000 2012-01-21 01:40:55 UTC
If this is fixed why isn't there a version listed for the fix?  I'm having the same freezes but without even needing any nfs or smb involved, and want to try upgrading to the version that got fixed.
Comment 5 anderlia 2012-05-02 09:53:47 UTC
I hereby confirm the resolution of this issue with KDE 4.8.2 (Kubuntu 12.04 Precise Pangolin). If I shutdown my NAS, then Klauncher no longer freezes and is as responsive as the NAS was still on. Thanks for your continued support on this bug.