Bug 268719

Summary: Kopete and Plasma workspace crashed
Product: plasma4 Reporter: Little Girl <littlergirl>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: aseigo
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Little Girl 2011-03-17 06:53:40 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-29-generic i686
Distribution: Ubuntu 10.04.2 LTS

-- Information about the crash:
I was using kopete 4:4.4.5-0ubuntu1 in Kubuntu 10.04 Lucid Lynx. Mozilla Firefox 3.6.15 was also open at the time.

A few minutes after I opened Kopete and connected to AIM and ICQ, Kopete got an "Unknown error" and disconnected several times (maybe four or five times) in rapid succession. This was annoying enough that I said goodbye to the person I was chatting with and closed Kopete.

When I closed Kopete, Plasma workspace crashed and a window popped up offering me an opportunity to report the bug.

It may be important to note that although I was told my Plasma workspace crashed, my Desktop background was intact and my panel was present at the bottom of the screen (both still are as I write this).


 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7748aa0 (LWP 1875))]

Thread 2 (Thread 0xaa04cb70 (LWP 1876)):
#0  0x05145e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x08aee6fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x08af3825 in QTimerInfoList::updateCurrentTime (this=0x97f73ec) at kernel/qeventdispatcher_unix.cpp:340
#3  0x08af386a in QTimerInfoList::timerWait (this=0x97f73ec, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x08af1818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaa04c0cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x08af18a5 in timerSourcePrepare (source=0x0, timeout=0x5149ff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x01122aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x01122ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x011234b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x08af160f in QEventDispatcherGlib::processEvents (this=0x97f7338, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x08ac4059 in QEventLoop::processEvents (this=0xaa04c290, flags=) at kernel/qeventloop.cpp:149
#11 0x08ac44aa in QEventLoop::exec (this=0xaa04c290, flags=...) at kernel/qeventloop.cpp:201
#12 0x089c05a8 in QThread::exec (this=0x967c2a0) at thread/qthread.cpp:487
#13 0x08aa3c1b in QInotifyFileSystemWatcherEngine::run (this=0x967c2a0) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x089c332e in QThreadPrivate::start (arg=0x967c2a0) at thread/qthread_unix.cpp:248
#15 0x00a9296e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x0382ea4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7748aa0 (LWP 1875)):
[KCrash Handler]
#6  0x00e5d356 in QString (this=0x24, group=0, state=0) at /usr/include/qt4/QtCore/qstring.h:714
#7  KIconEffect::fingerprint (this=0x24, group=0, state=0) at ../../kdeui/icons/kiconeffect.cpp:158
#8  0x00e69ae4 in KIconLoader::loadIcon (this=0x9bc60d0, _name=..., group=KIconLoader::Desktop, size=22, state=0, overlays=..., path_store=0x0, canReturnNull=false)
    at ../../kdeui/icons/kiconloader.cpp:1085
#9  0x00e61c88 in KIconEngine::actualSize (this=0x9e97088, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:80
#10 0x05e0f4b6 in QIcon::actualSize (this=0x988f4f4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:700
#11 0x013aa143 in Plasma::IconWidgetPrivate::decoration (this=0x988f478, option=0x942e230, useHoverEffect=false, usePressedEffect=false) at ../../plasma/widgets/iconwidget.cpp:701
#12 0x013abd57 in Plasma::IconWidget::paint (this=0x9c66510, painter=0xbfdf9f7c, option=0x942e230, widget=0x0) at ../../plasma/widgets/iconwidget.cpp:1013
#13 0x063e2f2c in _q_paintItem (item=<value optimized out>, painter=<value optimized out>, option=0x942e230, widget=0x0, useWindowOpacity=false, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4243
#14 0x063e5b1a in _q_paintIntoCache (pix=<value optimized out>, item=<value optimized out>, pixmapExposed=..., itemToPixmap=..., renderHints=..., option=0x942e230, 
    painterStateProtection=<value optimized out>) at graphicsview/qgraphicsscene.cpp:4281
#15 0x063ff620 in QGraphicsScenePrivate::drawItemHelper (this=0x942e0d0, item=0x9c66518, painter=0xbfdfbda4, option=0x942e230, widget=0x945c950, painterStateProtection=true)
    at graphicsview/qgraphicsscene.cpp:4574
#16 0x06400044 in QGraphicsScenePrivate::draw (this=0x942e0d0, item=0x9c66518, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, transformPtr=0xbfdfa960, exposedRegion=0x98ab964, widget=0x945c950, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4827
#17 0x06400cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x942e0d0, item=0x9c66518, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, exposedRegion=0x98ab964, widget=0x945c950, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#18 0x064000d4 in QGraphicsScenePrivate::draw (this=0x942e0d0, item=0x97e20b8, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, transformPtr=0xbfdfae60, exposedRegion=0x98ab964, widget=0x945c950, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#19 0x06400cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x942e0d0, item=0x97e20b8, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, exposedRegion=0x98ab964, widget=0x945c950, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#20 0x064000d4 in QGraphicsScenePrivate::draw (this=0x942e0d0, item=0x976f090, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, transformPtr=0xbfdfb360, exposedRegion=0x98ab964, widget=0x945c950, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#21 0x06400cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x942e0d0, item=0x976f090, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, exposedRegion=0x98ab964, widget=0x945c950, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#22 0x064000d4 in QGraphicsScenePrivate::draw (this=0x942e0d0, item=0x95e2508, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, transformPtr=0xbfdfb860, exposedRegion=0x98ab964, widget=0x945c950, 
    opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4841
#23 0x06400cb3 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x942e0d0, item=0x95e2508, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, exposedRegion=0x98ab964, widget=0x945c950, 
    parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4749
#24 0x064016be in QGraphicsScenePrivate::drawItems (this=0x942e0d0, painter=0xbfdfbda4, viewTransform=0xbfdfbbdc, exposedRegion=0x98ab964, widget=0x945c950) at graphicsview/qgraphicsscene.cpp:4619
#25 0x0641bbeb in QGraphicsView::paintEvent (this=0x98bd3d8, event=0xbfdfc4c4) at graphicsview/qgraphicsview.cpp:3393
#26 0x04d60c79 in PanelView::paintEvent (this=0x98bd3d8, event=0xbfdfc4c4) at ../../../../plasma/desktop/shell/panelview.cpp:1300
#27 0x05dab6b6 in QWidget::event (this=0x98bd3d8, event=0xbfdfc4c4) at kernel/qwidget.cpp:8144
#28 0x061a7fd3 in QFrame::event (this=0x98bd3d8, e=0xbfdfc4c4) at widgets/qframe.cpp:557
#29 0x06242382 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x24) at widgets/qabstractscrollarea.cpp:1036
#30 0x0641806b in QGraphicsView::viewportEvent (this=0x98bd3d8, event=0xbfdfc4c4) at graphicsview/qgraphicsview.cpp:2787
#31 0x06244c65 in QAbstractScrollAreaPrivate::viewportEvent (this=0x9ae0b28, o=0x945c950, e=0xbfdfc4c4) at widgets/qabstractscrollarea_p.h:100
#32 QAbstractScrollAreaFilter::eventFilter (this=0x9ae0b28, o=0x945c950, e=0xbfdfc4c4) at widgets/qabstractscrollarea_p.h:116
#33 0x08ac4cda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x93c5910, receiver=0x945c950, event=0xbfdfc4c4) at kernel/qcoreapplication.cpp:819
#34 0x05d4d4b9 in QApplicationPrivate::notify_helper (this=0x93c5910, receiver=0x945c950, e=0xbfdfc4c4) at kernel/qapplication.cpp:4296
#35 0x05d540f9 in QApplication::notify (this=0x93bf7d0, receiver=0x945c950, e=0xbfdfc4c4) at kernel/qapplication.cpp:4265
#36 0x00ea740a in KApplication::notify (this=0x93bf7d0, receiver=0x945c950, event=0xbfdfc4c4) at ../../kdeui/kernel/kapplication.cpp:302
#37 0x08ac5a3b in QCoreApplication::notifyInternal (this=0x93bf7d0, receiver=0x945c950, event=0xbfdfc4c4) at kernel/qcoreapplication.cpp:704
#38 0x05db49d6 in QCoreApplication::sendSpontaneousEvent (this=0x98d54f0, pdev=0x9474034, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x957bb40)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#39 QWidgetPrivate::drawWidget (this=0x98d54f0, pdev=0x9474034, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x957bb40) at kernel/qwidget.cpp:5339
#40 0x05db5815 in QWidgetPrivate::paintSiblingsRecursive (this=0x98ab600, pdev=0x9474034, siblings=..., index=3, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x957bb40)
    at kernel/qwidget.cpp:5452
#41 0x05db564e in QWidgetPrivate::paintSiblingsRecursive (this=0x98ab600, pdev=0x9474034, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x957bb40)
    at kernel/qwidget.cpp:5439
#42 0x05db4725 in QWidgetPrivate::drawWidget (this=0x98ab600, pdev=0x9474034, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x957bb40) at kernel/qwidget.cpp:5388
#43 0x05f8b890 in QWidgetBackingStore::sync (this=0x957bb40) at painting/qbackingstore.cpp:1291
#44 0x05da4b93 in QWidgetPrivate::syncBackingStore (this=0x98ab600) at kernel/qwidget.cpp:1672
#45 0x05dabe76 in QWidget::event (this=0x98bd3d8, event=0xa0c0ef8) at kernel/qwidget.cpp:8291
#46 0x061a7fd3 in QFrame::event (this=0x98bd3d8, e=0xa0c0ef8) at widgets/qframe.cpp:557
#47 0x06242d97 in QAbstractScrollArea::event (this=0x98bd3d8, e=0xa0c0ef8) at widgets/qabstractscrollarea.cpp:989
#48 0x0641a216 in QGraphicsView::event (this=0x98bd3d8, event=0xa0c0ef8) at graphicsview/qgraphicsview.cpp:2666
#49 0x04d61613 in PanelView::event (this=0x98bd3d8, event=0xa0c0ef8) at ../../../../plasma/desktop/shell/panelview.cpp:1314
#50 0x05d4d4dc in QApplicationPrivate::notify_helper (this=0x93c5910, receiver=0x98bd3d8, e=0xa0c0ef8) at kernel/qapplication.cpp:4300
#51 0x05d540f9 in QApplication::notify (this=0x93bf7d0, receiver=0x98bd3d8, e=0xa0c0ef8) at kernel/qapplication.cpp:4265
#52 0x00ea740a in KApplication::notify (this=0x93bf7d0, receiver=0x98bd3d8, event=0xa0c0ef8) at ../../kdeui/kernel/kapplication.cpp:302
#53 0x08ac5a3b in QCoreApplication::notifyInternal (this=0x93bf7d0, receiver=0x98bd3d8, event=0xa0c0ef8) at kernel/qcoreapplication.cpp:704
#54 0x08ac8473 in QCoreApplication::sendEvent (receiver=0x98bd3d8, event_type=77, data=0x935cfc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x98bd3d8, event_type=77, data=0x935cfc8) at kernel/qcoreapplication.cpp:1345
#56 0x08ac85dd in QCoreApplication::sendPostedEvents (receiver=0x98bd3d8, event_type=77) at kernel/qcoreapplication.cpp:1238
#57 0x063fd326 in QGraphicsViewPrivate::dispatchPendingUpdateRequests (this=0x942e0d0) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:184
#58 QGraphicsScenePrivate::_q_processDirtyItems (this=0x942e0d0) at graphicsview/qgraphicsscene.cpp:509
#59 0x063fd876 in QGraphicsScene::qt_metacall (this=0x9489b70, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x988e3c8) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#60 0x012e901a in Plasma::Corona::qt_metacall (this=0x9489b70, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x988e3c8) at ./corona.moc:107
#61 0x04d50fad in DesktopCorona::qt_metacall (this=0x9489b70, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x988e3c8) at ./desktopcorona.moc:86
#62 0x08acac9a in QMetaObject::metacall (object=0x9489b70, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x988e3c8) at kernel/qmetaobject.cpp:237
#63 0x08ad5336 in QMetaCallEvent::placeMetaCall (this=0x9858338, object=0x9489b70) at kernel/qobject.cpp:561
#64 0x08ad63fe in QObject::event (this=0x9489b70, e=0x9858338) at kernel/qobject.cpp:1248
#65 0x063f9554 in QGraphicsScene::event (this=0x9489b70, event=0x9858338) at graphicsview/qgraphicsscene.cpp:3500
#66 0x05d4d4dc in QApplicationPrivate::notify_helper (this=0x93c5910, receiver=0x9489b70, e=0x9858338) at kernel/qapplication.cpp:4300
#67 0x05d5405e in QApplication::notify (this=0x93bf7d0, receiver=0x9489b70, e=0x9858338) at kernel/qapplication.cpp:3704
#68 0x00ea740a in KApplication::notify (this=0x93bf7d0, receiver=0x9489b70, event=0x9858338) at ../../kdeui/kernel/kapplication.cpp:302
#69 0x08ac5a3b in QCoreApplication::notifyInternal (this=0x93bf7d0, receiver=0x9489b70, event=0x9858338) at kernel/qcoreapplication.cpp:704
#70 0x08ac8473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x935cfc8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#71 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x935cfc8) at kernel/qcoreapplication.cpp:1345
#72 0x08ac85dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#73 0x08af1adf in QCoreApplication::sendPostedEvents (s=0x93c7910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#74 postEventSourceDispatch (s=0x93c7910) at kernel/qeventdispatcher_glib.cpp:276
#75 0x0111f5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#76 0x011232d8 in ?? () from /lib/libglib-2.0.so.0
#77 0x011234b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#78 0x08af15d5 in QEventDispatcherGlib::processEvents (this=0x93c55e0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#79 0x05e0d135 in QGuiEventDispatcherGlib::processEvents (this=0x93c55e0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#80 0x08ac4059 in QEventLoop::processEvents (this=0xbfdfdee4, flags=) at kernel/qeventloop.cpp:149
#81 0x08ac44aa in QEventLoop::exec (this=0xbfdfdee4, flags=...) at kernel/qeventloop.cpp:201
#82 0x08ac869f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#83 0x05d4d577 in QApplication::exec () at kernel/qapplication.cpp:3579
#84 0x04d5905e in kdemain (argc=1, argv=0x93b63a8) at ../../../../plasma/desktop/shell/main.cpp:112
#85 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9396658 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#86 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#87 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#88 0x0804fe4f in main (argc=4, argv=0xbfdfe994, envp=0xbfdfe9a8) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 226596.

Possible duplicates by query: bug 268597, bug 268518, bug 268436, bug 268360, bug 268342.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-03-17 08:39:28 UTC

*** This bug has been marked as a duplicate of bug 258706 ***