Bug 267844

Summary: Automatic detection of proxy OR proxy URL don't work
Product: kde Reporter: Kanwar Plaha <Kanwar.Plaha>
Component: generalAssignee: Dawit Alemayehu <adawit>
Status: RESOLVED FIXED    
Severity: normal CC: adawit
Priority: NOR    
Version: 4.6   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 4.7

Description Kanwar Plaha 2011-03-07 01:37:46 UTC
Version:           4.6 (using KDE 4.6.1) 
OS:                Linux

This is a KDE-wide issue. Automatic proxy URL does not work. Also, Automatic detection fails. This is causing issues with the proxy setup at my office where a proxy URL is provided.

Reproducible: Always

Steps to Reproduce:
Choose 'automatically detect proxy settings' OR 'automatic proxy URL'. Try to browse using either Konqueror or any KDE-browser or GHNS and it fails.

Actual Results:  
None.

Expected Results:  
Browsing the internet is possible thru the above methods.

This has been the case since KDE 3.x.
Comment 1 Dawit Alemayehu 2011-04-07 07:15:07 UTC
Git commit 98946bcb75615b0900a2b2e124cae89b7c323fd0 by Dawit Alemayehu.
Committed on 29/03/2011 at 00:12.
Pushed by adawit into branch 'master'.

KIO proxy overhaul Part I:

Features:
- Switched the PAC file parser from KJS to QtScript.
- Implemented the Microsoft IPv6 PAC extensions.
- Implemented support for returning SOCKS proxy information (only SOCKS5).
- Added a new dbus call, proxiesForUrl, that returns all the proxy addresses
  for a given url.
- Added a new kpactest file to test the new MS IPv6 extension functions.

Fixes:
- Fixed the DateRange function by adding back two missing months in the static
  months array.
- Fixed the DNS related functions by fixing how the lookup works through
  the following modification to the KIO DNS caching code:
    * Added a function, lookupCachedHostInfoFor, for quering the KIO cache for
      information without causing a DNS query.
    * Added a function, cacheLookup, for inserting a DNS lookup result into
      the KIO cache.
- Fixed myIpAddress by using QNetworkInterface, though this fix is still far
  from ideal since it grabs the first suitable interface on multi-homed systems.

REVIEW: 100971
BUG: 153973
BUG: 267844
FIXED-IN: 4.7
DIGEST: KIO Proxy overhaul for KDE 4.7

M  +32   -0    kio/kio/hostinfo.cpp     
M  +4    -0    kio/kio/hostinfo_p.h     
M  +2    -5    kio/misc/kpac/CMakeLists.txt     
M  +1    -0    kio/misc/kpac/kpac_dhcp_helper.c     
M  +2    -2    kio/misc/kpac/kpactest.pac     
A  +63   -0    kio/misc/kpac/kpactest2.pac         [License: UNKNOWN]  *
M  +138  -64   kio/misc/kpac/proxyscout.cpp     
M  +5    -2    kio/misc/kpac/proxyscout.h     
M  +640  -376  kio/misc/kpac/script.cpp     
M  +3    -3    kio/misc/kpac/script.h     

The files marked with a * at the end have a non valid license. Please read: http://techbase.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


http://commits.kde.org/kdelibs/98946bcb75615b0900a2b2e124cae89b7c323fd0
Comment 2 Kanwar Plaha 2011-04-07 14:29:54 UTC
Thanks! Can't wait for 4.7 to test it. Will it make to to the first beta?
Comment 3 Dawit Alemayehu 2011-04-07 14:48:52 UTC
(In reply to comment #2)
> Thanks! Can't wait for 4.7 to test it. Will it make to to the first beta?

Yes. I actually welcome any real world production enviornment testing this code can recieve because I have no means of testing it in that scenario, especially the automatic proxy configuration through DHCP and/or DNS poritions. 

If things still do not work for you when the 4.7 beta cycle starts, please reopen this ticket again.