Bug 267097

Summary: Marble crashes when zooming with mouse wheel (just after install)
Product: marble Reporter: Emmanuel <emmanuelduviviers49>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: normal CC: nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Emmanuel 2011-02-24 21:39:07 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-gentoo x86_64

-- Information about the crash:
Marble is installed via gentoo's portage system
I launched marble (via command line and KDE's menu)
I zoomed with the mouse wheel : at the beginning, it works but arriving at a certain level of zoom the application crashes.

It is important to note that now, the bug can no more be reproduced : I configured Marble to use another Map (Open Street Map) and it seems that one or many better config files prevent the application from crashing.

But using another user acount, the crash is still there, so there may be a problem with the config file(s).

I think this portion of the backtrace may be usefull even if it is not complete :
Thread 1 (Thread 0x7f91d6226760 (LWP 29081)):
[KCrash Handler]
#6  0x00007f91d586b5f1 in ?? () from /usr/lib/libmarblewidget.so.11
#7  0x00007f91d586d6e5 in ?? () from /usr/lib/libmarblewidget.so.11
#8  0x00007f91d586d8f2 in ?? () from /usr/lib/libmarblewidget.so.11
#9  0x00007f91d57daa59 in ?? () from /usr/lib/libmarblewidget.so.11
#10 0x00007f91d57cdf88 in Marble::MarbleWidget::paintEvent(QPaintEvent*) () from /usr/lib/libmarblewidget.so.11
#11 0x00007f91d36f8d0d in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#12 0x00007f91d36a34ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007f91d36a88ed in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#14 0x00007f91d4d97226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#15 0x00007f91d42fb5eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f91d36ff70d in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007f91d38d214e in ?? () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007f91d36f2df0 in QWidgetPrivate::syncBackingStore() () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007f91d36f93da in QWidget::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007f91d3abd04b in QMainWindow::event(QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007f91d4eadfd3 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x00007f91d36a34ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007f91d36a88ed in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#24 0x00007f91d4d97226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#25 0x00007f91d42fb5eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007f91d38cf517 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#27 0x00007f91d38d283f in ?? () from /usr/lib64/qt4/libQtGui.so.4
#28 0x00007f91d36f4f5b in QWidget::repaint(QRect const&) () from /usr/lib64/qt4/libQtGui.so.4
#29 0x00007f91d36f5023 in QWidget::repaint() () from /usr/lib64/qt4/libQtGui.so.4
#30 0x00007f91d57f56f6 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt(Marble::MarbleWidget*, QPoint const&, double) () from /usr/lib/libmarblewidget.so.11
#31 0x00007f91d57f8205 in Marble::MarbleWidgetDefaultInputHandler::eventFilter(QObject*, QEvent*) () from /usr/lib/libmarblewidget.so.11
#32 0x00007f91d42fae36 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007f91d36a347c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#34 0x00007f91d36a8fa3 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#35 0x00007f91d4d97226 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#36 0x00007f91d42fb5eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#37 0x00007f91d371b8d7 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#38 0x00007f91d372c63d in ?? () from /usr/lib64/qt4/libQtGui.so.4
#39 0x00007f91d372b09a in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#40 0x00007f91d37553f2 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#41 0x00007f91cd76c3d1 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#42 0x00007f91cd770308 in ?? () from /usr/lib/libglib-2.0.so.0
#43 0x00007f91cd7704bc in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#44 0x00007f91d43275d3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#45 0x00007f91d3754d6e in ?? () from /usr/lib64/qt4/libQtGui.so.4
#46 0x00007f91d42fa342 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#47 0x00007f91d42fa724 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#48 0x00007f91d42fe79b in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#49 0x0000000000422d23 in _start ()


Reproducible: Sometimes

Steps to Reproduce:
Relaunch the application, zoom in with mouse wheel on the Globe

Actual Results:  
At a certain level of zoom, the application crashes.

Expected Results:  
The zoom continues to work

With the firsts levels of zoom, everything is OK but at a certain level a crash occurs.

The bug only appears with a non configured install.
Comment 1 Dennis Nienhüser 2011-02-27 10:45:07 UTC
Sounds odd, but a small window size in combination with the download progress bar appearing triggers the crash. Shouldn't happen when you maximize the window (just a workaround of course).

*** This bug has been marked as a duplicate of bug 265599 ***