Bug 263220

Summary: crash occured when I restarted the network
Product: Network Management Reporter: m.wege
Component: Plasma WidgetAssignee: Sebastian K├╝gler <sebas>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, wstephenson
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description m.wege 2011-01-15 13:49:18 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.37-11-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: crash occured when I restarted the network.crash occured when I restarted the network

-- Backtrace:
Application: Plasma-Desktop-Umgebung (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2814940 (LWP 4939))]

Thread 5 (Thread 0xa97e0b70 (LWP 5019)):
#0  0xb7809424 in __kernel_vsyscall ()
#1  0xb76d8df6 in poll () from /lib/libc.so.6
#2  0xb36c3a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb36b643c in ?? () from /lib/libglib-2.0.so.0
#4  0xb36b6848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb663d59f in QEventDispatcherGlib::processEvents (this=0x9d57568, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0xb660d609 in QEventLoop::processEvents (this=0xa97e0280, flags=) at kernel/qeventloop.cpp:149
#7  0xb660da8a in QEventLoop::exec (this=0xa97e0280, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6509b7e in QThread::exec (this=0x9db33b0) at thread/qthread.cpp:490
#9  0xb65ec35b in QInotifyFileSystemWatcherEngine::run (this=0x9db33b0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb650cdf9 in QThreadPrivate::start (arg=0x9db33b0) at thread/qthread_unix.cpp:266
#11 0xb3758cc9 in start_thread () from /lib/libpthread.so.0
#12 0xb76e769e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa8fdfb70 (LWP 5020)):
#0  0xb375b3eb in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb76f4f66 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb36b5ea3 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0xb36b6279 in ?? () from /lib/libglib-2.0.so.0
#4  0xb36b6848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb663d59f in QEventDispatcherGlib::processEvents (this=0x9ce7f30, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0xb660d609 in QEventLoop::processEvents (this=0xa8fdf2a0, flags=) at kernel/qeventloop.cpp:149
#7  0xb660da8a in QEventLoop::exec (this=0xa8fdf2a0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6509b7e in QThread::exec (this=0x9de4c78) at thread/qthread.cpp:490
#9  0xb302b171 in Herqq::Upnp::HControlPointThread::run() () from /usr/lib/libHUpnp.so.0
#10 0xb650cdf9 in QThreadPrivate::start (arg=0x9de4c78) at thread/qthread_unix.cpp:266
#11 0xb3758cc9 in start_thread () from /lib/libpthread.so.0
#12 0xb76e769e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa768cb70 (LWP 5021)):
#0  0xb3747e36 in clock_gettime () from /lib/librt.so.1
#1  0xb656850b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb663f6e5 in QTimerInfoList::updateCurrentTime (this=0x9eb472c) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb663f72a in QTimerInfoList::timerWait (this=0x9eb472c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb663d7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xa768c0ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb663d83d in timerSourcePrepare (source=0x0, timeout=0xb374bff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb36b5e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb36b6279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb36b6848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb663d59f in QEventDispatcherGlib::processEvents (this=0x9b5fb80, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb660d609 in QEventLoop::processEvents (this=0xa768c280, flags=) at kernel/qeventloop.cpp:149
#12 0xb660da8a in QEventLoop::exec (this=0xa768c280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6509b7e in QThread::exec (this=0x9e4bb90) at thread/qthread.cpp:490
#14 0xb65ec35b in QInotifyFileSystemWatcherEngine::run (this=0x9e4bb90) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb650cdf9 in QThreadPrivate::start (arg=0x9e4bb90) at thread/qthread_unix.cpp:266
#16 0xb3758cc9 in start_thread () from /lib/libpthread.so.0
#17 0xb76e769e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa3f77b70 (LWP 6480)):
#0  0xb7809424 in __kernel_vsyscall ()
#1  0xb375d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb76f4d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb45d3877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb46d21a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb45d38c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb46d21a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb3758cc9 in start_thread () from /lib/libpthread.so.0
#6  0xb76e769e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2814940 (LWP 4939)):
[KCrash Handler]
#7  0x09d509e8 in ?? ()
#8  0xaf40609d in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#9  0xaf406a6b in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#10 0xaf40572b in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#11 0xaf3fa339 in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#12 0xaf3fac6a in ?? () from /usr/lib/kde4/plasma_applet_networkmanagement.so
#13 0xb66148ca in QMetaObject::metacall (object=0x9dd2ec0, cl=2940313588, idx=185757097, argv=0xb126da9) at kernel/qmetaobject.cpp:237
#14 0xb66276ad in QMetaObject::activate (sender=0x9cd6dd8, m=0xaf37366c, local_signal_index=3, argv=0xa638b30) at kernel/qobject.cpp:3280
#15 0xaf35756f in Solid::Control::NetworkInterface::connectionStateChanged (this=0x9cd6dd8, _t1=3, _t2=8, _t3=38) at ./networkinterface.moc:157
#16 0xaf3576eb in Solid::Control::NetworkInterface::qt_metacall (this=0x9cd6dd8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfbf6a70) at ./networkinterface.moc:125
#17 0xaf35cb7a in Solid::Control::WirelessNetworkInterface::qt_metacall (this=0x9cd6dd8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfbf6a70) at ./wirelessnetworkinterface.moc:105
#18 0xb66148ca in QMetaObject::metacall (object=0x9cd6dd8, cl=2940313588, idx=7, argv=0xbfbf6a70) at kernel/qmetaobject.cpp:237
#19 0xb66276ad in QMetaObject::activate (sender=0x9c38e70, m=0xaf33ca14, local_signal_index=2, argv=0xa638b30) at kernel/qobject.cpp:3280
#20 0xaf328c6f in NMNetworkInterface::connectionStateChanged (this=0x9c38e70, _t1=3, _t2=8, _t3=38) at ./networkinterface.moc:185
#21 0xaf328bd1 in NMNetworkInterface::stateChanged (this=0x9c38e70, new_state=3, old_state=8, reason=38) at ../../../solid/networkmanager-0.7/networkinterface.cpp:254
#22 0xaf329ff0 in NMNetworkInterface::qt_metacall (this=0x9c38e70, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfbf6c80) at ./networkinterface.moc:121
#23 0xaf31ed4a in NMWirelessNetworkInterface::qt_metacall (this=0x9c38e70, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbfbf6c80) at moc_wirelessnetworkinterface.cpp:88
#24 0xb66148ca in QMetaObject::metacall (object=0x9c38e70, cl=2940313588, idx=7, argv=0xbfbf6c80) at kernel/qmetaobject.cpp:237
#25 0xb66276ad in QMetaObject::activate (sender=0x9cb6e40, m=0xaf33dae4, local_signal_index=0, argv=0xa638b30) at kernel/qobject.cpp:3280
#26 0xaf333ddf in OrgFreedesktopNetworkManagerDeviceInterface::StateChanged (this=0x9cb6e40, _t1=3, _t2=8, _t3=38) at ./nm-deviceinterface.moc:134
#27 0xaf333e64 in OrgFreedesktopNetworkManagerDeviceInterface::qt_metacall (this=0x9cb6e40, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbf6e8c) at ./nm-deviceinterface.moc:90
#28 0xb67629dc in QDBusConnectionPrivate::deliverCall (this=0x95bab00, object=0x9cb6e40, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#29 0xb676e1f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9ceb478, object=0x9cb6e40) at qdbusintegrator_p.h:103
#30 0xb66216a2 in QObject::event (this=0x9cb6e40, e=0xb103d48) at kernel/qobject.cpp:1219
#31 0xb5b0dfdc in QApplicationPrivate::notify_helper (this=0x9580910, receiver=0x9cb6e40, e=0x9ceb478) at kernel/qapplication.cpp:4396
#32 0xb5b1404e in QApplication::notify (this=0x955da60, receiver=0x9cb6e40, e=0x9ceb478) at kernel/qapplication.cpp:3798
#33 0xb6c6ff8a in KApplication::notify (this=0x955da60, receiver=0x9cb6e40, event=0x9ceb478) at ../../kdeui/kernel/kapplication.cpp:311
#34 0xb660eb3b in QCoreApplication::notifyInternal (this=0x955da60, receiver=0x9cb6e40, event=0x9ceb478) at kernel/qcoreapplication.cpp:732
#35 0xb6611d8b in sendEvent (receiver=0x0, event_type=0, data=0x9520620) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9520620) at kernel/qcoreapplication.cpp:1373
#37 0xb6611f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#38 0xb663da74 in sendPostedEvents (s=0x9582d20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=0x9582d20) at kernel/qeventdispatcher_glib.cpp:277
#40 0xb36b2855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0xb36b6668 in ?? () from /lib/libglib-2.0.so.0
#42 0xb36b6848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0xb663d565 in QEventDispatcherGlib::processEvents (this=0x95566f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#44 0xb5bcfbe5 in QGuiEventDispatcherGlib::processEvents (this=0x95566f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0xb660d609 in QEventLoop::processEvents (this=0xbfbf76b4, flags=) at kernel/qeventloop.cpp:149
#46 0xb660da8a in QEventLoop::exec (this=0xbfbf76b4, flags=...) at kernel/qeventloop.cpp:201
#47 0xb661200f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#48 0xb5b0ce07 in QApplication::exec () at kernel/qapplication.cpp:3672
#49 0xb77c9fb7 in kdemain (argc=1, argv=0xbfbf78c4) at ../../../../plasma/desktop/shell/main.cpp:118
#50 0x080485bb in main (argc=1, argv=0xbfbf78c4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 240285.

Possible duplicates by query: bug 257113.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-23 16:25:10 UTC
[Comment from a bug triager]
Likely to be bug 240285. Merging. Thanks

*** This bug has been marked as a duplicate of bug 240285 ***