Bug 262825

Summary: kdeinit4 (Kde daemon) crash whes system starts
Product: [Frameworks and Libraries] solid Reporter: Michal Pokorny <miki>
Component: libsolid-udisksAssignee: Lukáš Tinkl <lukas>
Status: RESOLVED FIXED    
Severity: crash CC: miki, wstephenson
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Michal Pokorny 2011-01-11 06:53:48 UTC
Application: kded4 ($Id: kded.cpp 1204125 2010-12-06 11:17:10Z dfaure $)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

login in into kde

- Unusual behavior I noticed:

startup is extremly slow (after login) and before desktop is shown, there is a crash window (kdeinit4)

(krusader starts extremly slow too)

after start up other things work ok

The crash can be reproduced every time.

-- Backtrace:
Application: KDE démon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f614e133760 (LWP 3852))]

Thread 2 (Thread 0x7f61321f7710 (LWP 3951)):
#0  0x00007f614b80e6b3 in poll () from /lib64/libc.so.6
#1  0x00007f6148680fd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6148681510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f614ce04ae6 in QEventDispatcherGlib::processEvents (this=0x8667b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f614cdd9262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f614cdd9475 in QEventLoop::exec (this=0x7f61321f6d20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f614ccec1a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f614cdba918 in QInotifyFileSystemWatcherEngine::run (this=0x887de0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f614cceea1e in QThreadPrivate::start (arg=0x887de0) at thread/qthread_unix.cpp:285
#9  0x00007f61401e7ae3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007f614ca5fa4f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f614b81782d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f614e133760 (LWP 3852)):
[KCrash Handler]
#6  QList (this=0x48) at ../../src/corelib/tools/qlist.h:118
#7  QDBusMessage::arguments (this=0x48) at qdbusmessage.cpp:706
#8  0x00007f6149c5641d in QDBusPendingReplyData::argumentAt (this=0x7fffcdeecd10, index=0) at qdbuspendingreply.cpp:270
#9  0x00007f61457a7d48 in argumentAt<0> (this=0x7fffcdeed240) at /usr/include/QtDBus/qdbuspendingreply.h:176
#10 value (this=0x7fffcdeed240) at /usr/include/QtDBus/qdbuspendingreply.h:181
#11 Solid::Backends::UDisks::UDisksDevice::allProperties (this=0x7fffcdeed240) at /usr/src/debug/kdelibs-4.5.95/solid/solid/backends/udisks/udisksdevice.cpp:703
#12 0x00007f61457a847b in Solid::Backends::UDisks::UDisksDevice::checkCache (this=0x7fffcdeed240, key=...) at /usr/src/debug/kdelibs-4.5.95/solid/solid/backends/udisks/udisksdevice.cpp:671
#13 0x00007f61457a8706 in Solid::Backends::UDisks::UDisksDevice::property (this=0x7fffcdeed240, key=...) at /usr/src/debug/kdelibs-4.5.95/solid/solid/backends/udisks/udisksdevice.cpp:687
#14 0x00007f61457ab9c4 in Solid::Backends::UDisks::UDisksDevice::queryDeviceInterface (this=0x7fffcdeed240, type=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.95/solid/solid/backends/udisks/udisksdevice.cpp:157
#15 0x00007f61457a3da0 in Solid::Backends::UDisks::UDisksManager::devicesFromQuery (this=<value optimized out>, parentUdi=<value optimized out>, type=Solid::DeviceInterface::StorageVolume)
    at /usr/src/debug/kdelibs-4.5.95/solid/solid/backends/udisks/udisksmanager.cpp:123
#16 0x00007f614574e845 in Solid::Device::listFromType (type=@0x7fffcdeed47c, parentUdi=...) at /usr/src/debug/kdelibs-4.5.95/solid/solid/devicemanager.cpp:112
#17 0x00007f61321fd263 in DeviceAutomounter::init (this=0x8bc5d0) at /usr/src/debug/kdebase-runtime-4.5.95/solid-device-automounter/kded/DeviceAutomounter.cpp:53
#18 0x00007f61321fb762 in DeviceAutomounter::qt_metacall (this=0x8bc5d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x9a3c10)
    at /usr/src/debug/kdebase-runtime-4.5.95/build/solid-device-automounter/kded/moc_DeviceAutomounter.cpp:76
#19 0x00007f614cdedc6a in QObject::event (this=0x8bc5d0, e=<value optimized out>) at kernel/qobject.cpp:1211
#20 0x00007f614bf7acd4 in QApplicationPrivate::notify_helper (this=0x6f2ff0, receiver=0x8bc5d0, e=0x9606c0) at kernel/qapplication.cpp:4445
#21 0x00007f614bf831ca in QApplication::notify (this=<value optimized out>, receiver=0x8bc5d0, e=0x9606c0) at kernel/qapplication.cpp:4324
#22 0x00007f614da8eec6 in KApplication::notify (this=0x7fffcdeedf20, receiver=0x8bc5d0, event=0x9606c0) at /usr/src/debug/kdelibs-4.5.95/kdeui/kernel/kapplication.cpp:311
#23 0x00007f614cdd9e2c in QCoreApplication::notifyInternal (this=0x7fffcdeedf20, receiver=0x8bc5d0, event=0x9606c0) at kernel/qcoreapplication.cpp:732
#24 0x00007f614cddd625 in sendEvent (receiver=0x0, event_type=0, data=0x610420) at kernel/qcoreapplication.h:215
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x610420) at kernel/qcoreapplication.cpp:1373
#26 0x00007f614ce048f3 in sendPostedEvents (s=0x6f6930) at kernel/qcoreapplication.h:220
#27 postEventSourceDispatch (s=0x6f6930) at kernel/qeventdispatcher_glib.cpp:277
#28 0x00007f6148680a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f6148681270 in ?? () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f6148681510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f614ce04a8f in QEventDispatcherGlib::processEvents (this=0x6e1cb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f614c01feae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f614cdd9262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f614cdd9475 in QEventLoop::exec (this=0x7fffcdeede70, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f614cddd8db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#36 0x00007f613c0fc6d7 in kdemain (argc=1, argv=0x6ad3d0) at /usr/src/debug/kdelibs-4.5.95/kded/kded.cpp:925
#37 0x0000000000407609 in launch (argc=1, _name=0x40b512 "kded4", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40b397 "0") at /usr/src/debug/kdelibs-4.5.95/kinit/kinit.cpp:730
#38 0x0000000000409e2e in main (argc=4, argv=0x7fffcdeeef78, envp=0x7fffcdeeefa0) at /usr/src/debug/kdelibs-4.5.95/kinit/kinit.cpp:1845

Reported using DrKonqi
Comment 1 Lukáš Tinkl 2011-01-11 15:30:55 UTC
Missing udisks dependency, see bug #261742

*** This bug has been marked as a duplicate of bug 261742 ***
Comment 2 Michal Pokorny 2011-01-11 16:35:09 UTC
udisks is installed and running ( udisks-daemon and udisks-daemon: )
version 1.0.1-2.1.1-x86_64

this is not the solution
Comment 3 Will Stephenson 2011-01-12 12:33:11 UTC
Same crash here in the Solid KRunner when querying for something not-solid-related. udisks installed and running.
Comment 4 Will Stephenson 2011-01-12 12:35:40 UTC
See thread 3's stacktrace:

Application: Run Command Interface (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0xb58ab710 (LWP 10121))]

Thread 6 (Thread 0xb003fb70 (LWP 10128)):
#0  0xb5a86137 in __i686.get_pc_thunk.bx () from /lib/libglib-2.0.so.0
#1  0xb5adffac in g_thread_self () at gthread.c:2112
#2  0xb5ab3e37 in g_main_context_acquire (context=0x814dff0) at gmain.c:2518
#3  0xb5ab567d in g_main_context_iterate (context=0x814dff0, block=1, dispatch=1, self=0x80a0c28) at gmain.c:3031
#4  0xb5ab5dee in g_main_context_iteration (context=0x814dff0, may_block=1) at gmain.c:3150
#5  0xb6e5c787 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6e2d29d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6e2d4c9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6d2e7b9 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb6e0d22d in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6d313aa in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6cb6b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5fd3b7e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xa8f36b70 (LWP 11734)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6cbb105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6d31ab0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb31d287a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8115970, th=0x8392cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0xb31d67ba in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x814ffb0, th=0x8392cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#5  0xb31d27f9 in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8115970, th=0x8392cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#6  0xb31d675e in ThreadWeaver::WorkingHardState::applyForWork (this=0x814ffb0, th=0x8392cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb31d27d2 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8115970, th=0x8392cf0, previous=0x85c1cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb31d4351 in ThreadWeaver::ThreadRunHelper::run (this=0xa8f36314, parent=0x8115970, th=0x8392cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:87
#9  0xb31d460b in ThreadWeaver::Thread::run (this=0x8392cf0) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:142
#10 0xb6d313aa in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6cb6b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5fd3b7e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa8735b70 (LWP 11735)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6cbb105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6d31ab0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb31d287a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8115970, th=0x84ced88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0xb31d67ba in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x814ffb0, th=0x84ced88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#5  0xb31d27f9 in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8115970, th=0x84ced88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#6  0xb31d675e in ThreadWeaver::WorkingHardState::applyForWork (this=0x814ffb0, th=0x84ced88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb31d27d2 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8115970, th=0x84ced88, previous=0x8542a88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb31d4351 in ThreadWeaver::ThreadRunHelper::run (this=0xa8735314, parent=0x8115970, th=0x84ced88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:87
#9  0xb31d460b in ThreadWeaver::Thread::run (this=0x84ced88) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:142
#10 0xb6d313aa in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6cb6b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5fd3b7e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa7f34b70 (LWP 11736)):
[KCrash Handler]
#7  0xffffe430 in __kernel_vsyscall ()
#8  0xb5f2b8bf in raise () from /lib/libc.so.6
#9  0xb5f2d200 in abort () from /lib/libc.so.6
#10 0xb5ba7015 in ?? () from /lib/libdbus-1.so.3
#11 0xb5b9c921 in ?? () from /lib/libdbus-1.so.3
#12 0xb5b929ae in dbus_pending_call_block () from /lib/libdbus-1.so.3
#13 0xb6f83063 in ?? () from /usr/lib/libQtDBus.so.4
#14 0xb6fc6fc2 in ?? () from /usr/lib/libQtDBus.so.4
#15 0xb529c71b in Solid::Backends::UDisks::UDisksDevice::allProperties (this=0x8684b48) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/udisks/udisksdevice.cpp:702
#16 0xb529c480 in Solid::Backends::UDisks::UDisksDevice::checkCache (this=0x8684b48, key=...) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/udisks/udisksdevice.cpp:671
#17 0xb529c592 in Solid::Backends::UDisks::UDisksDevice::property (this=0x8684b48, key=...) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/udisks/udisksdevice.cpp:687
#18 0xb529b3f4 in Solid::Backends::UDisks::UDisksDevice::icon (this=0x8684b48) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/udisks/udisksdevice.cpp:532
#19 0xb529b591 in Solid::Backends::UDisks::UDisksDevice::icon (this=0x8403548) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/udisks/udisksdevice.cpp:549
#20 0xb523c820 in Solid::Device::icon (this=0x83b5c48) at /space/kde/sources/4_6/kdelibs/solid/solid/device.cpp:136
#21 0xa9d4752b in DeviceWrapper::icon (this=0x83b5c40) at /space/kde/sources/4_6/kdebase/workspace/plasma/generic/runners/solid/devicewrapper.cpp:110
#22 0xa9d43cf2 in SolidRunner::deviceMatch (this=0x83f5d68, device=0x83b5c40) at /space/kde/sources/4_6/kdebase/workspace/plasma/generic/runners/solid/solidrunner.cpp:209
#23 0xa9d439e7 in SolidRunner::createOrUpdateMatches (this=0x83f5d68, udiList=...) at /space/kde/sources/4_6/kdebase/workspace/plasma/generic/runners/solid/solidrunner.cpp:185
#24 0xa9d43413 in SolidRunner::match (this=0x83f5d68, context=...) at /space/kde/sources/4_6/kdebase/workspace/plasma/generic/runners/solid/solidrunner.cpp:114
#25 0xb4cb4638 in Plasma::AbstractRunner::performMatch (this=0x83f5d68, localContext=...) at /space/kde/sources/4_6/kdelibs/plasma/abstractrunner.cpp:136
#26 0xb4d63c92 in Plasma::FindMatchesJob::run (this=0x851e790) at /space/kde/sources/4_6/kdelibs/plasma/private/runnerjobs.cpp:159
#27 0xb31d4ee4 in ThreadWeaver::JobRunHelper::runTheJob (this=0xa7f3428c, th=0x84d1a68, job=0x851e790) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Job.cpp:106
#28 0xb31d5158 in ThreadWeaver::Job::execute (this=0x851e790, th=0x84d1a68) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Job.cpp:135
#29 0xb31d439e in ThreadWeaver::ThreadRunHelper::run (this=0xa7f34314, parent=0x8115970, th=0x84d1a68) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:95
#30 0xb31d460b in ThreadWeaver::Thread::run (this=0x84d1a68) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:142
#31 0xb6d313aa in ?? () from /usr/lib/libQtCore.so.4
#32 0xb6cb6b05 in start_thread () from /lib/libpthread.so.0
#33 0xb5fd3b7e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa7733b70 (LWP 11737)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6cbb105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6d31ab0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb31d287a in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8115970, th=0x84d95c8) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0xb31d67ba in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x814ffb0, th=0x84d95c8) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#5  0xb31d27f9 in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8115970, th=0x84d95c8) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#6  0xb31d675e in ThreadWeaver::WorkingHardState::applyForWork (this=0x814ffb0, th=0x84d95c8) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb31d27d2 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8115970, th=0x84d95c8, previous=0x8669f08) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb31d4351 in ThreadWeaver::ThreadRunHelper::run (this=0xa7733314, parent=0x8115970, th=0x84d95c8) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:87
#9  0xb31d460b in ThreadWeaver::Thread::run (this=0x84d95c8) at /space/kde/sources/4_6/kdelibs/threadweaver/Weaver/Thread.cpp:142
#10 0xb6d313aa in ?? () from /usr/lib/libQtCore.so.4
#11 0xb6cb6b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5fd3b7e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb58ab710 (LWP 10121)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6cbb105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6d31ab0 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb6d30ad5 in QThread::wait(unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb6dffd15 in QFileSystemWatcher::~QFileSystemWatcher() () from /usr/lib/libQtCore.so.4
#5  0xb6dffde2 in QFileSystemWatcher::~QFileSystemWatcher() () from /usr/lib/libQtCore.so.4
#6  0xb6e41cf4 in QObjectPrivate::deleteChildren() () from /usr/lib/libQtCore.so.4
#7  0xb6e46b7c in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#8  0xb52a772f in Solid::Backends::Fstab::FstabWatcher::~FstabWatcher (this=0x8151450, __in_chrg=<value optimized out>) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/fstab/fstabwatcher.cpp:48
#9  0xb52a7769 in Solid::Backends::Fstab::FstabWatcher::~FstabWatcher (this=0x8151450, __in_chrg=<value optimized out>) at /space/kde/sources/4_6/kdelibs/solid/solid/backends/fstab/fstabwatcher.cpp:51
#10 0xb52a75d7 in destroy () at /space/kde/sources/4_6/kdelibs/solid/solid/backends/fstab/fstabwatcher.cpp:30
#11 0xb5240211 in Solid::CleanUpGlobalStatic::~CleanUpGlobalStatic (this=0xb52cd8ec, __in_chrg=<value optimized out>) at /space/kde/sources/4_6/kdelibs/solid/solid/soliddefs_p.h:67
#12 0xb5f2e8bf in __run_exit_handlers () from /lib/libc.so.6
#13 0xb5f2e91d in exit () from /lib/libc.so.6
#14 0xb63b4198 in ?? () from /usr/lib/libQtGui.so.4
#15 0xb75c0263 in KApplication::xioErrhandler (this=0x80dd2d0, dpy=0x80f7000) at /space/kde/sources/4_6/kdelibs/kdeui/kernel/kapplication.cpp:417
#16 0xb75bf556 in kde_xio_errhandler (dpy=0x80f7000) at /space/kde/sources/4_6/kdelibs/kdeui/kernel/kapplication.cpp:126
#17 0xb72a74f4 in _XIOError () from /usr/lib/libX11.so.6
#18 0xb72a4ccf in _XEventsQueued () from /usr/lib/libX11.so.6
#19 0xb72953f8 in XEventsQueued () from /usr/lib/libX11.so.6
#20 0xb63f1375 in ?? () from /usr/lib/libQtGui.so.4
#21 0xb5ab4fa0 in g_main_context_check (context=0x80df698, max_priority=0, fds=0x82bca68, n_fds=9) at gmain.c:2957
#22 0xb5ab58e8 in g_main_context_iterate (context=0x80df698, block=1, dispatch=1, self=0x80dd598) at gmain.c:3084
#23 0xb5ab5dee in g_main_context_iteration (context=0x80df698, may_block=1) at gmain.c:3150
#24 0xb6e5c73b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0xb63f153a in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6e2d29d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0xb6e2d4c9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb6e31f70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0xb6339124 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0xb25be911 in kdemain (argc=1, argv=0x80a0a30) at /space/kde/sources/4_6/kdebase/workspace/krunner/main.cpp:65
#31 0x0804de40 in launch (argc=1, _name=0x805d04c "/space/kde/installs/4_6/bin/krunner", args=0x805d070 "", cwd=0x0, envc=0, envs=0x805d074 "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x80530cf "0") at /space/kde/sources/4_6/kdelibs/kinit/kinit.cpp:730
#32 0x0804eed5 in handle_launcher_request (sock=8, who=0x8053368 "launcher") at /space/kde/sources/4_6/kdelibs/kinit/kinit.cpp:1222
#33 0x0804f616 in handle_requests (waitForPid=0) at /space/kde/sources/4_6/kdelibs/kinit/kinit.cpp:1415
#34 0x08050f38 in main (argc=4, argv=0xbf8533e4, envp=0xbf8533f8) at /space/kde/sources/4_6/kdelibs/kinit/kinit.cpp:1903
Comment 5 Lukáš Tinkl 2011-01-12 14:12:30 UTC
SVN commit 1213993 by lukas:

add a crash guard

CCBUG: 262825


 M  +4 -0      udisksdevice.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1213993
Comment 6 Lukáš Tinkl 2011-01-12 14:39:03 UTC
SVN commit 1213999 by lukas:

forward port, add a crash guard
(bille says it fixes the bug :)

BUG: 262825


 M  +4 -0      udisksdevice.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1213999