Bug 262675

Summary: was renaming a file when crash happened
Product: dolphin Reporter: m.wege
Component: generalAssignee: Peter Penz <peter.penz19>
Status: RESOLVED DUPLICATE    
Severity: crash CC: frank78ac
Priority: NOR    
Version: 16.12.2   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description m.wege 2011-01-09 17:55:03 UTC
Application: dolphin (1.6)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.37-11-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: was renaming a file when crash happened. was renaming a file when crash happened.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4afe970 (LWP 15411))]

Thread 5 (Thread 0xb232fb70 (LWP 15412)):
#0  0xb51b4e36 in clock_gettime () from /lib/librt.so.1
#1  0xb5c3d50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb5d146e5 in QTimerInfoList::updateCurrentTime (this=0x9521f94) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb5d1472a in QTimerInfoList::timerWait (this=0x9521f94, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb5d127a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb232f0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb5d1283d in timerSourcePrepare (source=0x0, timeout=0xb51b8ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5329e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb532a279 in ?? () from /lib/libglib-2.0.so.0
#9  0xb532a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb5d1259f in QEventDispatcherGlib::processEvents (this=0x952b3b8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0xb5ce2609 in QEventLoop::processEvents (this=0xb232f290, flags=) at kernel/qeventloop.cpp:149
#12 0xb5ce2a8a in QEventLoop::exec (this=0xb232f290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb5bdeb7e in QThread::exec (this=0x94e4940) at thread/qthread.cpp:490
#14 0xb5cc135b in QInotifyFileSystemWatcherEngine::run (this=0x94e4940) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb5be1df9 in QThreadPrivate::start (arg=0x94e4940) at thread/qthread_unix.cpp:266
#16 0xb53d4cc9 in start_thread () from /lib/libpthread.so.0
#17 0xb77a569e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb1aaeb70 (LWP 15413)):
#0  0xb53299f6 in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0xb532a45e in ?? () from /lib/libglib-2.0.so.0
#2  0xb532a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb5d1259f in QEventDispatcherGlib::processEvents (this=0x95679f8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0xb5ce2609 in QEventLoop::processEvents (this=0xb1aae2b0, flags=) at kernel/qeventloop.cpp:149
#5  0xb5ce2a8a in QEventLoop::exec (this=0xb1aae2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0xb5bdeb7e in QThread::exec (this=0x952fae0) at thread/qthread.cpp:490
#7  0xb514a171 in Herqq::Upnp::HControlPointThread::run() () from /usr/lib/libHUpnp.so.0
#8  0xb5be1df9 in QThreadPrivate::start (arg=0x952fae0) at thread/qthread_unix.cpp:266
#9  0xb53d4cc9 in start_thread () from /lib/libpthread.so.0
#10 0xb77a569e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xafc2cb70 (LWP 15417)):
#0  0xb77b2f71 in pthread_mutex_unlock () from /lib/libc.so.6
#1  0xb532a4f9 in ?? () from /lib/libglib-2.0.so.0
#2  0xb532a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb5d1259f in QEventDispatcherGlib::processEvents (this=0x97ab080, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0xb5ce2609 in QEventLoop::processEvents (this=0xafc2c290, flags=) at kernel/qeventloop.cpp:149
#5  0xb5ce2a8a in QEventLoop::exec (this=0xafc2c290, flags=...) at kernel/qeventloop.cpp:201
#6  0xb5bdeb7e in QThread::exec (this=0x996b930) at thread/qthread.cpp:490
#7  0xb5cc135b in QInotifyFileSystemWatcherEngine::run (this=0x996b930) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb5be1df9 in QThreadPrivate::start (arg=0x996b930) at thread/qthread_unix.cpp:266
#9  0xb53d4cc9 in start_thread () from /lib/libpthread.so.0
#10 0xb77a569e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xadc28b70 (LWP 15709)):
#0  0xb78c6424 in __kernel_vsyscall ()
#1  0xb53d9884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb77b2df4 in pthread_cond_timedwait () from /lib/libc.so.6
#3  0xac85eb3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb4afe970 (LWP 15411)):
[KCrash Handler]
#7  operator!= (this=0x98b2f64, t=@0xbfa9265c) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:75
#8  QList<QTextCursorPrivate*>::append (this=0x98b2f64, t=@0xbfa9265c) at ../../include/QtCore/../../src/corelib/tools/qlist.h:495
#9  0xb64e2e52 in addCursor (this=0x9ce7920, rhs=...) at text/qtextdocument_p.h:279
#10 QTextCursorPrivate::QTextCursorPrivate (this=0x9ce7920, rhs=...) at text/qtextcursor.cpp:83
#11 0xb64e7dbd in clone (this=0x9cb88e8) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:215
#12 detach_helper (this=0x9cb88e8) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:221
#13 detach (this=0x9cb88e8) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:75
#14 operator-> (this=0x9cb88e8) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:78
#15 QTextCursor::removeSelectedText (this=0x9cb88e8) at text/qtextcursor.cpp:1621
#16 0xb64748b6 in QTextControlPrivate::startDrag (this=0x9cb8890) at text/qtextcontrol.cpp:527
#17 0xb647ad57 in QTextControlPrivate::mouseMoveEvent (this=0x9cb8890, buttons=..., mousePos=...) at text/qtextcontrol.cpp:1626
#18 0xb647f5ff in QTextControl::processEvent (this=0x9c0f5f0, e=0xbfa93150, matrix=..., contextWidget=0xa118548) at text/qtextcontrol.cpp:939
#19 0xb64744d0 in QTextControl::processEvent (this=0x9c0f5f0, e=0xbfa93150, coordinateOffset=..., contextWidget=0xa118548) at text/qtextcontrol.cpp:890
#20 0xb66f04fb in sendControlEvent (this=0xa164a98, e=0xbfa93150) at widgets/qtextedit_p.h:99
#21 QTextEdit::mouseMoveEvent (this=0xa164a98, e=0xbfa93150) at widgets/qtextedit.cpp:1560
#22 0xb6248caa in QWidget::event (this=0xa164a98, event=0xbfa93150) at kernel/qwidget.cpp:8172
#23 0xb666a763 in QFrame::event (this=0xa164a98, e=0xbfa93150) at widgets/qframe.cpp:557
#24 0xb6707a82 in QAbstractScrollArea::viewportEvent (this=0x0, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#25 0xb670a4d5 in viewportEvent (this=0xa1a4188, o=0xa118548, e=0xbfa93150) at widgets/qabstractscrollarea_p.h:100
#26 QAbstractScrollAreaFilter::eventFilter (this=0xa1a4188, o=0xa118548, e=0xbfa93150) at widgets/qabstractscrollarea_p.h:116
#27 0xb5ce329a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9400808, receiver=0xa118548, event=0xbfa93150) at kernel/qcoreapplication.cpp:847
#28 0xb61eafb9 in QApplicationPrivate::notify_helper (this=0x9400808, receiver=0xa118548, e=0xbfa93150) at kernel/qapplication.cpp:4392
#29 0xb61f1c2e in QApplication::notify (this=0xbfa93a10, receiver=0xa118548, e=0xbfa93150) at kernel/qapplication.cpp:3959
#30 0xb6d91f8a in KApplication::notify (this=0xbfa93a10, receiver=0xa118548, event=0xbfa93150) at ../../kdeui/kernel/kapplication.cpp:311
#31 0xb5ce3b3b in QCoreApplication::notifyInternal (this=0xbfa93a10, receiver=0xa118548, event=0xbfa93150) at kernel/qcoreapplication.cpp:732
#32 0xb61f0094 in sendEvent (receiver=0xa118548, event=0xbfa93150, alienWidget=0xa118548, nativeWidget=0x98809e8, buttonDown=0xb6b853c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#33 QApplicationPrivate::sendMouseEvent (receiver=0xa118548, event=0xbfa93150, alienWidget=0xa118548, nativeWidget=0x98809e8, buttonDown=0xb6b853c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#34 0xb627ed10 in QETWidget::translateMouseEvent (this=0x98809e8, event=0xbfa9366c) at kernel/qapplication_x11.cpp:4403
#35 0xb627e151 in QApplication::x11ProcessEvent (this=0xbfa93a10, event=0xbfa9366c) at kernel/qapplication_x11.cpp:3414
#36 0xb62ad36a in x11EventSourceDispatch (s=0x9402ef0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#37 0xb5326855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#38 0xb532a668 in ?? () from /lib/libglib-2.0.so.0
#39 0xb532a848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#40 0xb5d12565 in QEventDispatcherGlib::processEvents (this=0x93fd7c0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#41 0xb62acbe5 in QGuiEventDispatcherGlib::processEvents (this=0x93fd7c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb5ce2609 in QEventLoop::processEvents (this=0xbfa93964, flags=) at kernel/qeventloop.cpp:149
#43 0xb5ce2a8a in QEventLoop::exec (this=0xbfa93964, flags=...) at kernel/qeventloop.cpp:201
#44 0xb5ce700f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0xb61e9e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#46 0xb788a2ab in kdemain (argc=6, argv=0xbfa93c04) at ../../../../apps/dolphin/src/main.cpp:98
#47 0x080485ab in main (argc=6, argv=0xbfa93c04) at dolphin_dummy.cpp:3

Reported using DrKonqi
Comment 1 Frank Reininghaus 2011-03-17 18:50:21 UTC
Thanks for the bug report! There is another report with slightly more info -> marking as duplicate.

*** This bug has been marked as a duplicate of bug 268533 ***