Bug 262034

Summary: Marble widget crash
Product: [Applications] marble Reporter: Christian Korberl <ammonid>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: caulier.gilles, nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description Christian Korberl 2011-01-04 04:42:57 UTC
Application: digikam (1.7.0)
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-rc8-fs_27-Dec-2010 x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Every time that digiKam is launched, the splash screen is displayed and then the program crashes.  Prior to the KDE 4.6 RC1 upgrade, was successlly using digiKam on a daily bases.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fcc370f17c0 (LWP 11392))]

Thread 14 (Thread 0x7fcc1e7b5710 (LWP 11393)):
#0  0x00007fcc2eae739c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcc324b910b in wait (this=<value optimized out>, mutex=0x2b27680, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2b27680, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000005ebe45 in Digikam::ScanController::run (this=0x2d27cc0) at /usr/src/debug/digikam-1.7.0/digikam/scancontroller.cpp:571
#4  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2d27cc0) at thread/qthread_unix.cpp:285
#5  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7fcc1dfb4710 (LWP 11394)):
#0  0x00007fcc2eae6720 in pthread_mutex_unlock () from /lib64/libpthread.so.0
#1  0x00007fcc28dd8f72 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcc28dd9e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fcc28dda510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fcc325ceae6 in QEventDispatcherGlib::processEvents (this=0x2a461c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fcc325a3262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fcc325a3475 in QEventLoop::exec (this=0x7fcc1dfb3d80, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fcc324b61a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fcc32584918 in QInotifyFileSystemWatcherEngine::run (this=0x2d44480) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2d44480) at thread/qthread_unix.cpp:285
#10 0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7fcc1d7b3710 (LWP 11398)):
#0  0x00007fcc30b0f6b3 in poll () from /lib64/libc.so.6
#1  0x00007fcc28dd9fd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcc28dda510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fcc325ceae6 in QEventDispatcherGlib::processEvents (this=0x298dab0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fcc325a3262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcc325a3475 in QEventLoop::exec (this=0x7fcc1d7b2dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcc324b61a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2a28eb0) at thread/qthread_unix.cpp:285
#8  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7fcc1cda5710 (LWP 11399)):
#0  0x00007fcc30b0f6b3 in poll () from /lib64/libc.so.6
#1  0x00007fcc28dd9fd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcc28dda510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fcc325ceae6 in QEventDispatcherGlib::processEvents (this=0x2980b40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fcc325a3262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcc325a3475 in QEventLoop::exec (this=0x7fcc1cda4dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcc324b61a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2cc1c20) at thread/qthread_unix.cpp:285
#8  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fcc1c5a4710 (LWP 11400)):
#0  0x00007fcc2eae739c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcc324b910b in wait (this=<value optimized out>, mutex=0x2a4ff28, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2a4ff28, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fcc34a0c3c7 in Digikam::ParkingThread::run (this=0x2a4ff10) at /usr/src/debug/digikam-1.7.0/libs/threads/threadmanager.cpp:119
#4  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2a4ff10) at thread/qthread_unix.cpp:285
#5  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fcc1bda3710 (LWP 11401)):
#0  0x00007fcc2eae668e in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007fcc28dd9fc8 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcc28dda510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fcc325ceae6 in QEventDispatcherGlib::processEvents (this=0x2b57c30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fcc325a3262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcc325a3475 in QEventLoop::exec (this=0x7fcc1bda2dc0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fcc324b61a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2cbece0) at thread/qthread_unix.cpp:285
#8  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fcc1b5a2710 (LWP 11402)):
#0  0x00007fcc28dd9dac in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fcc28dda510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcc325ceae6 in QEventDispatcherGlib::processEvents (this=0x2c631b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007fcc325a3262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007fcc325a3475 in QEventLoop::exec (this=0x7fcc1b5a1dc0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007fcc324b61a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2a39ec0) at thread/qthread_unix.cpp:285
#7  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#8  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fcc16bf6710 (LWP 11403)):
#0  0x00007fcc2eae7709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcc182d7941 in ?? () from /usr/lib64/libxine.so.1
#2  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fcc157b9710 (LWP 11404)):
#0  0x00007fcc2eae7709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcc182e5aaf in ?? () from /usr/lib64/libxine.so.1
#2  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fcc14fb8710 (LWP 11405)):
#0  0x00007fcc2eae6678 in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007fcc28dd8eca in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fcc28dd9e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fcc28dda510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007fcc325ceae6 in QEventDispatcherGlib::processEvents (this=0x2bd0650, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fcc325a3262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fcc325a3475 in QEventLoop::exec (this=0x7fcc14fb7d70, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fcc324b61a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fcc185355e4 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#9  0x00007fcc324b8a1e in QThreadPrivate::start (arg=0x2ce54d0) at thread/qthread_unix.cpp:285
#10 0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fcc145ad710 (LWP 11409)):
#0  0x00007fcc30b0f6b3 in poll () from /lib64/libc.so.6
#1  0x00007fcc145b2907 in ?? () from /usr/lib64/xine/plugins/1.28/xineplug_ao_out_alsa.so
#2  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fcc13dac710 (LWP 11410)):
#0  0x00007fcc2eae739c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fcc182e9a6b in ?? () from /usr/lib64/libxine.so.1
#2  0x00007fcc2eae2a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007fcc30b1882d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcc134de710 (LWP 11411)):
#0  0xffffffffff600107 in ?? ()
#1  0x00007fcc134dda70 in ?? ()
#2  0x00007fff145ff79e in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fcc370f17c0 (LWP 11392)):
[KCrash Handler]
#6  ref (this=0x378aeb0) at /usr/include/QtCore/qatomic_x86_64.h:121
#7  QList (this=0x378aeb0) at /usr/include/QtCore/qlist.h:118
#8  Marble::GeoSceneTexture::downloadPolicies (this=0x378aeb0) at /usr/src/debug/kdeedu-4.5.90/marble/src/lib/geodata/scene/GeoSceneTexture.cpp:207
#9  0x00007fcc33bc2dc8 in Marble::MarbleModel::addDownloadPolicies (this=0x2a710d0, mapTheme=0x37e66b0) at /usr/src/debug/kdeedu-4.5.90/marble/src/lib/MarbleModel.cpp:552
#10 0x00007fcc33bc31c7 in Marble::MarbleModel::setMapTheme (this=0x2a710d0, mapTheme=0x37e66b0) at /usr/src/debug/kdeedu-4.5.90/marble/src/lib/MarbleModel.cpp:256
#11 0x00007fcc33bca143 in Marble::MarbleMap::setMapThemeId (this=0x29deed0, mapThemeId=<value optimized out>) at /usr/src/debug/kdeedu-4.5.90/marble/src/lib/MarbleMap.cpp:940
#12 0x00007fcc33bbef05 in Marble::MarbleWidget::setMapThemeId (this=0x2a62d50, mapThemeId=...) at /usr/src/debug/kdeedu-4.5.90/marble/src/lib/MarbleWidget.cpp:864
#13 0x00007fcc34a90f5a in Digikam::WorldMapWidget::setMapTheme (this=0x2b94de0, theme=<value optimized out>) at /usr/src/debug/digikam-1.7.0/libs/imageproperties/worldmapwidget.cpp:416
#14 0x00007fcc34a911a8 in Digikam::WorldMapWidget::readConfig (this=0x2b94de0, group=...) at /usr/src/debug/digikam-1.7.0/libs/imageproperties/worldmapwidget.cpp:370
#15 0x00007fcc34a8ec52 in Digikam::ImagePropertiesGPSTab::readConfig (this=0x2cf2da0) at /usr/src/debug/digikam-1.7.0/libs/imageproperties/imagepropertiesgpstab.cpp:215
#16 0x00007fcc34a8fc28 in Digikam::ImagePropertiesGPSTab::ImagePropertiesGPSTab (this=0x2cf2da0, parent=<value optimized out>)
    at /usr/src/debug/digikam-1.7.0/libs/imageproperties/imagepropertiesgpstab.cpp:197
#17 0x00007fcc34a81789 in Digikam::ImagePropertiesSideBar::ImagePropertiesSideBar (this=0x2d24aa0, parent=0x2c9c0d0, splitter=<value optimized out>, side=<value optimized out>, 
    mimimizedDefault=<value optimized out>) at /usr/src/debug/digikam-1.7.0/libs/imageproperties/imagepropertiessidebar.cpp:77
#18 0x000000000048c91b in Digikam::ImagePropertiesSideBarDB::ImagePropertiesSideBarDB (this=0x2d24aa0, parent=0x2c9c0d0, splitter=<value optimized out>, side=<value optimized out>, 
    mimimizedDefault=<value optimized out>) at /usr/src/debug/digikam-1.7.0/libs/imageproperties/imagepropertiessidebardb.cpp:86
#19 0x00000000005b2b77 in Digikam::DigikamView::DigikamView (this=0x2c9c0d0, parent=0x2a231a0, modelCollection=0x2ab0ac0) at /usr/src/debug/digikam-1.7.0/digikam/digikamview.cpp:189
#20 0x000000000058abed in Digikam::DigikamApp::setupView (this=0x2a231a0) at /usr/src/debug/digikam-1.7.0/digikam/digikamapp.cpp:515
#21 0x00000000005a364b in Digikam::DigikamApp::DigikamApp (this=0x2a231a0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /usr/src/debug/digikam-1.7.0/digikam/digikamapp.cpp:234
#22 0x000000000062dea3 in main (argc=41344624, argv=0x7fff145bfa78) at /usr/src/debug/digikam-1.7.0/digikam/main.cpp:177

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-01-06 12:44:30 UTC

*** This bug has been marked as a duplicate of bug 247420 ***