Bug 261994

Summary: KDevelop crashes on running cmake during an out-of-source build
Product: kdevplatform Reporter: tootse
Component: generalAssignee: kdevelop-bugs-null
Status: RESOLVED DUPLICATE    
Severity: crash CC: aleixpol
Priority: NOR    
Version: 0.9.94   
Target Milestone: 1.2.0   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description tootse 2011-01-03 20:39:27 UTC
Application: kdevelop (4.1.60)
KDE Platform Version: 4.5.90 (4.6 RC1)
Qt Version: 4.7.1
Operating System: Linux 2.6.36.2-4-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
In a separate terminal, I ran cmake with the CMakeLists.txt for the project configured for an out-of-source build

- Custom settings of the application:
* Handwritten CMake build files. 
* The project is a command-line project with no dependencies on kde libraries

The crash can be reproduced every time.

-- Backtrace:
Application: KDevelop (kdevelop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff0782ad760 (LWP 5002))]

Thread 8 (Thread 0x7ff060026710 (LWP 5003)):
#0  0x00007ff075248709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff0767e5072 in wait (this=<value optimized out>, mutex=0xee5d80, time=1000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xee5d80, time=1000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff072e833eb in KDevelop::DUChainPrivate::CleanupThread::run (this=0xee5d60) at /usr/src/debug/kdevplatform/language/duchain/duchain.cpp:283
#4  0x00007ff0767e4a1e in QThreadPrivate::start (arg=0xee5d60) at thread/qthread_unix.cpp:285
#5  0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00007ff07552a82d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7ff054a29710 (LWP 5006)):
#0  0x00007ff07524768e in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007ff06ff0a3d5 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff06ff0aedb in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff06ff0b510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007ff0768faae6 in QEventDispatcherGlib::processEvents (this=0x10ed8c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007ff0768cf262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007ff0768cf475 in QEventLoop::exec (this=0x7ff054a28e20, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007ff0767e21a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007ff0767e4a1e in QThreadPrivate::start (arg=0x1252a00) at thread/qthread_unix.cpp:285
#9  0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff07552a82d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ff054228710 (LWP 5007)):
#0  0x00007ff0755216b3 in poll () from /lib64/libc.so.6
#1  0x00007ff06ff0afd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff06ff0b510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff0768faae6 in QEventDispatcherGlib::processEvents (this=0x10ed4c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff0768cf262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff0768cf475 in QEventLoop::exec (this=0x7ff054227e20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff0767e21a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007ff0767e4a1e in QThreadPrivate::start (arg=0x1213a50) at thread/qthread_unix.cpp:285
#8  0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#9  0x00007ff07552a82d in clone () from /lib64/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ff051480710 (LWP 5010)):
#0  0x00007ff07524839c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff06128c634 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7ff0615ae180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007ff06128c669 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7ff0615bc254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#4  0x00007ff07552a82d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ff0506ff710 (LWP 5011)):
#0  0x00007ff0755216b3 in poll () from /lib64/libc.so.6
#1  0x00007ff06ff0afd4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ff06ff0b510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ff0768faae6 in QEventDispatcherGlib::processEvents (this=0x1b26870, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff0768cf262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff0768cf475 in QEventLoop::exec (this=0x7ff0506fede0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff0767e21a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007ff0768b0918 in QInotifyFileSystemWatcherEngine::run (this=0x1b267f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff0767e4a1e in QThreadPrivate::start (arg=0x1b267f0) at thread/qthread_unix.cpp:285
#9  0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff07552a82d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff04f354710 (LWP 5024)):
#0  0x00007ff07524839c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff0767e510b in wait (this=<value optimized out>, mutex=0xa33e90, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xa33e90, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff06d642254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xdd1620, th=0x17e91d0) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff06d6452a5 in waitForAvailableJob (this=0xab63f0, th=0x17e91d0) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0xab63f0, th=0x17e91d0) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007ff06d64264f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff04f353e30, parent=0xdd1620, th=0x17e91d0) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/Thread.cpp:87
#7  0x00007ff06d6426d8 in ThreadWeaver::Thread::run (this=0x17e91d0) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/Thread.cpp:142
#8  0x00007ff0767e4a1e in QThreadPrivate::start (arg=0x17e91d0) at thread/qthread_unix.cpp:285
#9  0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff07552a82d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff04eb53710 (LWP 5025)):
#0  0x00007ff07524839c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ff0767e510b in wait (this=<value optimized out>, mutex=0xa33e90, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xa33e90, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff06d642254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xdd1620, th=0x2cb2660) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007ff06d6452a5 in waitForAvailableJob (this=0xab63f0, th=0x2cb2660) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0xab63f0, th=0x2cb2660) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007ff06d6452be in ThreadWeaver::WorkingHardState::applyForWork (this=0xab63f0, th=0x2cb2660) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007ff06d64264f in ThreadWeaver::ThreadRunHelper::run (this=0x7ff04eb52e30, parent=0xdd1620, th=0x2cb2660) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/Thread.cpp:87
#8  0x00007ff06d6426d8 in ThreadWeaver::Thread::run (this=0x2cb2660) at /usr/src/debug/kdelibs-4.5.90/threadweaver/Weaver/Thread.cpp:142
#9  0x00007ff0767e4a1e in QThreadPrivate::start (arg=0x2cb2660) at thread/qthread_unix.cpp:285
#10 0x00007ff075243a4f in start_thread () from /lib64/libpthread.so.0
#11 0x00007ff07552a82d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff0782ad760 (LWP 5002)):
[KCrash Handler]
#6  QUrlPrivate::parse (this=0x4f6f2e0, parseOptions=QUrlPrivate::ParseAndSet) at io/qurl.cpp:3760
#7  0x00007ff076885bec in QUrl::scheme (this=0x7fff74c16590) at io/qurl.cpp:4430
#8  0x00007ff077ced424 in hasSubUrl (this=0x7fff74c16590) at /usr/src/debug/kdelibs-4.5.90/kdecore/io/kurl.cpp:961
#9  KUrl::hasSubUrl (this=0x7fff74c16590) at /usr/src/debug/kdelibs-4.5.90/kdecore/io/kurl.cpp:1006
#10 0x00007ff077d42eb6 in KUrl::addPath (this=0x7fff74c16590, _txt=...) at /usr/src/debug/kdelibs-4.5.90/kdecore/io/kurl.cpp:1315
#11 0x00007ff0734892f4 in KDevelop::AbstractFileManagerPlugin::Private::addJobItems (this=0xf96d90, job=0x4771d50, baseItem=0x4d49020, entries=<value optimized out>, forceRecursion=false)
    at /usr/src/debug/kdevplatform/project/abstractfilemanagerplugin.cpp:161
#12 0x00007ff07348a0c7 in KDevelop::AbstractFileManagerPlugin::qt_metacall (this=0xf9b9e0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff74c167b0)
    at /usr/src/debug/kdevplatform/build/project/abstractfilemanagerplugin.moc:117
#13 0x00007ff0768e4fef in QMetaObject::activate (sender=0x4771d50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff74c167b0) at kernel/qobject.cpp:3272
#14 0x00007ff07348b0b2 in KDevelop::FileManagerListJob::entries (this=<value optimized out>, _t1=0x4771d50, _t2=0x4d49020, _t3=<value optimized out>, _t4=false)
    at /usr/src/debug/kdevplatform/build/project/filemanagerlistjob.moc:101
#15 0x00007ff07348b146 in KDevelop::FileManagerListJob::slotResult (this=0x4771d50, job=0x5807f10) at /usr/src/debug/kdevplatform/project/filemanagerlistjob.cpp:75
#16 0x00007ff07348b3e4 in KDevelop::FileManagerListJob::qt_metacall (this=0x4771d50, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff74c16960)
    at /usr/src/debug/kdevplatform/build/project/filemanagerlistjob.moc:88
#17 0x00007ff0768e4fef in QMetaObject::activate (sender=0x5807f10, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff74c16960) at kernel/qobject.cpp:3272
#18 0x00007ff077cef652 in KJob::result (this=<value optimized out>, _t1=0x5807f10) at /usr/src/debug/kdelibs-4.5.90/build/kdecore/kjob.moc:194
#19 0x00007ff077cef690 in KJob::emitResult (this=0x5807f10) at /usr/src/debug/kdelibs-4.5.90/kdecore/jobs/kjob.cpp:312
#20 0x00007ff073f5de7d in KIO::SimpleJob::slotFinished (this=0x5807f10) at /usr/src/debug/kdelibs-4.5.90/kio/kio/job.cpp:525
#21 0x00007ff073f5dfb5 in KIO::ListJob::slotFinished (this=0x5807f10) at /usr/src/debug/kdelibs-4.5.90/kio/kio/job.cpp:2564
#22 0x00007ff073f376b9 in KIO::ListJob::qt_metacall (this=0x5807f10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff74c16c90)
    at /usr/src/debug/kdelibs-4.5.90/build/kio/jobclasses.moc:818
#23 0x00007ff0768e4fef in QMetaObject::activate (sender=0x2426be0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#24 0x00007ff073f760b1 in KIO::SlaveInterface::dispatch (this=0x2426be0, _cmd=<value optimized out>, rawdata=...) at /usr/src/debug/kdelibs-4.5.90/kio/kio/slaveinterface.cpp:173
#25 0x00007ff073f13a83 in KIO::SlaveInterface::dispatch (this=<value optimized out>) at /usr/src/debug/kdelibs-4.5.90/kio/kio/slaveinterface.cpp:89
#26 0x00007ff073f129f6 in KIO::Slave::gotInput (this=0x2426be0) at /usr/src/debug/kdelibs-4.5.90/kio/kio/slave.cpp:348
#27 0x00007ff073f1793c in KIO::Slave::qt_metacall (this=0x2426be0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff74c170e0)
    at /usr/src/debug/kdelibs-4.5.90/build/kio/slave.moc:82
#28 0x00007ff0768e4fef in QMetaObject::activate (sender=0x2479d00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#29 0x00007ff073f17717 in KIO::ConnectionPrivate::dequeue (this=0x4694350) at /usr/src/debug/kdelibs-4.5.90/kio/kio/connection.cpp:82
#30 0x00007ff073f177cd in KIO::Connection::qt_metacall (this=0x2479d00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x3e399d0)
    at /usr/src/debug/kdelibs-4.5.90/build/kio/connection.moc:79
#31 0x00007ff0768e3c6a in QObject::event (this=0x2479d00, e=<value optimized out>) at kernel/qobject.cpp:1211
#32 0x00007ff075c8dcd4 in QApplicationPrivate::notify_helper (this=0x656bd0, receiver=0x2479d00, e=0x1310460) at kernel/qapplication.cpp:4445
#33 0x00007ff075c961ca in QApplication::notify (this=<value optimized out>, receiver=0x2479d00, e=0x1310460) at kernel/qapplication.cpp:4324
#34 0x00007ff07700ac46 in KApplication::notify (this=0x7fff74c17ea0, receiver=0x2479d00, event=0x1310460) at /usr/src/debug/kdelibs-4.5.90/kdeui/kernel/kapplication.cpp:311
#35 0x0000000000405179 in _start ()

This bug may be a duplicate of or related to bug 260741.

Possible duplicates by query: bug 260741, bug 254697, bug 234804, bug 224337.

Reported using DrKonqi
Comment 1 Aleix Pol 2011-01-04 03:16:39 UTC
That's not a cmake project, it's crashing in AbstractFileManagerPlugin
Comment 2 tootse 2011-01-04 05:20:31 UTC
(In reply to comment #1)
> That's not a cmake project, it's crashing in AbstractFileManagerPlugin

I never said that it was a cmake project. I said that kdevelop would crash on running cmake for this project from a separate terminal. It could very well be crashing for a reason unrelated to cmake.
Comment 3 Milian Wolff 2011-01-04 12:51:05 UTC
try out the cmake manager, it should work better for you probably. Anyways, this is already tracked in a different bug report.

*** This bug has been marked as a duplicate of bug 260741 ***
Comment 4 tootse 2011-01-04 17:18:05 UTC
(In reply to comment #3)
> try out the cmake manager, it should work better for you probably. Anyways,
> this is already tracked in a different bug report.
> 
> *** This bug has been marked as a duplicate of bug 260741 ***

Will try your suggestion.