Bug 261887

Summary: plasma crash
Product: [Plasma] plasma4 Reporter: kdekda <teabof>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description kdekda 2011-01-02 18:45:14 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
i was using Eclipse (Java IDE) and kpackage kit crashed when i clicked on its tray icon

-- Backtrace:
Application: Spazio di lavoro di Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb6163a30 (LWP 3279))]

Thread 6 (Thread 0xad0b9b70 (LWP 3282)):
#0  0x08247e36 in clock_gettime () from /lib/librt.so.1
#1  0x0778a50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x078616e5 in QTimerInfoList::updateCurrentTime (this=0xae001934) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0786172a in QTimerInfoList::timerWait (this=0xae001934, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0785f7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xad0b8ffc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0785f83d in timerSourcePrepare (source=0x0, timeout=0x824bff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0165fe6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x01660279 in ?? () from /lib/libglib-2.0.so.0
#9  0x01660848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0785f59f in QEventDispatcherGlib::processEvents (this=0x878ec40, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0782f609 in QEventLoop::processEvents (this=0xad0b91d0, flags=) at kernel/qeventloop.cpp:149
#12 0x0782fa8a in QEventLoop::exec (this=0xad0b91d0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0772bb7e in QThread::exec (this=0x878e9b8) at thread/qthread.cpp:490
#14 0x0780e35b in QInotifyFileSystemWatcherEngine::run (this=0x878e9b8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0772edf9 in QThreadPrivate::start (arg=0x878e9b8) at thread/qthread_unix.cpp:266
#16 0x01507ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 5 (Thread 0xab499b70 (LWP 12514)):
#0  0x009e5416 in __kernel_vsyscall ()
#1  0x0093d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x001edd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0772f9c7 in wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00954030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9335b68, th=0x9333550) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x009577dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9335c58, th=0x9333550) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0095355b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9335b68, th=0x9333550) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x009578d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9335c58, th=0x9333550) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00954533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9335b68, th=0x9333550, previous=0x9989020) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x0095595e in ThreadWeaver::ThreadRunHelper::run (this=0xab499234, parent=0x9335b68, th=0x9333550) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x0095607b in ThreadWeaver::Thread::run (this=0x9333550) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x0772edf9 in QThreadPrivate::start (arg=0x9333550) at thread/qthread_unix.cpp:266
#13 0x01507ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 4 (Thread 0xac8b6b70 (LWP 12515)):
#0  0x009e5416 in __kernel_vsyscall ()
#1  0x0093d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x001edd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0772f9c7 in wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00954030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9335b68, th=0x9996240) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x009577dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9335c58, th=0x9996240) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0095355b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9335b68, th=0x9996240) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x009578d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9335c58, th=0x9996240) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00954533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9335b68, th=0x9996240, previous=0x0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x009578f1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9335c58, th=0x9996240) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x00954533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9335b68, th=0x9996240, previous=0x8908140) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#12 0x0095595e in ThreadWeaver::ThreadRunHelper::run (this=0xac8b6234, parent=0x9335b68, th=0x9996240) at ../../../threadweaver/Weaver/Thread.cpp:87
#13 0x0095607b in ThreadWeaver::Thread::run (this=0x9996240) at ../../../threadweaver/Weaver/Thread.cpp:142
#14 0x0772edf9 in QThreadPrivate::start (arg=0x9996240) at thread/qthread_unix.cpp:266
#15 0x01507ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 3 (Thread 0xa89c7b70 (LWP 12516)):
#0  0x009e5416 in __kernel_vsyscall ()
#1  0x0093d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x001edd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0772f9c7 in wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00954030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9335b68, th=0x97ff868) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x009577dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9335c58, th=0x97ff868) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0095355b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9335b68, th=0x97ff868) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x009578d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9335c58, th=0x97ff868) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00954533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9335b68, th=0x97ff868, previous=0x932d0f8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x0095595e in ThreadWeaver::ThreadRunHelper::run (this=0xa89c7234, parent=0x9335b68, th=0x97ff868) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x0095607b in ThreadWeaver::Thread::run (this=0x97ff868) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x0772edf9 in QThreadPrivate::start (arg=0x97ff868) at thread/qthread_unix.cpp:266
#13 0x01507ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 2 (Thread 0xa81c6b70 (LWP 12517)):
#0  0x009e5416 in __kernel_vsyscall ()
#1  0x0093d4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x001edd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x0772f9c7 in wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9335b80, mutex=0x9335d68, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x00954030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9335b68, th=0x9979d00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x009577dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9335c58, th=0x9979d00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x0095355b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9335b68, th=0x9979d00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x009578d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9335c58, th=0x9979d00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x00954533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9335b68, th=0x9979d00, previous=0x999dc60) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x0095595e in ThreadWeaver::ThreadRunHelper::run (this=0xa81c6234, parent=0x9335b68, th=0x9979d00) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x0095607b in ThreadWeaver::Thread::run (this=0x9979d00) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x0772edf9 in QThreadPrivate::start (arg=0x9979d00) at thread/qthread_unix.cpp:266
#13 0x01507ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 1 (Thread 0xb6163a30 (LWP 3279)):
[KCrash Handler]
#7  QMutex::lock (this=0xff6085b5) at thread/qmutex.cpp:151
#8  0x07833724 in QCoreApplication::postEvent (receiver=0x87b18b8, event=0x94b8570, priority=0) at kernel/qcoreapplication.cpp:1141
#9  0x07833aac in QCoreApplication::postEvent (receiver=0x87b18b8, event=0x94b8570) at kernel/qcoreapplication.cpp:1094
#10 0x078422c4 in QObject::deleteLater (this=0x87b18b8) at kernel/qobject.cpp:2131
#11 0x007b8e6c in KJob::emitResult (this=0x87b18b8) at ../../kdecore/jobs/kjob.cpp:315
#12 0x003e7b97 in Plasma::ServiceJob::setResult (this=0x87b18b8, result=...) at ../../plasma/servicejob.cpp:80
#13 0x05a72d6d in StatusNotifierItemJob::contextMenuReady (this=0x87b18b8, menu=0x98a6980) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#14 0x05a72ded in StatusNotifierItemJob::qt_metacall (this=0x87b18b8, _c=QMetaObject::InvokeMetaMethod, _id=27, _a=0xbfb289e8) at ./statusnotifieritemjob.moc:75
#15 0x078368ca in QMetaObject::metacall (object=0x87b18b8, cl=142284984, idx=27, argv=0xbfb289e8) at kernel/qmetaobject.cpp:237
#16 0x078496ad in QMetaObject::activate (sender=0x97057d0, m=0x5a79c40, local_signal_index=0, argv=0x214dcc3) at kernel/qobject.cpp:3280
#17 0x05a6c0a3 in StatusNotifierItemSource::contextMenuReady (this=0x97057d0, _t1=0x98a6980) at ./statusnotifieritemsource.moc:109
#18 0x05a6c2b1 in StatusNotifierItemSource::contextMenuReady (this=0x97057d0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:369
#19 0x05a71803 in StatusNotifierItemSource::qt_metacall (this=0x97057d0, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfb28b0c) at ./statusnotifieritemsource.moc:90
#20 0x078368ca in QMetaObject::metacall (object=0x97057d0, cl=142284984, idx=11, argv=0xbfb28b0c) at kernel/qmetaobject.cpp:237
#21 0x078496ad in QMetaObject::activate (sender=0x8e7bb80, m=0x1613d84, local_signal_index=0, argv=0x214dcc3) at kernel/qobject.cpp:3280
#22 0x015fe567 in DBusMenuImporter::menuUpdated() () from /usr/lib/libdbusmenu-qt.so.2
#23 0x01603cdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#24 0x01604f2b in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#25 0x078368ca in QMetaObject::metacall (object=0x8e7bb80, cl=142284984, idx=12, argv=0xbfb28d4c) at kernel/qmetaobject.cpp:237
#26 0x078496ad in QMetaObject::activate (sender=0x98a6980, m=0x240efe8, local_signal_index=0, argv=0x214dcc3) at kernel/qobject.cpp:3280
#27 0x01f4dee7 in QMenu::aboutToShow (this=0x98a6980) at .moc/release-shared/moc_qmenu.cpp:151
#28 0x01f55193 in QMenu::qt_metacall (this=0x98a6980, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb28e9c) at .moc/release-shared/moc_qmenu.cpp:97
#29 0x078368ca in QMetaObject::metacall (object=0x98a6980, cl=142284984, idx=27, argv=0xbfb28e9c) at kernel/qmetaobject.cpp:237
#30 0x0783a352 in QMetaMethod::invoke (this=0xbfb2902c, object=0x98a6980, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#31 0x0783ba1f in QMetaObject::invokeMethod (obj=0x98a6980, member=0x160a3e1 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#32 0x015fe93e in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#33 0x05a6d6ef in StatusNotifierItemSource::contextMenu (this=0x97057d0, x=980, y=785) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#34 0x05a7433e in StatusNotifierItemJob::start (this=0x87b18b8) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#35 0x003e7a13 in Plasma::ServiceJobPrivate::slotStart (this=0x87b0c10) at ../../plasma/servicejob.cpp:37
#36 0x003e7ae4 in Plasma::ServiceJob::qt_metacall (this=0x87b18b8, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x8fbfe08) at ./servicejob.moc:72
#37 0x05a72dca in StatusNotifierItemJob::qt_metacall (this=0x87b18b8, _c=QMetaObject::InvokeMetaMethod, _id=26, _a=0x8fbfe08) at ./statusnotifieritemjob.moc:70
#38 0x078368ca in QMetaObject::metacall (object=0x87b18b8, cl=142284984, idx=26, argv=0x8fbfe08) at kernel/qmetaobject.cpp:237
#39 0x07841df6 in QMetaCallEvent::placeMetaCall (this=0x96bbb68, object=0x87b18b8) at kernel/qobject.cpp:534
#40 0x078436a2 in QObject::event (this=0x87b18b8, e=0x4) at kernel/qobject.cpp:1219
#41 0x01a89fdc in QApplicationPrivate::notify_helper (this=0x86c0910, receiver=0x87b18b8, e=0x96bbb68) at kernel/qapplication.cpp:4396
#42 0x01a9004e in QApplication::notify (this=0x86af460, receiver=0x87b18b8, e=0x96bbb68) at kernel/qapplication.cpp:3798
#43 0x011c605a in KApplication::notify (this=0x86af460, receiver=0x87b18b8, event=0x96bbb68) at ../../kdeui/kernel/kapplication.cpp:310
#44 0x07830b3b in QCoreApplication::notifyInternal (this=0x86af460, receiver=0x87b18b8, event=0x96bbb68) at kernel/qcoreapplication.cpp:732
#45 0x07833d8b in sendEvent (receiver=0x0, event_type=0, data=0x865b028) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#46 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x865b028) at kernel/qcoreapplication.cpp:1373
#47 0x07833f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#48 0x0785fa74 in sendPostedEvents (s=0x86c2d10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#49 postEventSourceDispatch (s=0x86c2d10) at kernel/qeventdispatcher_glib.cpp:277
#50 0x0165c855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#51 0x01660668 in ?? () from /lib/libglib-2.0.so.0
#52 0x01660848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#53 0x0785f565 in QEventDispatcherGlib::processEvents (this=0x865ace8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#54 0x01b4bbe5 in QGuiEventDispatcherGlib::processEvents (this=0x865ace8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#55 0x0782f609 in QEventLoop::processEvents (this=0xbfb29e04, flags=) at kernel/qeventloop.cpp:149
#56 0x0782fa8a in QEventLoop::exec (this=0xbfb29e04, flags=...) at kernel/qeventloop.cpp:201
#57 0x0783400f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#58 0x01a88e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#59 0x009918e7 in kdemain (argc=1, argv=0xbfb2a014) at ../../../../plasma/desktop/shell/main.cpp:118
#60 0x080485bb in main (argc=1, argv=0xbfb2a014) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 241562.

Possible duplicates by query: bug 261741, bug 261405, bug 260767, bug 259248, bug 258761.

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-02 23:04:44 UTC
[Comment from a bug triager]
This is fixed in KDE SC 4.5.5 / 4.6.0 and later
Merging with bug 254435. Thanks

*** This bug has been marked as a duplicate of bug 254435 ***