Bug 261526

Summary: Other applications to edit the photos cannot be added in the "open , "others" - error: path is not correct
Product: digikam Reporter: reiku
Component: Portability-InterroperabilityAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: anantapalani, caulier.gilles, Deep-Sea, smarij
Priority: NOR    
Version: 1.7.0   
Target Milestone: ---   
Platform: Microsoft Windows   
OS: Microsoft Windows   
Latest Commit: Version Fixed In: 4.0.0
Attachments: open with menu under Linux

Description reiku 2010-12-29 12:15:19 UTC
Version:           1.7.0 (using KDE 4.4.4) 
OS:                MS Windows

Other applications to edit photos (like GIMP, RAW Therapee etc.) cannot be added - they are not found, but there exist and the path is correct (it works f.i. in Irfanview and other applications perfectly. It does not work if I am logged in as administrator neither as other user.

Reproducible: Always

Steps to Reproduce:
Go to thumbnail, right click, "open with", "others" ( or "other application" - I use the German version. Click to the correct path - an error message occurs: 'C:/Programme/../gimp-2.6.exe' not found, please type a valid program name.' - regardless of which application and (correct) path you choose.


Expected Results:  
It should add the application to the same menu where "showFot" or "DNGConverter" are. If you click on "The Gimp" for instance, the foto would be opened by the progamm "The Gimp"

Without this feature, digikam has no use for my workflow - what a pity, it is such a nice piece of software !
Comment 1 caulier.gilles 2011-12-13 10:02:22 UTC
Not reproducible here...

Gilles Caulier
Comment 2 caulier.gilles 2011-12-13 10:03:16 UTC
... under Linux i want mean...

Under Windows, i don't know...

Gilles Caulier
Comment 3 caulier.gilles 2011-12-13 10:03:57 UTC
Created attachment 66687 [details]
open with menu under Linux
Comment 4 Deep-Sea 2012-01-07 22:29:59 UTC
Version:           2.3.0 (using KDE 4.7.2) 
OS:                MS Windows

It works under Windows too. But you have to replace the unix directory separators (slash, "/") by the windows directory separators (backslash, "\") manually. And you have to quote the complete path, if it contains a space.

So far so good, but there is still a problem: If you check "Remember application association for this type of file" and click ok, digiKam will freeze. I think this is an other bug and belongs to an own report?!
Comment 5 Ananta Palani 2013-06-10 12:59:16 UTC
(In reply to comment #4)
> Version:           2.3.0 (using KDE 4.7.2) 
> OS:                MS Windows
> 
> It works under Windows too. But you have to replace the unix directory
> separators (slash, "/") by the windows directory separators (backslash, "\")
> manually. And you have to quote the complete path, if it contains a space.
> 
> So far so good, but there is still a problem: If you check "Remember
> application association for this type of file" and click ok, digiKam will
> freeze. I think this is an other bug and belongs to an own report?!

This works for me now on Windows in 3.1.0 except that the path is incorrectly displayed to the user (i.e. still using unix paths). However, it does not crash and the image is opened correctly. Also, you can click the 'remember' button and it will add the program to the list of available 'open with' programs (I see that the icon of the program is not pulled in to the context menu, I'll see how hard that is to fix - also when you open with the open with menu, the opened application does not come to the front, i'll see if I can fix that too). Can you try this out and I will fix the path display for the next version? Here is the new installer:
   http://download.kde.org/stable/digikam/digiKam-installer-3.1.0-win32.exe
Comment 6 Deep-Sea 2013-06-10 13:56:50 UTC
For me, with version 3.1.0, it's exactly as you described it :-)
Comment 7 caulier.gilles 2013-11-25 13:53:00 UTC
This file can be closed as fixed following comment #5 and #6

Gilles Caulier
Comment 8 caulier.gilles 2013-11-25 16:58:20 UTC
*** Bug 235593 has been marked as a duplicate of this bug. ***