Bug 261177

Summary: Digikam crashes during startup
Product: digikam Reporter: Omar <omarvn>
Component: Plugin-Bqm-RotateAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: caulier.gilles
Priority: NOR    
Version: 1.5.0   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 7.5.0

Description Omar 2010-12-24 20:04:30 UTC
Application: digikam (1.5.0)
KDE Platform Version: 4.5.85 (4.6 Beta2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
Almost everytime I launch Digikam, it crashes. No particular situation, no other software running, apparently no reason why it happens.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fea103c27c0 (LWP 2315))]

Thread 17 (Thread 0x7fe9faea0700 (LWP 2317)):
#0  0x00007fea059be665 in __pthread_mutex_lock (mutex=0x2116298) at pthread_mutex_lock.c:61
#1  0x00007fea0474fa61 in g_main_context_query () from /lib/libglib-2.0.so.0
#2  0x00007fea04754efc in ?? () from /lib/libglib-2.0.so.0
#3  0x00007fea047557b5 in g_main_loop_run () from /lib/libglib-2.0.so.0
#4  0x00007fe9fb7f00f4 in ?? () from /usr/lib/libgio-2.0.so.0
#5  0x00007fea0477a7e4 in ?? () from /lib/libglib-2.0.so.0
#6  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#7  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 16 (Thread 0x7fe9ea6ef700 (LWP 2318)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea08a16e3b in wait (this=<value optimized out>, mutex=0x2336e30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2336e30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000000006fac5b in Digikam::ScanController::run (this=0x233a3a0) at /build/buildd/digikam-1.5.0/digikam/scancontroller.cpp:515
#4  0x00007fea08a1627e in QThreadPrivate::start (arg=0x233a3a0) at thread/qthread_unix.cpp:266
#5  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 15 (Thread 0x7fe9e9eee700 (LWP 2319)):
#0  0x00007fea04755053 in ?? () from /lib/libglib-2.0.so.0
#1  0x00007fea0475545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x00007fea08b361e6 in QEventDispatcherGlib::processEvents (this=0x233eeb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#3  0x00007fea08b08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#4  0x00007fea08b08dec in QEventLoop::exec (this=0x7fe9e9eedd50, flags=) at kernel/qeventloop.cpp:201
#5  0x00007fea08a132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007fea08ae85f8 in QInotifyFileSystemWatcherEngine::run (this=0x233e810) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007fea08a1627e in QThreadPrivate::start (arg=0x233e810) at thread/qthread_unix.cpp:266
#8  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 14 (Thread 0x7fe9e96ed700 (LWP 2374)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fe9e96eca50 in ?? ()
#2  0x00007fff47bff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 13 (Thread 0x7fe9e8eec700 (LWP 2409)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fe9e8eeba70 in ?? ()
#2  0x00007fff47bff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 12 (Thread 0x7fe9e63e0700 (LWP 2410)):
#0  0x00007fea04754a05 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x00007fea04754e78 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fea0475545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fea08b361e6 in QEventDispatcherGlib::processEvents (this=0x26ada50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fea08b08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fea08b08dec in QEventLoop::exec (this=0x7fe9e63dfd90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fea08a132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fea08a1627e in QThreadPrivate::start (arg=0x7fe9f401c410) at thread/qthread_unix.cpp:266
#8  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#9  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7fe9e5b5e700 (LWP 2411)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fea08a16e3b in wait (this=<value optimized out>, mutex=0x7fe9f40242d8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7fe9f40242d8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fea0d338ed4 in Digikam::ParkingThread::run (this=0x7fe9f40242c0) at /build/buildd/digikam-1.5.0/libs/threads/threadmanager.cpp:101
#4  0x00007fea08a1627e in QThreadPrivate::start (arg=0x7fe9f40242c0) at thread/qthread_unix.cpp:266
#5  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fe9e535d700 (LWP 2412)):
#0  pthread_mutex_unlock (mutex=0x23b3b28) at forward.c:184
#1  0x00007fea04755486 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x00007fea08b361e6 in QEventDispatcherGlib::processEvents (this=0x24e4950, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#3  0x00007fea08b08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#4  0x00007fea08b08dec in QEventLoop::exec (this=0x7fe9e535cd90, flags=) at kernel/qeventloop.cpp:201
#5  0x00007fea08a132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007fea08a1627e in QThreadPrivate::start (arg=0x7fe9f41ff950) at thread/qthread_unix.cpp:266
#7  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fe9e4b5c700 (LWP 2413)):
#0  0x00007fea0475500b in ?? () from /lib/libglib-2.0.so.0
#1  0x00007fea0475545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x00007fea08b361e6 in QEventDispatcherGlib::processEvents (this=0x2479070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#3  0x00007fea08b08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#4  0x00007fea08b08dec in QEventLoop::exec (this=0x7fe9e4b5bd90, flags=) at kernel/qeventloop.cpp:201
#5  0x00007fea08a132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007fea08a1627e in QThreadPrivate::start (arg=0x7fe9f41fe130) at thread/qthread_unix.cpp:266
#7  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fe9d78f7700 (LWP 2427)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007fe9e12910d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fe9d66be700 (LWP 2428)):
#0  0x00007fea079ea2c3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fe9e12ba385 in xine_usec_sleep () from /usr/lib/libxine.so.1
#2  0x00007fe9e129ed09 in ?? () from /usr/lib/libxine.so.1
#3  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#4  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fe9d5ebd700 (LWP 2429)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fe9d5ebca10 in ?? ()
#2  0x00007fff47bff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 5 (Thread 0x7fe9d54b7700 (LWP 2430)):
#0  0x00007fea079e5203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fea076f640f in ?? () from /usr/lib/libpulse.so.0
#2  0x00007fea076e5d76 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#3  0x00007fea076e77f9 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#4  0x00007fea076e78b0 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#5  0x00007fea076f620b in ?? () from /usr/lib/libpulse.so.0
#6  0x00007fe9ff2e3fb8 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#7  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fe9d0cb5700 (LWP 2431)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe9e12a1e83 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fe9d04b4700 (LWP 2432)):
#0  0x00007fea079e5203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fea04755009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007fea0475545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007fea08b361e6 in QEventDispatcherGlib::processEvents (this=0x390e0f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007fea08b08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007fea08b08dec in QEventLoop::exec (this=0x7fe9d04b3d50, flags=) at kernel/qeventloop.cpp:201
#6  0x00007fea08a132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fea08ae85f8 in QInotifyFileSystemWatcherEngine::run (this=0x7fe9f4276c20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fea08a1627e in QThreadPrivate::start (arg=0x7fe9f4276c20) at thread/qthread_unix.cpp:266
#9  0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe9c9b34700 (LWP 2439)):
#0  0x00007fea059bfc9d in __pthread_mutex_unlock_usercnt (mutex=0x4b65448) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x4b65448) at pthread_mutex_unlock.c:290
#2  0x00007fea04754a05 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x00007fea04754e78 in ?? () from /lib/libglib-2.0.so.0
#4  0x00007fea0475545c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00007fea08b361e6 in QEventDispatcherGlib::processEvents (this=0x4b65350, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#6  0x00007fea08b08a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#7  0x00007fea08b08dec in QEventLoop::exec (this=0x7fe9c9b33d50, flags=) at kernel/qeventloop.cpp:201
#8  0x00007fea08a132fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#9  0x00007fea08ae85f8 in QInotifyFileSystemWatcherEngine::run (this=0x7fe9f456a600) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fea08a1627e in QThreadPrivate::start (arg=0x7fe9f456a600) at thread/qthread_unix.cpp:266
#11 0x00007fea059bc971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007fea079f192d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fea103c27c0 (LWP 2315)):
[KCrash Handler]
#6  deref (this=0x7fff47bd2ad0, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:133
#7  QVariant::~QVariant (this=0x7fff47bd2ad0, __in_chrg=<value optimized out>) at kernel/qvariant.cpp:1407
#8  0x00007fe9bf65dd94 in ?? () from /usr/lib/kde4/kipiplugin_jpeglossless.so
#9  0x00007fe9bf6552cc in ?? () from /usr/lib/kde4/kipiplugin_jpeglossless.so
#10 0x0000000000692123 in Digikam::DigikamApp::slotKipiPluginPlug (this=0x23a7f10) at /build/buildd/digikam-1.5.0/digikam/digikamapp.cpp:2377
#11 0x00000000006a934d in Digikam::DigikamApp::qt_metacall (this=0x23a7f10, _c=QMetaObject::InvokeMetaMethod, _id=24, _a=0x7fff47bd3190) at /build/buildd/digikam-1.5.0/obj-x86_64-linux-gnu/digikam/digikamapp.moc:228
#12 0x00007fea08b21b27 in QMetaObject::activate (sender=0x7fe9f4a18350, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff47bd28df) at kernel/qobject.cpp:3280
#13 0x0000000000697f26 in Digikam::DigikamApp::loadPlugins (this=0x23a7f10) at /build/buildd/digikam-1.5.0/digikam/digikamapp.cpp:2320
#14 0x00000000006a6d13 in Digikam::DigikamApp::DigikamApp (this=0x23a7f10, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.5.0/digikam/digikamapp.cpp:251
#15 0x0000000000789825 in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/digikam-1.5.0/digikam/main.cpp:172

This bug may be a duplicate of or related to bug 234021.

Possible duplicates by query: bug 234021.

Reported using DrKonqi
Comment 1 caulier.gilles 2010-12-24 22:53:30 UTC

*** This bug has been marked as a duplicate of bug 234021 ***
Comment 2 caulier.gilles 2021-12-17 21:33:21 UTC
Fixed with #234021