Bug 259623

Summary: Application: showFoto (showfoto), signal: Segmentation fault (opening jpg)
Product: digikam Reporter: omega <biasquez>
Component: Showfoto-LoadAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: crash CC: andresbajotierra, biasquez, caulier.gilles, nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In: 6.0.0

Description omega 2010-12-12 17:25:28 UTC
Application: showfoto (1.5.0)
KDE Platform Version: 4.5.85 (4.6 Beta2)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-8-generic x86_64
Distribution: Ubuntu natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

i had this crash opening file .jpg  clicking on "Open with showPhoto"

The crash can be reproduced every time.

-- Backtrace:
Application: showFoto (showfoto), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0e538ed800 (LWP 10029))]

Thread 3 (Thread 0x7f0e373f6710 (LWP 10030)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f0e4f7b00eb in wait (this=<value optimized out>, mutex=0xa38d58, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xa38d58, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f0e5315e2d9 in Digikam::ParkingThread::run (this=0xa38d40) at /build/buildd/digikam-1.5.0/libs/threads/threadmanager.cpp:101
#4  0x00007f0e4f7afa2e in QThreadPrivate::start (arg=0xa38d40) at thread/qthread_unix.cpp:285
#5  0x00007f0e4c761971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#6  0x00007f0e4ed0194d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0e36b25710 (LWP 10031)):
#0  0x00007f0e4ecf5203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f0e4b713030 in g_main_context_poll (context=0xd85130, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.4/glib/gmain.c:3400
#2  g_main_context_iterate (context=0xd85130, block=<value optimized out>, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.4/glib/gmain.c:3082
#3  0x00007f0e4b713559 in g_main_context_iteration (context=0xd85130, may_block=1) at /build/buildd/glib2.0-2.27.4/glib/gmain.c:3150
#4  0x00007f0e4f8c1f26 in QEventDispatcherGlib::processEvents (this=0xd7ca20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f0e4f896362 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f0e4f89659c in QEventLoop::exec (this=0x7f0e36b24d20, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f0e4f7ad274 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f0e4f87882f in QInotifyFileSystemWatcherEngine::run (this=0xd7a9f0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f0e4f7afa2e in QThreadPrivate::start (arg=0xd7a9f0) at thread/qthread_unix.cpp:285
#10 0x00007f0e4c761971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f0e4ed0194d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0e538ed800 (LWP 10029)):
[KCrash Handler]
#6  0x00007f0e4c1f7b4c in Marble::MarbleModel::addDownloadPolicies(Marble::GeoSceneDocument*) () from /usr/lib/libmarblewidget.so.10
#7  0x00007f0e4c1f9498 in Marble::MarbleModel::setMapTheme(Marble::GeoSceneDocument*, Marble::Projection) () from /usr/lib/libmarblewidget.so.10
#8  0x00007f0e4c1ff6a7 in Marble::MarbleMap::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#9  0x00007f0e4c1f22f5 in Marble::MarbleWidget::setMapThemeId(QString const&) () from /usr/lib/libmarblewidget.so.10
#10 0x00007f0e531fac39 in Digikam::WorldMapWidget::setMapTheme (this=0xd79510, theme=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/worldmapwidget.cpp:409
#11 0x00007f0e531fae77 in Digikam::WorldMapWidget::readConfig (this=0xd79510, group=...) at /build/buildd/digikam-1.5.0/libs/imageproperties/worldmapwidget.cpp:364
#12 0x00007f0e531f88d9 in Digikam::ImagePropertiesGPSTab::readConfig (this=0xd78650) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiesgpstab.cpp:212
#13 0x00007f0e531f98ab in Digikam::ImagePropertiesGPSTab::ImagePropertiesGPSTab (this=0xd78650, parent=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiesgpstab.cpp:194
#14 0x00007f0e531ea060 in Digikam::ImagePropertiesSideBar::ImagePropertiesSideBar (this=0xa51290, parent=0xa30b90, splitter=<value optimized out>, side=<value optimized out>, mimimizedDefault=<value optimized out>) at /build/buildd/digikam-1.5.0/libs/imageproperties/imagepropertiessidebar.cpp:77
#15 0x000000000042edf6 in ShowFoto::ShowFoto::setupUserArea (this=0x9d2b50) at /build/buildd/digikam-1.5.0/showfoto/showfoto.cpp:401
#16 0x0000000000432101 in ShowFoto::ShowFoto::ShowFoto (this=0x9d2b50, urlList=..., __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/digikam-1.5.0/showfoto/showfoto.cpp:222
#17 0x0000000000429885 in main (argc=6, argv=0x7fffbc0a9558) at /build/buildd/digikam-1.5.0/showfoto/main.cpp:80

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-12 18:11:38 UTC
[Comment from a bug triager]
- Is the Marble application properly installed and updated ?
As bug 247420 and other reports, this could be caused by some old Marble installation conflicting with the new one.
Thanks
Comment 2 omega 2010-12-12 18:28:28 UTC
ii  libmarblewidget10                                                4:4.5.3-0ubuntu1                           Marble globe widget library
ii  libmarblewidget11                                                4:4.5.85-0ubuntu1                          Marble globe widget library
ii  marble                                                           4:4.5.85-0ubuntu1                          globe and map widget
ii  marble-data                                                      4:4.5.85-0ubuntu1                          data files for Marble
ii  marble-plugins                                                   4:4.5.85-0ubuntu1                          plugins for Marble
Comment 3 Dario Andres 2010-12-12 18:30:35 UTC
[Comment from a bug triager]
If "libmarblewidget10" is installed, try uninstalling it (and reinstalling "libmarblewidget11 ")
Comment 4 omega 2010-12-12 18:38:24 UTC
uninstalling libmarblewidget10, system removes dikikam too.maybe there is an error with dependency in kubuntu (digikam 1.5.0)
Comment 5 Johannes Wienke 2010-12-12 18:47:54 UTC
Where did you get version 11 from? It is not from the standard package sources in maverick.
Comment 6 omega 2010-12-12 19:46:27 UTC
(In reply to comment #5)
> Where did you get version 11 from? It is not from the standard package sources
> in maverick.

i'm using natty
Comment 7 Johannes Wienke 2010-12-12 19:49:05 UTC
Then there must be a packaging error. If version 11 is the natty one, then digikam must also be built against this one. having two versions of marblewidget installed is strange.
Comment 8 Dennis Nienhüser 2011-01-01 12:14:03 UTC

*** This bug has been marked as a duplicate of bug 247420 ***
Comment 9 caulier.gilles 2018-09-04 04:40:14 UTC
Not reproducible with 6.0.0