Bug 258362

Summary: plasma crashes suddenly and keeps crashing now
Product: [Plasma] plasma4 Reporter: jos poortvliet <jospoortvliet>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: asraniel
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description jos poortvliet 2010-11-30 12:27:24 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-rc3-git1-7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- Unusual behavior I noticed:

Plasma worked just fine after the upgrade to 4.6 beta1 but suddenly had crashed when I came back - and couldn't be restarted, crashing again and again... :(

I have as widgets mostly microblogs (2), a few clocks (as plasma is all about the clocks, right?), a photo widget, plasma NM, otherwise nothing special...

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fedd3f10760 (LWP 10849))]

Thread 6 (Thread 0x7fedc5ef5710 (LWP 10850)):
#0  0x0000003001e0b39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fedd8c88af4 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fedd8faa180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fedd8c88b29 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fedd8fb8254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#4  0x00000030016d082d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fedc2907710 (LWP 10853)):
#0  0x0000003001e090b4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x000000300423f729 in g_main_context_release () from /usr/lib64/libglib-2.0.so.0
#2  0x0000003004241008 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x0000003004241510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007feddb59dae6 in QEventDispatcherGlib::processEvents (this=0xe24250, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007feddb572262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007feddb572475 in QEventLoop::exec (this=0x7fedc2906de0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007feddb4851a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007feddb553918 in QInotifyFileSystemWatcherEngine::run (this=0xe24fa0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007feddb487a1e in QThreadPrivate::start (arg=0xe24fa0) at thread/qthread_unix.cpp:285
#10 0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#11 0x00000030016d082d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fedc1826710 (LWP 10861)):
#0  0x0000003001e0b709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007feddb488072 in wait (this=<value optimized out>, mutex=0x1280630, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1280630, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feddb47de98 in QThreadPoolThread::run (this=0x125ee90) at concurrent/qthreadpool.cpp:140
#4  0x00007feddb487a1e in QThreadPrivate::start (arg=0x125ee90) at thread/qthread_unix.cpp:285
#5  0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00000030016d082d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fedbdd28710 (LWP 10867)):
#0  0x0000003001e0b709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007feddb488072 in wait (this=<value optimized out>, mutex=0xab1470, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xab1470, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feddb47de98 in QThreadPoolThread::run (this=0x1630af0) at concurrent/qthreadpool.cpp:140
#4  0x00007feddb487a1e in QThreadPrivate::start (arg=0x1630af0) at thread/qthread_unix.cpp:285
#5  0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00000030016d082d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fedbd527710 (LWP 10868)):
#0  0x0000003001e0b709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007feddb488072 in wait (this=<value optimized out>, mutex=0xab1470, time=30000) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xab1470, time=30000) at thread/qwaitcondition_unix.cpp:160
#3  0x00007feddb47de98 in QThreadPoolThread::run (this=0xae2280) at concurrent/qthreadpool.cpp:140
#4  0x00007feddb487a1e in QThreadPrivate::start (arg=0xae2280) at thread/qthread_unix.cpp:285
#5  0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#6  0x00000030016d082d in clone () from /lib64/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fedd3f10760 (LWP 10849)):
[KCrash Handler]
#6  Plasma::ExtenderItem::group (this=0x1343da0) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extenderitem.cpp:476
#7  0x00007feddda971e6 in Plasma::Extender::itemAddedEvent (this=0x12d0860, item=0x1343da0, pos=...) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extender.cpp:490
#8  0x00007feddda976e4 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x13443a0) at /usr/src/debug/kdelibs-4.5.80/plasma/extenders/extender.cpp:805
#9  0x00007feddda98f92 in Plasma::Extender::qt_metacall (this=0x12d0860, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x12225b0) at /usr/src/debug/kdelibs-4.5.80/build/plasma/extender.moc:105
#10 0x00007feddb586c6a in QObject::event (this=0x12d0860, e=<value optimized out>) at kernel/qobject.cpp:1211
#11 0x00007feddaf5571b in QGraphicsWidget::event (this=0x12d0860, event=0x12ef760) at graphicsview/qgraphicswidget.cpp:1407
#12 0x00007fedda930cd4 in QApplicationPrivate::notify_helper (this=0x69e4c0, receiver=0x12d0860, e=0x12ef760) at kernel/qapplication.cpp:4445
#13 0x00007fedda9391ca in QApplication::notify (this=<value optimized out>, receiver=0x12d0860, e=0x12ef760) at kernel/qapplication.cpp:4324
#14 0x00007feddc15f976 in KApplication::notify (this=0x649830, receiver=0x12d0860, event=0x12ef760) at /usr/src/debug/kdelibs-4.5.80/kdeui/kernel/kapplication.cpp:311
#15 0x00007feddb572e2c in QCoreApplication::notifyInternal (this=0x649830, receiver=0x12d0860, event=0x12ef760) at kernel/qcoreapplication.cpp:732
#16 0x00007feddb576625 in sendEvent (receiver=0x0, event_type=0, data=0x60b7e0) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b7e0) at kernel/qcoreapplication.cpp:1373
#18 0x00007feddb59d8f3 in sendPostedEvents (s=0x6a1c30) at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=0x6a1c30) at kernel/qeventdispatcher_glib.cpp:277
#20 0x0000003004240a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x0000003004241270 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x0000003004241510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007feddb59da8f in QEventDispatcherGlib::processEvents (this=0x6114e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007fedda9d5eae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007feddb572262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007feddb572475 in QEventLoop::exec (this=0x7fff9335b080, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007feddb5768db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x00007fedddea6578 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#29 0x000000300161eb7d in __libc_start_main () from /lib64/libc.so.6
#30 0x0000000000400699 in _start ()

This bug may be a duplicate of or related to bug 257658.

Possible duplicates by query: bug 257658.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-11-30 13:58:13 UTC

*** This bug has been marked as a duplicate of bug 257658 ***