Bug 258297

Summary: Plasma crashed while I visited sony website using Firefox
Product: [Plasma] plasma4 Reporter: Alexis Kauffmann <leh>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra, asraniel, kdelibs-bugs, von.kdebugs
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Alexis Kauffmann 2010-11-29 19:28:15 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: The title is very descriptive. I was trying to view the website www,sony.com/index.php when firefox froze. A few seconds later, Plasma crashed. I will also try to report this bug to Mozilla.

-- Backtrace:
Application: Espa├žo de trabalho do Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff971ffc780 (LWP 1956))]

Thread 3 (Thread 0x7ff950634710 (LWP 1960)):
#0  0x00007ff97190a203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff966588009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007ff96658845c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007ff96efbf1e6 in QEventDispatcherGlib::processEvents (this=0x1eebd00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007ff96ef91a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007ff96ef91dec in QEventLoop::exec (this=0x7ff950633d90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007ff96ee9c2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007ff96ef715f8 in QInotifyFileSystemWatcherEngine::run (this=0x1f735a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff96ee9f27e in QThreadPrivate::start (arg=0x1f735a0) at thread/qthread_unix.cpp:266
#9  0x00007ff96ec14971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007ff97191694d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff94eccb710 (LWP 1961)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007ff9718af1dc in _L_lock_12347 () from /lib/libc.so.6
#2  0x00007ff9718adc78 in __libc_free (mem=0x7ff971baee40) at malloc.c:3736
#3  0x00007ff96efbfe3a in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x1efa950, __in_chrg=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:392
#4  0x00007ff96ee9eac4 in QThreadPrivate::finish (arg=<value optimized out>) at thread/qthread_unix.cpp:302
#5  0x00007ff96ee9f286 in ~__pthread_cleanup_class (arg=0x7ff96f2c4f40) at /usr/include/pthread.h:545
#6  QThreadPrivate::start (arg=0x7ff96f2c4f40) at thread/qthread_unix.cpp:271
#7  0x00007ff96ec14971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#8  0x00007ff97191694d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff971ffc780 (LWP 1956)):
[KCrash Handler]
#6  malloc_consolidate (av=0x7ff971baee40) at malloc.c:5165
#7  0x00007ff9718aae82 in _int_malloc (av=0x7ff971baee40, bytes=4096) at malloc.c:4373
#8  0x00007ff9718ac38e in __libc_malloc (bytes=4096) at malloc.c:3660
#9  0x00007ff9718723d8 in __realpath (name=0x2ed8cc8 "/home/alexis/.kde/share/config/plasmarc", resolved=0x1000 <Address 0x1000 out of bounds>) at canonicalize.c:79
#10 0x00007ff96ef625c5 in realpath (path=...) at /usr/include/bits/stdlib.h:49
#11 QFSFileEnginePrivate::canonicalized (path=...) at io/qfsfileengine.cpp:172
#12 0x00007ff96ef6ad95 in QFSFileEngine::fileName (this=<value optimized out>, file=QAbstractFileEngine::CanonicalName) at io/qfsfileengine_unix.cpp:1073
#13 0x00007ff96ef25e4e in QFileInfoPrivate::getFileName (this=0x2dc0fe0, name=QAbstractFileEngine::CanonicalName) at io/qfileinfo.cpp:86
#14 0x00007ff96ef2653b in QFileInfo::canonicalFilePath (this=<value optimized out>) at io/qfileinfo.cpp:510
#15 0x00007ff96f5e46ed in KConfigIniBackend::setFilePath (this=0x2dff120, file=<value optimized out>) at ../../kdecore/config/kconfigini.cpp:541
#16 0x00007ff96f5e330e in KConfigBackend::create (componentData=<value optimized out>, file=<value optimized out>, sys=<value optimized out>) at ../../kdecore/config/kconfigbackend.cpp:89
#17 0x00007ff96f5d0caa in KConfigPrivate::changeFileName (this=0x2e96140, name=..., type=<value optimized out>) at ../../kdecore/config/kconfig.cpp:434
#18 0x00007ff96f5d261b in KConfig::KConfig (this=0x7fff74897380, file=..., mode=<value optimized out>, resourceType=0x7ff9715ba330 "config") at ../../kdecore/config/kconfig.cpp:158
#19 0x00007ff9714f44d5 in Plasma::ToolTipManager::show (this=0x1a49f60, widget=0x2dcbca0) at ../../plasma/tooltipmanager.cpp:147
#20 0x00007ff9714f4e12 in Plasma::ToolTipManager::eventFilter (this=0x1a49f60, watched=0x2dcbca0, event=0x7fff748979d0) at ../../plasma/tooltipmanager.cpp:432
#21 0x00007ff96ef92507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x2dcbca0, event=0x7fff748979d0) at kernel/qcoreapplication.cpp:847
#22 0x00007ff96e0dcfac in QApplicationPrivate::notify_helper (this=0x18c19a0, receiver=0x2dcbca0, e=0x7fff748979d0) at kernel/qapplication.cpp:4392
#23 0x00007ff96e0e2aed in QApplication::notify (this=0x18b01f0, receiver=0x2dcbca0, e=0x7fff748979d0) at kernel/qapplication.cpp:4277
#24 0x00007ff96fc2e156 in KApplication::notify (this=0x18b01f0, receiver=0x2dcbca0, event=0x7fff748979d0) at ../../kdeui/kernel/kapplication.cpp:310
#25 0x00007ff96ef92cdc in QCoreApplication::notifyInternal (this=0x18b01f0, receiver=0x2dcbca0, event=0x7fff748979d0) at kernel/qcoreapplication.cpp:732
#26 0x00007ff96e71d0b3 in sendEvent (this=<value optimized out>, item=0x2dcbcb0, event=0x7fff748979d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QGraphicsScenePrivate::sendEvent (this=<value optimized out>, item=0x2dcbcb0, event=0x7fff748979d0) at graphicsview/qgraphicsscene.cpp:1207
#28 0x00007ff96e71d40f in QGraphicsScenePrivate::sendHoverEvent (this=0x19dd580, type=<value optimized out>, item=0x2dcbcb0, hoverEvent=0x7fff74897b60) at graphicsview/qgraphicsscene.cpp:1258
#29 0x00007ff96e7231a8 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x19dd580, hoverEvent=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3921
#30 0x00007ff96e7234c4 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7fff74898230) at graphicsview/qgraphicsscene.cpp:4080
#31 0x00007ff96e73424b in QGraphicsScene::event (this=0x18b4630, event=0x7fff74898230) at graphicsview/qgraphicsscene.cpp:3437
#32 0x00007ff96e0dcfdc in QApplicationPrivate::notify_helper (this=0x18c19a0, receiver=0x18b4630, e=0x7fff74898230) at kernel/qapplication.cpp:4396
#33 0x00007ff96e0e2aed in QApplication::notify (this=0x18b01f0, receiver=0x18b4630, e=0x7fff74898230) at kernel/qapplication.cpp:4277
#34 0x00007ff96fc2e156 in KApplication::notify (this=0x18b01f0, receiver=0x18b4630, event=0x7fff74898230) at ../../kdeui/kernel/kapplication.cpp:310
#35 0x00007ff96ef92cdc in QCoreApplication::notifyInternal (this=0x18b01f0, receiver=0x18b4630, event=0x7fff74898230) at kernel/qcoreapplication.cpp:732
#36 0x00007ff96e752c17 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x2063270, event=0x7fff74898d90) at graphicsview/qgraphicsview.cpp:647
#37 0x00007ff96e752e0e in QGraphicsView::mouseMoveEvent (this=0x2264700, event=0x7fff74898d90) at graphicsview/qgraphicsview.cpp:3272
#38 0x00007ff96e132cab in QWidget::event (this=0x2264700, event=0x7fff74898d90) at kernel/qwidget.cpp:8172
#39 0x00007ff96e4fe5e6 in QFrame::event (this=0x2264700, e=0x7fff74898d90) at widgets/qframe.cpp:557
#40 0x00007ff96e75087b in QGraphicsView::viewportEvent (this=0x2264700, event=0x7fff74898d90) at graphicsview/qgraphicsview.cpp:2862
#41 0x00007ff96ef92507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x18b5620, event=0x7fff74898d90) at kernel/qcoreapplication.cpp:847
#42 0x00007ff96e0dcfac in QApplicationPrivate::notify_helper (this=0x18c19a0, receiver=0x18b5620, e=0x7fff74898d90) at kernel/qapplication.cpp:4392
#43 0x00007ff96e0e330e in QApplication::notify (this=0x18b01f0, receiver=0x18b5620, e=0x7fff74898d90) at kernel/qapplication.cpp:3959
#44 0x00007ff96fc2e156 in KApplication::notify (this=0x18b01f0, receiver=0x18b5620, event=0x7fff74898d90) at ../../kdeui/kernel/kapplication.cpp:310
#45 0x00007ff96ef92cdc in QCoreApplication::notifyInternal (this=0x18b01f0, receiver=0x18b5620, event=0x7fff74898d90) at kernel/qcoreapplication.cpp:732
#46 0x00007ff96e0e1dbe in sendEvent (receiver=0x18b5620, event=0x7fff74898d90, alienWidget=0x18b5620, nativeWidget=0x2264700, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#47 QApplicationPrivate::sendMouseEvent (receiver=0x18b5620, event=0x7fff74898d90, alienWidget=0x18b5620, nativeWidget=0x2264700, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#48 0x00007ff96e165345 in QETWidget::translateMouseEvent (this=0x2264700, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#49 0x00007ff96e163c5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff748996b0) at kernel/qapplication_x11.cpp:3536
#50 0x00007ff96e1900e2 in x11EventSourceDispatch (s=0x18c5200, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#51 0x00007ff966584342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#52 0x00007ff9665882a8 in ?? () from /lib/libglib-2.0.so.0
#53 0x00007ff96658845c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#54 0x00007ff96efbf193 in QEventDispatcherGlib::processEvents (this=0x1895070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#55 0x00007ff96e18fa4e in QGuiEventDispatcherGlib::processEvents (this=0x7ff971baee40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#56 0x00007ff96ef91a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#57 0x00007ff96ef91dec in QEventLoop::exec (this=0x7fff748999e0, flags=) at kernel/qeventloop.cpp:201
#58 0x00007ff96ef95ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#59 0x00007ff971beda56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#60 0x00007ff97184ed8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff74899da8) at libc-start.c:226
#61 0x0000000000400669 in _start ()

Possible duplicates by query: bug 257258, bug 228536, bug 228085.

Reported using DrKonqi
Comment 1 Marco Martin 2010-11-30 11:33:52 UTC
*** Bug 258303 has been marked as a duplicate of this bug. ***
Comment 2 Beat Wolf 2010-11-30 14:00:01 UTC

*** This bug has been marked as a duplicate of bug 257258 ***
Comment 3 Dario Andres 2011-01-23 15:36:49 UTC
[Comment from a bug triager]
Mh, this doesn't look related to KIO as 257258, I don't see the connection. It is still a kdelibs related bug anyway..