Bug 255649

Summary: Dolphin crashed while copying files from NFS to local directory
Product: nepomuk Reporter: Thorsten <homelan>
Component: generalAssignee: Sebastian Trueg <sebastian>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description Thorsten 2010-10-30 10:56:51 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-pae i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
When drag'n'drop copy a set of 100+ JPG files from an NFS-mounted server directory to my local directory, Dophin repeatly crashes.

The crash can be reproduced every time.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4c97710 (LWP 4257))]

Thread 3 (Thread 0xb15b2b70 (LWP 4353)):
[KCrash Handler]
#6  0xb67312d4 in QMutex::lock() () from /usr/lib/libQtCore.so.4
#7  0xb5678d93 in relock (this=0x9136ed8, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/include/QtCore/qmutex.h:120
#8  QMutexLocker (this=0x9136ed8, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/include/QtCore/qmutex.h:102
#9  Soprano::Client::ClientModel::executeQuery (this=0x9136ed8, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/soprano-2.4.2/client/clientmodel.cpp:103
#10 0xb745cac5 in Nepomuk::MainModel::executeQuery (this=0x81ba4d0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/nepomukmainmodel.cpp:214
#11 0xb734985f in Soprano::FilterModel::executeQuery (this=0x80f1900, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/soprano-2.4.2/soprano/filtermodel.cpp:164
#12 0xb7464116 in Nepomuk::ResourceData::determineUri (this=0xb24536c0) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:673
#13 0xb7474ea9 in Nepomuk::ResourceData::load (this=0xb24536c0) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:415
#14 0xb74759a8 in Nepomuk::ResourceData::property (this=0xb24536c0, uri=...) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:271
#15 0xb7475a79 in Nepomuk::Resource::property (this=0xb15b22a8, uri=...) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:280
#16 0xb7475f55 in Nepomuk::Resource::tags (this=0xb15b22a8) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:633
#17 0x0809c36e in _start ()

Thread 2 (Thread 0xb1db3b70 (LWP 4355)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5a9e0b1 in select () from /lib/libc.so.6
#2  0xb685881f in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timeval const*) () from /usr/lib/libQtCore.so.4
#3  0xb5561650 in ?? () from /usr/lib/libQtNetwork.so.4
#4  0xb55486fd in ?? () from /usr/lib/libQtNetwork.so.4
#5  0xb555adb1 in QAbstractSocket::waitForReadyRead(int) () from /usr/lib/libQtNetwork.so.4
#6  0xb5563f13 in QLocalSocket::waitForReadyRead(int) () from /usr/lib/libQtNetwork.so.4
#7  0xb5675ed5 in Soprano::Client::ClientConnection::executeQuery (this=0x834c588, modelId=1641645676, query=..., type=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/soprano-2.4.2/client/clientconnection.cpp:259
#8  0xb5678c0b in Soprano::Client::ClientModel::executeQuery (this=0xb0c04928, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/soprano-2.4.2/client/clientmodel.cpp:101
#9  0xb745cac5 in Nepomuk::MainModel::executeQuery (this=0x81ba4d0, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/nepomukmainmodel.cpp:214
#10 0xb734985f in Soprano::FilterModel::executeQuery (this=0x80f1900, query=..., language=2983930504, userQueryLanguage=...) at /usr/src/debug/soprano-2.4.2/soprano/filtermodel.cpp:164
#11 0xb7464116 in Nepomuk::ResourceData::determineUri (this=0xb0c1a5a0) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:673
#12 0xb7474ea9 in Nepomuk::ResourceData::load (this=0xb0c1a5a0) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:415
#13 0xb74759a8 in Nepomuk::ResourceData::property (this=0xb0c1a5a0, uri=...) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:271
#14 0xb7475a79 in Nepomuk::Resource::property (this=0xb1db32a8, uri=...) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:280
#15 0xb7475cad in Nepomuk::Resource::rating (this=0xb1db32a8) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:800
#16 0x0809c2a7 in _start ()

Thread 1 (Thread 0xb4c97710 (LWP 4257)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5a9a75e in poll () from /lib/libc.so.6
#2  0xb50f0470 in ?? () from /usr/lib/libxcb.so.1
#3  0xb50f0a82 in ?? () from /usr/lib/libxcb.so.1
#4  0xb50f0b31 in xcb_writev () from /usr/lib/libxcb.so.1
#5  0xb57f2490 in _XSend () from /usr/lib/libX11.so.6
#6  0xb57f2738 in _XEventsQueued () from /usr/lib/libX11.so.6
#7  0xb57db2e8 in XEventsQueued () from /usr/lib/libX11.so.6
#8  0xb5e34053 in ?? () from /usr/lib/libQtGui.so.4
#9  0xb52a70c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#10 0xb52a7f22 in ?? () from /usr/lib/libglib-2.0.so.0
#11 0xb52a860e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#12 0xb685bd4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#13 0xb5e3419a in ?? () from /usr/lib/libQtGui.so.4
#14 0xb682f11d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#15 0xb682f319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#16 0xb6833c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#17 0xb5d81164 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#18 0x080785b5 in _start ()

This bug may be a duplicate of or related to bug 251261, bug 235166.

Possible duplicates by query: bug 253906, bug 252886, bug 251769, bug 251759, bug 251400.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-25 17:19:44 UTC
[Comment from a bug triager]
This issue is being tracked at bug 235166. Merging. Thanks

*** This bug has been marked as a duplicate of bug 235166 ***