Bug 247416

Summary: crash when enabling sun shading
Product: marble Reporter: Bernhard Beschow <shentey>
Component: generalAssignee: marble-bugs
Status: RESOLVED FIXED    
Severity: crash CC: turner.isaac, vince
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux Packages   
OS: Linux   
Latest Commit: Version Fixed In: 4.7.1

Description Bernhard Beschow 2010-08-11 20:39:34 UTC
Application: marble (0.11.0 SVN)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.34-ARCH i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
When enabling the sun shading (not citylights) in the new sun control box, Marble crashes immediately.

The crash can be reproduced every time.

 -- Backtrace:
Application: Marble-Schreibtischglobus (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3d05710 (LWP 13415))]

Thread 4 (Thread 0xb2404b70 (LWP 13416)):
#0  0xb7719424 in __kernel_vsyscall ()
#1  0xb5d24e26 in poll () from /lib/libc.so.6
#2  0xb46e868b in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb46d868f in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#4  0xb46d8a04 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6ba0eb7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6b75119 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb6b7538a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb6a8188d in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb6b572db in ?? () from /usr/lib/libQtCore.so.4
#10 0xb6a8432e in ?? () from /usr/lib/libQtCore.so.4
#11 0xb5ba6e60 in start_thread () from /lib/libpthread.so.0
#12 0xb5d2f20e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb1711b70 (LWP 13420)):
#0  0xb4769d46 in clock_gettime () from /lib/librt.so.1
#1  0xb6b9db8b in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6ba1c72 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6ba06c2 in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6ba075d in ?? () from /usr/lib/libQtCore.so.4
#5  0xb46d7496 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0xb46d8333 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#7  0xb46d8a04 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0xb6ba0eb7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6b75119 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6b7538a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6a8188d in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0xb6b572db in ?? () from /usr/lib/libQtCore.so.4
#13 0xb6a8432e in ?? () from /usr/lib/libQtCore.so.4
#14 0xb5ba6e60 in start_thread () from /lib/libpthread.so.0
#15 0xb5d2f20e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb09acb70 (LWP 13421)):
#0  0xb46d7a69 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#1  0xb46d851a in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#2  0xb46d8a04 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0xb6ba0eb7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0xb6b75119 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb6b7538a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb6a8188d in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0xb75ff340 in Marble::FileStorageWatcher::run (this=0x8dc0c50) at /home/shentey/Projekte/marble/src/src/lib/FileStorageWatcher.cpp:401
#8  0xb6a8432e in ?? () from /usr/lib/libQtCore.so.4
#9  0xb5ba6e60 in start_thread () from /lib/libpthread.so.0
#10 0xb5d2f20e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb3d05710 (LWP 13415)):
[KCrash Handler]
#6  Marble::GeoSceneTexture::levelZeroColumns (this=0x0) at /home/shentey/Projekte/marble/src/src/lib/geodata/scene/GeoSceneTexture.cpp:90
#7  0xb7630c2e in Marble::MergedLayerDecorator::paintSunShading (this=0x8fcfd08) at /home/shentey/Projekte/marble/src/src/lib/MergedLayerDecorator.cpp:117
#8  0xb76322ca in Marble::MergedLayerDecorator::paint (this=0x8fcfd08, themeId=..., mapTheme=0x8ffee38) at /home/shentey/Projekte/marble/src/src/lib/MergedLayerDecorator.cpp:83
#9  0xb7566bfb in Marble::MarbleModel::paintTile (this=0x8e90910, tile=0xb1b14528, textureLayer=0xb1b0bef8) at /home/shentey/Projekte/marble/src/src/lib/MarbleModel.cpp:931
#10 0xb760a03a in Marble::StackedTileLoader::mergeDecorations (this=0xb1b014c0, stackedTileId=..., usage=Marble::DownloadBrowse, forMergedLayerDecorator=false)
    at /home/shentey/Projekte/marble/src/src/lib/StackedTileLoader.cpp:502
#11 Marble::StackedTileLoader::loadTile (this=0xb1b014c0, stackedTileId=..., usage=Marble::DownloadBrowse, forMergedLayerDecorator=false)
    at /home/shentey/Projekte/marble/src/src/lib/StackedTileLoader.cpp:228
#12 0xb75f53ca in Marble::AbstractScanlineTextureMapper::nextTile (this=0x9055150, posX=@0xbffa2d38, posY=@0xbffa2d30)
    at /home/shentey/Projekte/marble/src/src/lib/AbstractScanlineTextureMapper.cpp:547
#13 0xb75f54e6 in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0x9055150, lon=-0.16918435837645052, lat=1.0075472960365111, scanLine=0xb0d79008)
    at /home/shentey/Projekte/marble/src/src/lib/AbstractScanlineTextureMapper.cpp:142
#14 0xb75f672b in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x9055150, viewParams=0x8e5635c) at /home/shentey/Projekte/marble/src/src/lib/SphericalScanlineTextureMapper.cpp:204
#15 0xb75692a1 in Marble::MarbleModel::paintGlobe (this=0x8e90910, painter=0xbffa31b0, width=838, height=498, viewParams=0x8e5635c, redrawBackground=true, dirtyRect=...)
    at /home/shentey/Projekte/marble/src/src/lib/MarbleModel.cpp:606
#16 0xb756dbb7 in Marble::MarbleMapPrivate::paintGround (this=0x8e56348, painter=..., dirtyRect=...) at /home/shentey/Projekte/marble/src/src/lib/MarbleMap.cpp:242
#17 0xb755cc26 in Marble::MarbleWidget::paintEvent (this=0x8e3b480, evt=0xbffa3774) at /home/shentey/Projekte/marble/src/src/lib/MarbleWidget.cpp:820
#18 0xb615717e in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#19 0xb60fff14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb61041ab in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb70703ea in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb6b75ecb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb6151dd4 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#24 0xb631d951 in ?? () from /usr/lib/libQtGui.so.4
#25 0xb6148013 in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#26 0xb61577dd in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb6556897 in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb71524cc in KMainWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#29 0xb71903cf in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#30 0xb60fff14 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#31 0xb61041ab in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#32 0xb70703ea in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#33 0xb6b75ecb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#34 0xb6b799c1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#35 0xb6b79bad in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#36 0xb6ba098f in ?? () from /usr/lib/libQtCore.so.4
#37 0xb46d7f72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#38 0xb46d8750 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#39 0xb46d8a04 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#40 0xb6ba0e7c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb61ac1b5 in ?? () from /usr/lib/libQtGui.so.4
#42 0xb6b75119 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#43 0xb6b7538a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#44 0xb6b79c6f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#45 0xb60fd637 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#46 0x0805ce9d in main (argc=0, argv=0x2) at /home/shentey/Projekte/marble/src/src/kdemain.cpp:333

Reported using DrKonqi
Comment 1 Bernhard Beschow 2011-08-05 22:39:38 UTC
*** Bug 268183 has been marked as a duplicate of this bug. ***
Comment 3 Jekyll Wu 2012-07-05 21:07:42 UTC
*** Bug 280376 has been marked as a duplicate of this bug. ***