Bug 233232

Summary: facebook/Jabber on Kopete does not work anymore
Product: kopete Reporter: Leo <sir_kalot>
Component: generalAssignee: Kopete Developers <kopete-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: gfdsa, guilo19, idonthack, jouni.karlsson, maggsimo, markotahal, pali.rohar, theunfor, weits, yehielb
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Leo 2010-04-04 11:30:27 UTC
Version:           1.0.0 (using 4.4.2 (KDE 4.4.2), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.31-21-generic

Hi all, 
I've tried to configure my kopete to use jabber to comunicate with facebook as described here:
http://www.facebook.com/help/?faq=16739
But when I try to connect I get the following errors on the xml console (I've just removed the username)


<?xml version="1.0"?>

<stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="chat.facebook.com">

<?xml version="1.0"?><stream:stream id="453D8287" from="chat.facebook.com" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en">

<iq type="get" to="chat.facebook.com" id="auth_1">
<query xmlns="jabber:iq:auth">
<username>XXXXXXXXXXXX</username>
</query>
</iq>

<stream:error>
<unsupported-version xmlns="urn:ietf:params:xml:ns:xmpp-streams"/>
<text xmlns="urn:ietf:params:xml:ns:xmpp-streams" xml:lang="">XMPP 1.0 is required</text>
</stream:error>

Anyone could help me pls

Leo
Comment 1 Jouni Karlsson 2010-06-27 20:34:31 UTC
Affects also Kopete shipped with 4.5 beta 2

Qt: 4.7.0
KDE Development Platform: 4.4.85 (KDE 4.4.85 (KDE 4.5 Beta2))
Kopete: 1.0.80


XML Console output:

<?xml version="1.0"?>

<stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="chat.facebook.com">

<?xml version="1.0"?><stream:stream id="3575957F" from="chat.facebook.com" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en">

<iq type="get" to="chat.facebook.com" id="auth_1">
<query xmlns="jabber:iq:auth">
<username>foo.bar</username>
</query>
</iq>

<stream:error>
<unsupported-version xmlns="urn:ietf:params:xml:ns:xmpp-streams"/>
<text xmlns="urn:ietf:params:xml:ns:xmpp-streams" xml:lang="">XMPP 1.0 is required</text>
</stream:error>



Console output when trying to connect:

foo@bar:~$ kopete --nofork --noplugins --autoconnect foo.bar@chat.facebook.com
kopete(28648)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "/home/foo/.kde/share/apps/kabc" 
kopete(28648)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795
Comment 2 Mark 2010-09-22 15:18:14 UTC
I can confirm this bug on Archlinux, kopete 1.0.80, kde 4.5.1
facebook chat via jabber used to work for me, some time ago it stopped working. 
Unlike the others above, I don't see any messages in XML console. Is there any command to send to get some output? Any way I could help debug this problem? 
Thank you, Mark
Comment 3 Mark 2010-09-22 15:24:56 UTC
...i forgot: 
* tried with clean .kde4, not helpful. 
* run: 
$  kopete --nofork --noplugins --noconnect --autoconnect marek.prijmeni@chat.facebook.com
kopete(8334) Kopete::Global::Properties::Properties:
kopete(8334) Kopete::IdentityManager::load: Created identity  "JPbcfFQQv0"
kopete(8334) Kopete::IdleTimer::IdleTimer: Using platform idle timer
kopete(8334) ContactList::LayoutManager::loadUserLayouts: found user file:  "Compact2.xml"
kopete(8334) ContactList::LayoutManager::loadUserLayouts: found user file:  "mmm.xml"
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kopete(8334) KDBusServiceStarter::findServiceFor: DBus service is available now, as "org.kde.kontact"
kopete(8334)/kresources Kolab::KMailConnection::checkReply: D-Bus communication with KMail failed. Reply error is:  QDBusError("org.freedesktop.DBus.Error.UnknownObject", "No such object path '/Groupware'") Last interface error was:  QDBusError("", "") 
kopete(8334)/kdepimlibs (kabc): "Unable to open resource 'imap-resource'." 
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteApplication::slotAllPluginsLoaded: initial status set in config:  2
kopete(8334) KopeteApplication::slotAllPluginsLoaded: initial status set in config:  2
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
Unknown signature value:  795
Comment 4 Mark 2010-09-22 15:28:07 UTC
...i forgot: 
* tried with clean .kde4, not helpful. 
* run: 
$  kopete --nofork --noplugins --noconnect --autoconnect aaa.bbb@chat.facebook.com
kopete(8334) Kopete::Global::Properties::Properties:
kopete(8334) Kopete::IdentityManager::load: Created identity  "JPbcfFQQv0"
kopete(8334) Kopete::IdleTimer::IdleTimer: Using platform idle timer
kopete(8334) ContactList::LayoutManager::loadUserLayouts: found user file:  "Compact2.xml"
kopete(8334) ContactList::LayoutManager::loadUserLayouts: found user file:  "mmm.xml"
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
kopete(8334) KDBusServiceStarter::findServiceFor: DBus service is available now, as "org.kde.kontact"
kopete(8334)/kresources Kolab::KMailConnection::checkReply: D-Bus communication with KMail failed. Reply error is:  QDBusError("org.freedesktop.DBus.Error.UnknownObject", "No such object path '/Groupware'") Last interface error was:  QDBusError("", "") 
kopete(8334)/kdepimlibs (kabc): "Unable to open resource 'imap-resource'." 
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
kopete(8334) KopeteApplication::slotAllPluginsLoaded: initial status set in config:  2
kopete(8334) KopeteApplication::slotAllPluginsLoaded: initial status set in config:  2
kopete(8334) KopeteWindow::slotIdentityStatusIconChanged: QVariant(, )
Unknown signature value:  795
Comment 5 lazx888 2010-09-26 18:30:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 guilo19 2010-10-01 23:15:22 UTC
Same here on Kubuntu 10.04, Kopete 1.0.80
Comment 7 Anthony Winslow 2010-10-17 01:26:00 UTC
i have the same problem with kopete 1.0.80 (kde 4.5.2)

it appears the problem is the lack of a "version" attribute in the initial <stream:stream> element.

i can get a good response from the chat.facebook.com server if i cut+paste kopete's attempt at communication, and manually add a version attribute. proceeding with a request for DIGEST-MD5 authentication will generate an authentication challenge from the server:

$ telnet chat.facebook.com 5222

<?xml version="1.0"?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="chat.facebook.com" version='1.0'>

<?xml version="1.0"?><stream:stream id="A893C4B8" from="chat.facebook.com" xmlns="jabber:client" xmlns:stream="http://etherx.jabber.org/streams" version="1.0" xml:lang="en"><stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>X-FACEBOOK-PLATFORM</mechanism><mechanism>DIGEST-MD5</mechanism></mechanisms></stream:features>

<auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='DIGEST-MD5' />

<challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09ImNoYXQuZmFjZWJvb2suY29tIixub25jZT0iMTU3MzI2RURGMkExMkRBNzFGMzQ0MThDMTc3MDQ4NzAiLHFvcD0iYXV0aCIsY2hhcnNldD11dGYtOCxhbGdvcml0aG09bWQ1LXNlc3M=</challenge>

unfortunately i cannot decode base64 in my head, and i don't know anything else about jabber, so i cannot manually authenticate using telnet.
Comment 8 Petr Svoboda 2010-11-08 12:28:20 UTC
Same here on Kubuntu 10.10 with KDE 4.5.3 from PPA
Comment 9 Mark 2010-11-08 15:11:23 UTC
just to add, for me it's just facebook problem, other jabber (GTalk) works fine. still persisting in kde 4.5.3 on arch too
Comment 10 Rodric Glaser 2010-11-12 19:17:59 UTC
I experience this problem connecting to an openfire jabber server from kubuntu's kopete 4.5.1-0ubuntu2.  However, the same account has worked from sabyon's kopete build of 4.5.1 through 4.5.3.
Comment 11 Rodric Glaser 2010-11-13 23:12:30 UTC
(In reply to comment #10)
> I experience this problem connecting to an openfire jabber server from
> kubuntu's kopete 4.5.1-0ubuntu2.  However, the same account has worked from
> sabyon's kopete build of 4.5.1 through 4.5.3.
Apologies for misspelling Sabayon.  The version currently working for me is:
Qt: 4.7.1
KDE Development Platform: 4.5.3 (KDE 4.5.3)
Kopete: 1.0.80

Google shows "Unknown signature value:  795" may be TLS related so I thought I would mention Sabayon shows qca-ossl at 2.0.0_beta3-r1 while Kubuntu shows libqca2-plugin-ossl at 0.1~20070904-4build1.
Comment 12 Mark 2010-11-15 09:04:59 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > I experience this problem connecting to an openfire jabber server from
> > kubuntu's kopete 4.5.1-0ubuntu2.  However, the same account has worked from
> > sabyon's kopete build of 4.5.1 through 4.5.3.
> Apologies for misspelling Sabayon.  The version currently working for me is:
> Qt: 4.7.1
> KDE Development Platform: 4.5.3 (KDE 4.5.3)
> Kopete: 1.0.80
> 
> Google shows "Unknown signature value:  795" may be TLS related so I thought I
> would mention Sabayon shows qca-ossl at 2.0.0_beta3-r1 while Kubuntu shows
> libqca2-plugin-ossl at 0.1~20070904-4build1.

i have the qca-ossl at version 2.0.0 in Arch too, but facebook doesn't work, gtalk does.
Comment 13 Mark 2010-11-26 07:58:40 UTC
Unfortunately still can confirm on kde 4.6beta1
Comment 14 Petr Svoboda 2010-12-15 11:28:17 UTC
Still not working on kde 4.6beta2 on Kubuntu 10.10
Comment 15 guilo19 2010-12-15 11:36:23 UTC
For me it is working again with 1.0.80 on KDE 4.5.4. I retried 2 weeks ago and it was working. I have MSN + Gmail account for chat + Facebook on Kopete working. Unfortunately I can't tell if any update came to solve the problem. But here is the fact. It works for me with that same version I said not to work (comment #6). So maybe the problem is in a backend and not in Kopete itself
Comment 16 Petr Svoboda 2010-12-15 12:29:17 UTC
After some trying to make it work, it works again. What I did:

1. removed the old jabber account for facebook
2. created a new one this way: 
jabberID: jirka.sirka@chat.facebook.com
and on the connection tab leave all three checkboxes UNchecked

and it started to work!
Comment 17 Michael 2010-12-15 12:35:42 UTC
(In reply to comment #16)
> After some trying to make it work, it works again. What I did:
> 
> 1. removed the old jabber account for facebook
> 2. created a new one this way: 
> jabberID: jirka.sirka@chat.facebook.com
> and on the connection tab leave all three checkboxes UNchecked
> 
> and it started to work!

wow. this works for me too.
Comment 18 Mark 2010-12-15 21:20:32 UTC
lucky you guys, unfortunately, it still doesn't do the trick for me :( kde4.6b2,archlinux
Comment 19 Johannes Christenson 2010-12-18 21:12:17 UTC
(In reply to comment #16)
> After some trying to make it work, it works again. What I did:
> 
> 1. removed the old jabber account for facebook
> 2. created a new one this way: 
> jabberID: jirka.sirka@chat.facebook.com
> and on the connection tab leave all three checkboxes UNchecked
> 
> and it started to work!

Works for me! :-)
Comment 20 Rodric Glaser 2011-01-17 20:19:13 UTC
Please see:
https://bugs.kde.org/show_bug.cgi?id=221533#c16

I can confirm applying the "workaround" qca-ossl-fix.patch to libqca2-plugin-ossl_0.1~20070904-4build1 allows my kopete to connect to the openfire server.

http://rt.openssl.org/Ticket/Display.html?id=2240 Indicates the root problem has been fixed upstream but I did not see a diff that easily applies to openssl-0.9.8o-1ubuntu4.3
Comment 21 Mark 2011-01-27 14:14:11 UTC
ok, works for me finally too :) 
archlinux, kde4.6, kdepim 4.4.9

I didn't do any workarounds, it just started to work after upgrade. 

Good job, thanks a lot guys! :)
Comment 22 simag 2011-02-22 00:05:30 UTC
> After some trying to make it work, it works again. What I did:
> 
> 1. removed the old jabber account for facebook
> 2. created a new one this way: 
> jabberID: jirka.sirka@chat.facebook.com
> and on the connection tab leave all three checkboxes UNchecked
> 
> and it started to work!

kubuntu 10.10 kde 4.6 

work for me
Comment 23 Leo 2011-02-22 08:34:22 UTC
Is there anyone who hase still this problem? otherwise I think this bug could be closed...

Leo
Comment 24 Dj YB 2011-05-27 19:13:19 UTC
facebook chat using xmpp not working for me either
but I don;t know how to get the output provided above, how do I get to an XML console?
Comment 25 JoseLuisT 2013-11-24 03:29:34 UTC
Still doesn't work, I don't think this is been fixed, or in fb the things changed again... 

KDE 4.10 and KDE 4.8.4

<?xml version="1.0"?>

<stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="chat.facebook.com">

<?xml version='1.0' ?><stream:stream from='chat.facebook.com' id='1' version='1.0' xmlns:stream='http://etherx.jabber.org/streams' xmlns='jabber:client' xml:lang='en'>

<iq type="get" to="chat.facebook.com" id="auth_1">
<query xmlns="jabber:iq:auth">
<username>joseluisf.triana</username>
</query>
</iq>

<stream:features>
<starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
<mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl">
<mechanism>X-FACEBOOK-PLATFORM</mechanism>
<mechanism>PLAIN</mechanism>
</mechanisms>
</stream:features>

<stream:error>
<not-authorized xmlns="urn:ietf:params:xml:ns:xmpp-streams"/>
</stream:error>
Comment 26 Pali Rohár 2013-11-24 09:51:14 UTC
@JoseLuisT: Check if you have enabled plain text authentification in connection tab in account settings.
Comment 27 JoseLuisT 2013-11-24 16:19:27 UTC
(In reply to comment #26)
> @JoseLuisT: Check if you have enabled plain text authentification in
> connection tab in account settings.

Yes, I have it, it does not connect, If I uncheck that option, does not change anything can't connect.
Comment 28 Pali Rohár 2013-11-24 16:31:42 UTC
@JoseLuisT: see bug 324937 It was fixed in KDE 4.12 and backported to KDE 4.11.3. Now I see that you used KDE 4.10, so upgrade to KDE 4.11.3 first.