Bug 228438

Summary: Launching Akregator pops up a Kontact crash window
Product: [Applications] akregator Reporter: RICARDO CARRILLO CRUZ <emaildericky>
Component: kontact pluginAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Archlinux   
OS: Linux   
Latest Commit: Version Fixed In:

Description RICARDO CARRILLO CRUZ 2010-02-25 12:16:01 UTC
Version:            (using KDE 4.4.0)
OS:                Linux
Installed from:    Archlinux Packages

Hi guys

I can consistenly reproduce an issue on my desktop.

- Launch Kontact 
- Switch to kmail view
- Kmail gets stuck loading imail from an imap server forever
- Close Kontact
- Click on Kontact icon
- Kontact doesn't show up, it doesn't start at all
- Launch akregator
- Crash window from Kontact shows up. This is the trace:

Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f76321b9308 in KontactInterface::UniqueAppHandler::newInstance() () from /usr/lib/libkontactinterface.so.4
#6  0x00007f761a52d53e in AkregatorUniqueAppHandler::newInstance() () from /usr/lib/kde4/kontact_akregatorplugin.so
#7  0x00007f76321b93b9 in KontactInterface::UniqueAppHandler::newInstance(QByteArray const&, QByteArray const&) () from /usr/lib/libkontactinterface.so.4
#8  0x00007f76321b9424 in KontactInterface::UniqueAppHandler::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkontactinterface.so.4
#9  0x00007f762e4bd791 in ?? () from /usr/lib/libQtDBus.so.4
#10 0x00007f762e4be99f in ?? () from /usr/lib/libQtDBus.so.4
#11 0x00007f762e4bf1be in ?? () from /usr/lib/libQtDBus.so.4
#12 0x00007f762e4bf718 in ?? () from /usr/lib/libQtDBus.so.4
#13 0x00007f7631017419 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0x00007f76303cb5ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x00007f76303d1bdb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f76319d4cd6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x00007f763100779c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x00007f7631009f17 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#19 0x00007f76310310d3 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f762883826e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#21 0x00007f762883bc28 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#22 0x00007f762883bd50 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#23 0x00007f7631030c13 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#24 0x00007f7630479d6e in ?? () from /usr/lib/libQtGui.so.4
#25 0x00007f76310060c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f763100649c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f763100a1db in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#28 0x0000000000403b3e in _start ()

- Click on 'Restart Application' and then Kontact shows up

Let me know if you want me to make any further tests.

Regards
Comment 1 Christophe Marin 2010-02-25 12:28:00 UTC

*** This bug has been marked as a duplicate of bug 194268 ***