Bug 223647

Summary: Kontact segfault after printing an email with attachement
Product: [Applications] kontact Reporter: François Bianco <fbianco>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:
Sentry Crash Report:

Description François Bianco 2010-01-21 09:38:15 UTC
Application that crashed: kontact
Version of the application: 4.3.4
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-trunk-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
I just printed one email, and then selected an other one, then Kontact crashed.

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7ffd9f570750 (LWP 9739))]

Thread 3 (Thread 0x7ffd80049910 (LWP 9753)):
#0  0x00007ffd9cb6dfc2 in select () from /lib/libc.so.6
#1  0x00007ffd9de4ad36 in QProcessManager::run (this=0x1cc6f40) at io/qprocess_unix.cpp:296
#2  0x00007ffd9dd864a5 in QThreadPrivate::start (arg=0x1cc6f40) at thread/qthread_unix.cpp:188
#3  0x00007ffd9692473a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007ffd9cb746dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffd6b610910 (LWP 14354)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007ffd9dd87499 in QWaitConditionPrivate::wait (this=0x1f51c60, mutex=0x1f51c58, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=0x1f51c60, mutex=0x1f51c58, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007ffd9837b3b4 in QHostInfoAgent::run (this=0x1f51c40) at kernel/qhostinfo.cpp:260
#4  0x00007ffd9dd864a5 in QThreadPrivate::start (arg=0x1f51c40) at thread/qthread_unix.cpp:188
#5  0x00007ffd9692473a in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007ffd9cb746dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffd9f570750 (LWP 9739)):
[KCrash Handler]
#5  0x00007ffd86fa54e1 in DwString::c_str (aDwBodyPart=0x2177800, aPart=0x34e6e68, withBody=true) at ../../mimelib/mimelib/string.h:618
#6  DwMessageComponent::partId (aDwBodyPart=0x2177800, aPart=0x34e6e68, withBody=true) at ../../mimelib/mimelib/msgcmp.h:259
#7  KMMessage::bodyPart (aDwBodyPart=0x2177800, aPart=0x34e6e68, withBody=true) at ../../kmail/kmmessage.cpp:2721
#8  0x00007ffd872c9db9 in partNode::msgPart (this=<value optimized out>, url=..., w=0x22dbc90) at ../../kmail/partNode.h:99
#9  statusBarMessage (this=<value optimized out>, url=..., w=0x22dbc90) at ../../kmail/urlhandlermanager.cpp:549
#10 0x00007ffd872c9a94 in KMail::URLHandlerManager::statusBarMessage (this=0x384ad50, url=..., w=0x22dbc90) at ../../kmail/urlhandlermanager.cpp:323
#11 0x00007ffd8709236c in KMReaderWin::slotUrlOn (this=0x22dbc90, aUrl=<value optimized out>) at ../../kmail/kmreaderwin.cpp:2031
#12 0x00007ffd87094e4e in KMReaderWin::qt_metacall (this=0x22dbc90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff75bb7a90) at ./kmreaderwin.moc:178
#13 0x00007ffd9de80df2 in QMetaObject::activate (sender=0x22ed180, from_signal_index=<value optimized out>, to_signal_index=14, argv=0x111) at kernel/qobject.cpp:3112
#14 0x00007ffd9beb41c2 in KHTMLPart::onURL (this=0x7ffd9cdf8e60, _t1=<value optimized out>) at ./khtml_part.moc:400
#15 0x00007ffd9beca730 in KHTMLPart::overURL (this=0x22ed180, url=..., target=...) at ../../khtml/khtml_part.cpp:3521
#16 0x00007ffd9becc781 in KHTMLPart::handleMouseMoveEventOver (this=0x22ed180, event=<value optimized out>) at ../../khtml/khtml_part.cpp:6355
#17 0x00007ffd9beccb3b in KHTMLPart::khtmlMouseMoveEvent (this=0x22ed180, event=0x7fff75bb8dd0) at ../../khtml/khtml_part.cpp:6403
#18 0x00007ffd9de7b715 in QObject::event (this=0x22ed180, e=0x7fff75bb8dd0) at kernel/qobject.cpp:1141
#19 0x00007ffd9d2e501d in QApplicationPrivate::notify_helper (this=0x1ccdcd0, receiver=0x22ed180, e=0x7fff75bb8dd0) at kernel/qapplication.cpp:4065
#20 0x00007ffd9d2ed07a in QApplication::notify (this=0x7fff75bbba20, receiver=0x22ed180, e=0x7fff75bb8dd0) at kernel/qapplication.cpp:4030
#21 0x00007ffd9e811e06 in KApplication::notify (this=0x7fff75bbba20, receiver=0x22ed180, event=0x7fff75bb8dd0) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x00007ffd9de6bc9c in QCoreApplication::notifyInternal (this=0x7fff75bbba20, receiver=0x22ed180, event=0x7fff75bb8dd0) at kernel/qcoreapplication.cpp:610
#23 0x00007ffd9bea8052 in QCoreApplication::sendEvent (this=0x22effc0, _mouse=<value optimized out>) at /usr/include/qt4/QtCore/qcoreapplication.h:213
#24 KHTMLView::mouseMoveEvent (this=0x22effc0, _mouse=<value optimized out>) at ../../khtml/khtmlview.cpp:1541
#25 0x00007ffd9d335218 in QWidget::event (this=0x22effc0, event=0x7fff75bb9c60) at kernel/qwidget.cpp:7539
#26 0x00007ffd9d69d92b in QFrame::event (this=0x22effc0, e=0x7fff75bb9c60) at widgets/qframe.cpp:559
#27 0x00007ffd9bea5095 in KHTMLView::widgetEvent (this=0x22effc0, e=0x0) at ../../khtml/khtmlview.cpp:2338
#28 0x00007ffd9bea53af in KHTMLView::eventFilter (this=0x22effc0, o=0x22f2380, e=0x7fff75bb9c60) at ../../khtml/khtmlview.cpp:2191
#29 0x00007ffd9de6afb8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x22f2380, event=0x7fff75bb9c60) at kernel/qcoreapplication.cpp:726
#30 0x00007ffd9d2e4fec in QApplicationPrivate::notify_helper (this=0x1ccdcd0, receiver=0x22f2380, e=0x7fff75bb9c60) at kernel/qapplication.cpp:4061
#31 0x00007ffd9d2ed7ca in QApplication::notify (this=<value optimized out>, receiver=0x22f2380, e=0x7fff75bb9c60) at kernel/qapplication.cpp:3767
#32 0x00007ffd9e811e06 in KApplication::notify (this=0x7fff75bbba20, receiver=0x22f2380, event=0x7fff75bb9c60) at ../../kdeui/kernel/kapplication.cpp:302
#33 0x00007ffd9de6bc9c in QCoreApplication::notifyInternal (this=0x7fff75bbba20, receiver=0x22f2380, event=0x7fff75bb9c60) at kernel/qcoreapplication.cpp:610
#34 0x00007ffd9d2eca78 in QCoreApplication::sendSpontaneousEvent (receiver=0x22f2380, event=0x7fff75bb9c60, alienWidget=0x22f2380, nativeWidget=0x22ba4c0, buttonDown=<value optimized out>, 
    lastMouseReceiver=...) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#35 QApplicationPrivate::sendMouseEvent (receiver=0x22f2380, event=0x7fff75bb9c60, alienWidget=0x22f2380, nativeWidget=0x22ba4c0, buttonDown=<value optimized out>, lastMouseReceiver=...)
    at kernel/qapplication.cpp:2924
#36 0x00007ffd9d355659 in QETWidget::translateMouseEvent (this=0x22ba4c0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4411
#37 0x00007ffd9d35440f in QApplication::x11ProcessEvent (this=0x7fff75bbba20, event=0x7fff75bbb630) at kernel/qapplication_x11.cpp:3552
#38 0x00007ffd9d37c76c in x11EventSourceDispatch (s=0x1cc5ee0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0x00007ffd96b7590e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#40 0x00007ffd96b792c8 in ?? () from /lib/libglib-2.0.so.0
#41 0x00007ffd96b793f0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#42 0x00007ffd9de9439c in QEventDispatcherGlib::processEvents (this=0x1c9b920, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#43 0x00007ffd9d37bf1f in QGuiEventDispatcherGlib::processEvents (this=0x7ffd9cdf8e60, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#44 0x00007ffd9de6a562 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007ffd9de6a934 in QEventLoop::exec (this=0x7fff75bbb960, flags=...) at kernel/qeventloop.cpp:201
#46 0x00007ffd9de6cba4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#47 0x0000000000403f17 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 213236

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-21 13:34:33 UTC
This is being tracked at bug 128357. Regards

*** This bug has been marked as a duplicate of bug 128357 ***