Bug 214854

Summary: kmix size is not restored by session management, only position.
Product: kmix Reporter: Thomas Capricelli <kdebugs.20.orzelf>
Component: generalAssignee: Christian Esken <esken>
Status: RESOLVED FIXED    
Severity: normal CC: benni, jp7677
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Thomas Capricelli 2009-11-16 18:36:02 UTC
Version:            (using KDE 4.3.3)
OS:                Linux
Installed from:    Gentoo Packages

Title says it all. I've checked currently reported kmix bugs, and most of them are related to .. erm.. sound. This one is not. 

It's disturbing,because the default size is so small that i can not do much with sliders. I have to get it bigger to be able to use it, and i have to do that at each startup...
Comment 1 Christian Esken 2010-05-19 12:30:56 UTC
I cannot reproduce this. Size is saved for me.

Are you still using KDE4.3.3, or are you able to try that with KDE4.x?
Comment 2 Thomas Capricelli 2010-05-19 13:25:54 UTC
the bug is still there here. I'm now using 4.4.3
kmix provides a systray icon. Right clicking on it, the menu provides a "Show mixer window". This is the window i'm speaking about (just to be sure).
Actually, maybe only the height is not restored right.
Comment 3 jens 2010-06-27 08:01:57 UTC
I see the same annoyance exists in KDE SC 4.5 RC1. The main mixer windows (thus where you have a lot of sliders and tabs) always starts upper left with a default size when clicking 'Mixer' in the window where you can adjust the master silder. Could you please let kmix remember its size, position and the selected tab?

(I'm using pulseaudio and since kmix offers direct support for pulse including moving of of streams it will be a much more used application than now. :) )
Comment 4 Thomas Capricelli 2010-08-14 22:27:10 UTC
Confirmed in 4.5 final
Comment 5 Christian Esken 2010-08-23 18:23:05 UTC
It might depend on timing. Because either KMix is restored by session management OR it is started by Autostart.

Because if KMix gets Autostarted, size and position will be random. Actually the position is stored by KMix, but I don't know how to do it with size (because the Layout manger might decide to overrule my code).
Comment 6 Christian Esken 2011-07-20 21:15:02 UTC
Oh, I now see that I misread your your bug report. It is not about starting the session (this works), but opening from Systray. Yes, I can confirm that. It doesn't work for me either. Actually currently KMix always opens with minimal size (which I actually don't find too small, as minimum size was increased recently).
Comment 7 Benni Hill 2012-05-03 19:19:28 UTC
I can reproduce this bug with KDE 4.8.2 but only when kmix (the systray applet) is automatically started. When I exit kmix (in systray), restart it and then click the "Mixer" button, the window is always positioned and sized right.
Comment 8 Christian Esken 2012-08-04 21:08:10 UTC
Cannot reproduce the click on "Mixer" form Systray anymore.
 -  KDE4.8.2
 - KMix 4.2

I also WILL NOT track the  click on "Mixer" form Systray in this ticket, because the bug report is about when restoring from session.

Orzel, I currently cannot see anything wrong any longer. Especially your issue with "default size is so small that i can not do much with sliders" is not true any longer. i would thus like to close this bug report. OK?

Please report back.
Comment 9 Christian Esken 2013-12-20 10:26:53 UTC
Git commit 0f7a603e1d327f76dbd6a62d08315b1956794d42 by Christian Esken.
Committed on 20/12/2013 at 10:17.
Pushed by esken into branch 'master'.

Configuration menu is now using Tabs to provide a more standard,
  convenient and pleasing layout
 Sound Menu: Play button reflects playback status and shows either
  "Play" or "Pause"
 Bugfixes and Features (CCBUGS, as most bugs are already closed). Hint: Some
bugs might have actually been alreay fixed ibn KDE4.11 or KDE4.12.

Bug ID	Severity	Summary
Related: bug 317926, bug 20, bug 315383, bug 299477, bug 256854, bug 304144, bug 296951, bug 303608, bug 319600
applet
volume control
position.

M  +9    -5    CMakeLists.txt
M  +41   -20   ChangeLog
M  +5    -1    apps/KMixApp.cpp
M  +167  -238  apps/kmix.cpp
M  +8    -13   apps/kmix.h
M  +3    -0    apps/kmixctrl.cpp
M  +3    -0    apps/kmixd.cpp
M  +18   -12   backends/mixer_backend.cpp
M  +1    -0    backends/mixer_backend.h
M  +229  -150  backends/mixer_mpris2.cpp
M  +23   -6    backends/mixer_mpris2.h
M  +8    -2    backends/mixer_oss.cpp
M  +1    -1    backends/mixer_pulse.cpp
M  +9    -9    core/ControlManager.cpp
M  +102  -15   core/GlobalConfig.cpp
M  +105  -47   core/GlobalConfig.h
M  +65   -31   core/kmixdevicemanager.cpp
M  +9    -4    core/mixdevice.cpp
M  +4    -12   core/mixdevice.h
M  +6    -4    core/mixer.cpp
M  +16   -10   core/mixertoolbox.cpp
M  +1    -1    core/version.h
M  +17   -3    core/volume.cpp
M  +9    -8    core/volume.h
M  +19   -6    gui/dialogchoosebackends.cpp
M  +1    -1    gui/dialogchoosebackends.h
M  +9    -2    gui/dialogviewconfiguration.cpp
M  +37   -10   gui/guiprofile.cpp
M  +27   -24   gui/guiprofile.h
M  +93   -118  gui/kmixdockwidget.cpp
M  +3    -4    gui/kmixdockwidget.h
M  +13   -11   gui/kmixerwidget.cpp
M  +296  -91   gui/kmixprefdlg.cpp
M  +82   -32   gui/kmixprefdlg.h
M  +87   -38   gui/mdwslider.cpp
M  +4    -2    gui/mdwslider.h
M  +69   -42   gui/viewbase.cpp
M  +1    -0    gui/viewbase.h
M  +25   -30   gui/viewdockareapopup.cpp
M  +1    -1    gui/viewdockareapopup.h
M  +4    -4    gui/viewsliders.cpp
M  +1    -1    gui/volumesliderextradata.h

http://commits.kde.org/kmix/0f7a603e1d327f76dbd6a62d08315b1956794d42