Bug 208545

Summary: Keditbookmark crashing while drag 'n dropping
Product: keditbookmarks Reporter: Fabio Puddu <fpuddu>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Fabio Puddu 2009-09-25 20:40:28 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-15-generic x86_64
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Keditbookmarks crashed while drag'n'dropping bookmarks in the main panel

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fd865c282a4 in QDomElementPrivate::save (this=0x2444290, s=@0x7fff6f730b80, depth=5, indent=1) at dom/qdom.cpp:4603
#6  0x00007fd865c1d634 in QDomNodePrivate::save (this=<value optimized out>, s=@0x7fff6f730b80, depth=5, indent=1) at dom/qdom.cpp:1916
#7  0x00007fd865c27e44 in QDomElementPrivate::save (this=0x2445de0, s=@0x7fff6f730b80, depth=4, indent=1) at dom/qdom.cpp:4640
#8  0x00007fd865c1d634 in QDomNodePrivate::save (this=<value optimized out>, s=@0x7fff6f730b80, depth=4, indent=1) at dom/qdom.cpp:1916
#9  0x00007fd865c27e44 in QDomElementPrivate::save (this=0x23f10e0, s=@0x7fff6f730b80, depth=3, indent=1) at dom/qdom.cpp:4640
#10 0x00007fd865c1d634 in QDomNodePrivate::save (this=<value optimized out>, s=@0x7fff6f730b80, depth=3, indent=1) at dom/qdom.cpp:1916
#11 0x00007fd865c27e44 in QDomElementPrivate::save (this=0x2443b30, s=@0x7fff6f730b80, depth=2, indent=1) at dom/qdom.cpp:4640
#12 0x00007fd865c1d634 in QDomNodePrivate::save (this=<value optimized out>, s=@0x7fff6f730b80, depth=2, indent=1) at dom/qdom.cpp:1916
#13 0x00007fd865c27e44 in QDomElementPrivate::save (this=0xfdd100, s=@0x7fff6f730b80, depth=1, indent=1) at dom/qdom.cpp:4640
#14 0x00007fd865c1d634 in QDomNodePrivate::save (this=<value optimized out>, s=@0x7fff6f730b80, depth=1, indent=1) at dom/qdom.cpp:1916
#15 0x00007fd865c27e44 in QDomElementPrivate::save (this=0xee84e0, s=@0x7fff6f730b80, depth=0, indent=1) at dom/qdom.cpp:4640
#16 0x00007fd865c2c785 in QDomDocumentPrivate::saveDocument (this=0xee22a0, s=@0x7fff6f730b80, indent=1, encUsed=<value optimized out>) at dom/qdom.cpp:6473
#17 0x00007fd865c2cec7 in QDomDocument::toString (this=0x7fff6f730cd0, indent=1) at dom/qdom.cpp:6845
#18 0x00007fd86633948b in KBookmarkManager::saveAs (this=0xe40be0, filename=@0xee0ed0, toolbarCache=<value optimized out>) at /build/buildd/kde4libs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:402
#19 0x00007fd866339933 in KBookmarkManager::emitChanged (this=0x3, group=@0x7fff6f730e50) at /build/buildd/kde4libs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:516
#20 0x00007fd8672e7b89 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#21 0x00007fd867304700 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#22 0x00007fd86433978d in QAbstractItemView::dropEvent (this=0xee1fa0, event=0x7fff6f731be0) at itemviews/qabstractitemview.cpp:1849
#23 0x00007fd863e9cb99 in QWidget::event (this=0xee1fa0, event=0x7fff6f731be0) at kernel/qwidget.cpp:7731
#24 0x00007fd86420ff0b in QFrame::event (this=0xee1fa0, e=0x7fff6f731be0) at widgets/qframe.cpp:559
#25 0x00007fd864345c0d in QAbstractItemView::viewportEvent (this=0xee1fa0, event=0x7fff6f731be0) at itemviews/qabstractitemview.cpp:1476
#26 0x00007fd86437d2d9 in QTreeView::viewportEvent (this=0xee1fa0, event=0x7fff6f731be0) at itemviews/qtreeview.cpp:1266
#27 0x00007fd8649cd9b8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xee6750, event=0x7fff6f731be0) at kernel/qcoreapplication.cpp:726
#28 0x00007fd863e4bf1c in QApplicationPrivate::notify_helper (this=0xdb77e0, receiver=0xee6750, e=0x7fff6f731be0) at kernel/qapplication.cpp:4052
#29 0x00007fd863e546d0 in QApplication::notify (this=<value optimized out>, receiver=0xee6750, e=0x7fff6f731be0) at kernel/qapplication.cpp:4009
#30 0x00007fd865812deb in KApplication::notify (this=0x7fff6f737440, receiver=0xee6750, event=0x7fff6f731be0) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#31 0x00007fd8649ce6ac in QCoreApplication::notifyInternal (this=0x7fff6f737440, receiver=0xee6750, event=0x7fff6f731be0) at kernel/qcoreapplication.cpp:610
#32 0x00007fd863eca775 in QX11Data::xdndHandleDrop (this=<value optimized out>, xe=<value optimized out>, passive=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#33 0x00007fd863ecf027 in QDragManager::drop (this=0x2349e00) at kernel/qdnd_x11.cpp:1709
#34 0x00007fd863ecf1bc in QDragManager::eventFilter (this=0x2349e00, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1302
#35 0x00007fd8649cda7c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0xdb77e0, receiver=0x243b360, event=0x7fff6f732420) at kernel/qcoreapplication.cpp:707
#36 0x00007fd863e4beb6 in QApplicationPrivate::notify_helper (this=0x3, receiver=0x2444328, e=0x7fd864cc1820) at kernel/qapplication.cpp:4031
#37 0x00007fd863e548ea in QApplication::notify (this=<value optimized out>, receiver=0x243b360, e=0x7fff6f732420) at kernel/qapplication.cpp:3758
#38 0x00007fd865812deb in KApplication::notify (this=0x7fff6f737440, receiver=0x243b360, event=0x7fff6f732420) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#39 0x00007fd8649ce6ac in QCoreApplication::notifyInternal (this=0x7fff6f737440, receiver=0x243b360, event=0x7fff6f732420) at kernel/qcoreapplication.cpp:610
#40 0x00007fd863e53b38 in QApplicationPrivate::sendMouseEvent (receiver=0x243b360, event=0x7fff6f732420, alienWidget=0x0, nativeWidget=0x243b360, buttonDown=<value optimized out>, 
    lastMouseReceiver=@0x7fd864883010) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#41 0x00007fd863ebdb19 in QETWidget::translateMouseEvent (this=0x243b360, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#42 0x00007fd863ebcb53 in QApplication::x11ProcessEvent (this=0x7fff6f737440, event=0x7fff6f733fa0) at kernel/qapplication_x11.cpp:3550
#43 0x00007fd863ee5454 in x11EventSourceDispatch (s=0xdbb320, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#44 0x00007fd85f6ec20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0x00007fd85f6ef8e0 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0x00007fd85f6efa7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0x00007fd8649f7a8f in QEventDispatcherGlib::processEvents (this=0xd9db50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#48 0x00007fd863ee4bdf in QGuiEventDispatcherGlib::processEvents (this=0x3, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#49 0x00007fd8649ccf42 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1869824656}) at kernel/qeventloop.cpp:149
#50 0x00007fd8649cd314 in QEventLoop::exec (this=0x23f10a0, flags={i = 1869824800}) at kernel/qeventloop.cpp:201
#51 0x00007fd863ece977 in QDragManager::drag (this=0x2349e00, o=<value optimized out>) at kernel/qdnd_x11.cpp:1969
#52 0x00007fd863e5e9c8 in QDrag::exec (this=0x11f8160, supportedActions={i = 1869825264}, defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#53 0x00007fd864343f3e in QAbstractItemView::startDrag (this=0xee1fa0, supportedActions={i = 1869825712}) at itemviews/qabstractitemview.cpp:3205
#54 0x00007fd8643411c7 in QAbstractItemView::mouseMoveEvent (this=0xee1fa0, event=0x7fff6f735340) at itemviews/qabstractitemview.cpp:1552
#55 0x00007fd863e9cf58 in QWidget::event (this=0xee1fa0, event=0x7fff6f735340) at kernel/qwidget.cpp:7534
#56 0x00007fd86420ff0b in QFrame::event (this=0xee1fa0, e=0x7fff6f735340) at widgets/qframe.cpp:559
#57 0x00007fd864345c0d in QAbstractItemView::viewportEvent (this=0xee1fa0, event=0x7fff6f735340) at itemviews/qabstractitemview.cpp:1476
#58 0x00007fd86437d2d9 in QTreeView::viewportEvent (this=0xee1fa0, event=0x7fff6f735340) at itemviews/qtreeview.cpp:1266
#59 0x00007fd8649cd9b8 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xee6750, event=0x7fff6f735340) at kernel/qcoreapplication.cpp:726
#60 0x00007fd863e4bf1c in QApplicationPrivate::notify_helper (this=0xdb77e0, receiver=0xee6750, e=0x7fff6f735340) at kernel/qapplication.cpp:4052
#61 0x00007fd863e548ea in QApplication::notify (this=<value optimized out>, receiver=0xee6750, e=0x7fff6f735340) at kernel/qapplication.cpp:3758
#62 0x00007fd865812deb in KApplication::notify (this=0x7fff6f737440, receiver=0xee6750, event=0x7fff6f735340) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#63 0x00007fd8649ce6ac in QCoreApplication::notifyInternal (this=0x7fff6f737440, receiver=0xee6750, event=0x7fff6f735340) at kernel/qcoreapplication.cpp:610
#64 0x00007fd863e53b38 in QApplicationPrivate::sendMouseEvent (receiver=0xee6750, event=0x7fff6f735340, alienWidget=0xee6750, nativeWidget=0xe4d4e0, buttonDown=<value optimized out>, 
    lastMouseReceiver=@0x7fd864883010) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#65 0x00007fd863ebdb19 in QETWidget::translateMouseEvent (this=0xe4d4e0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#66 0x00007fd863ebcb53 in QApplication::x11ProcessEvent (this=0x7fff6f737440, event=0x7fff6f736ec0) at kernel/qapplication_x11.cpp:3550
#67 0x00007fd863ee5454 in x11EventSourceDispatch (s=0xdbb320, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#68 0x00007fd85f6ec20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#69 0x00007fd85f6ef8e0 in ?? () from /usr/lib/libglib-2.0.so.0
#70 0x00007fd85f6efa7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#71 0x00007fd8649f7a8f in QEventDispatcherGlib::processEvents (this=0xd9db50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#72 0x00007fd863ee4bdf in QGuiEventDispatcherGlib::processEvents (this=0x3, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#73 0x00007fd8649ccf42 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1869836720}) at kernel/qeventloop.cpp:149
#74 0x00007fd8649cd314 in QEventLoop::exec (this=0x7fff6f7371f0, flags={i = 1869836800}) at kernel/qeventloop.cpp:201
#75 0x00007fd8649cf5e4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#76 0x00007fd8672e3d60 in kdemain () from /usr/lib/libkdeinit4_keditbookmarks.so
#77 0x00007fd8631ad5a6 in __libc_start_main (main=0x400820 <_start+240>, argc=6, ubp_av=0x7fff6f737fc8, init=0x400850 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fff6f737fb8) at libc-start.c:220
#78 0x0000000000400759 in _start ()

This bug may be a duplicate of or related to bug 160679

Reported using DrKonqi
Comment 1 Tommi Tervo 2009-09-25 20:58:07 UTC

*** This bug has been marked as a duplicate of bug 187892 ***