Bug 201300

Summary: bookmarks editor crashed while moving one bookmark into one new folder
Product: keditbookmarks Reporter: Andrea Diamantini <adjam7>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Andrea Diamantini 2009-07-24 00:58:33 UTC
Application that crashed: keditbookmarks
Version of the application: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
KDE Version: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
Qt Version: 4.5.2
Operating System: Linux 2.6.30.2 i686

What I was doing when the application crashed:
the same as described above

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#5  0xb789f3b9 in QDomElementPrivate::save (this=0x9ff2330, s=@0xbfa83a40, depth=5, indent=1) at dom/qdom.cpp:4603
#6  0xb7893eab in QDomNodePrivate::save (this=0x9ff22f0, s=@0xbfa83a40, depth=5, indent=1) at dom/qdom.cpp:1916
#7  0xb789ef60 in QDomElementPrivate::save (this=0x9ff22f0, s=@0xbfa83a40, depth=4, indent=1) at dom/qdom.cpp:4640
#8  0xb7893eab in QDomNodePrivate::save (this=0x9feb150, s=@0xbfa83a40, depth=4, indent=1) at dom/qdom.cpp:1916
#9  0xb789ef60 in QDomElementPrivate::save (this=0x9feb150, s=@0xbfa83a40, depth=3, indent=1) at dom/qdom.cpp:4640
#10 0xb7893eab in QDomNodePrivate::save (this=0x9f3c6d0, s=@0xbfa83a40, depth=3, indent=1) at dom/qdom.cpp:1916
#11 0xb789ef60 in QDomElementPrivate::save (this=0x9f3c6d0, s=@0xbfa83a40, depth=2, indent=1) at dom/qdom.cpp:4640
#12 0xb7893eab in QDomNodePrivate::save (this=0x9d7f1c0, s=@0xbfa83a40, depth=2, indent=1) at dom/qdom.cpp:1916
#13 0xb789ef60 in QDomElementPrivate::save (this=0x9d7f1c0, s=@0xbfa83a40, depth=1, indent=1) at dom/qdom.cpp:4640
#14 0xb7893eab in QDomNodePrivate::save (this=0x9d7ef80, s=@0xbfa83a40, depth=1, indent=1) at dom/qdom.cpp:1916
#15 0xb789ef60 in QDomElementPrivate::save (this=0x9d7ef80, s=@0xbfa83a40, depth=0, indent=1) at dom/qdom.cpp:4640
#16 0xb78a3777 in QDomDocumentPrivate::saveDocument (this=0x9d1f4c0, s=@0xbfa83a40, indent=1, encUsed=QDomNode::EncodingFromDocument) at dom/qdom.cpp:6473
#17 0xb78a3e32 in QDomNode::save (this=0xbfa83ae0, str=@0xbfa83a40, indent=1) at dom/qdom.cpp:2684
#18 0xb78a3e95 in QDomDocument::toString (this=0xbfa83ae0, indent=1) at dom/qdom.cpp:6845
#19 0xb7b4c8ec in KBookmarkManager::saveAs (this=0x9d93a98, filename=@0x9d786d8, toolbarCache=true) at /DATI/SOFTWARE/BRANCH/tmp/kdelibs/kio/bookmarks/kbookmarkmanager.cc:402
#20 0xb7b4ca85 in KBookmarkManager::save (this=0x9d93a98, toolbarCache=<value optimized out>) at /DATI/SOFTWARE/BRANCH/tmp/kdelibs/kio/bookmarks/kbookmarkmanager.cc:368
#21 0xb7b4cab0 in KBookmarkManager::emitChanged (this=0x9d93a98, group=@0xbfa83ba4) at /DATI/SOFTWARE/BRANCH/tmp/kdelibs/kio/bookmarks/kbookmarkmanager.cc:516
#22 0xb803deb6 in CurrentMgr::notifyManagers (this=0x9d61eb8, grp=@0xbfa83ba4) at /DATI/SOFTWARE/BRANCH/tmp/kdebase_apps/keditbookmarks/toplevel.cpp:183
#23 0xb803ecda in CmdHistory::slotCommandExecuted (this=0x9d20428, k=0x9f3d748) at /DATI/SOFTWARE/BRANCH/tmp/kdebase_apps/keditbookmarks/toplevel.cpp:82
#24 0xb80576df in KBookmarkModel::dropMimeData (this=0x9d84db0, data=0x9d22e40, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfa83ce4)
    at /DATI/SOFTWARE/BRANCH/tmp/kdebase_apps/keditbookmarks/bookmarkmodel.cpp:306
#25 0xb6d0e95e in QAbstractItemView::dropEvent (this=0x9d7d880, event=0xbfa84480) at itemviews/qabstractitemview.cpp:1849
#26 0xb6860200 in QWidget::event (this=0x9d7d880, event=0xbfa84480) at kernel/qwidget.cpp:7731
#27 0xb6bd7c54 in QFrame::event (this=0x9d7d880, e=0xbfa84480) at widgets/qframe.cpp:559
#28 0xb6c6f522 in QAbstractScrollArea::viewportEvent (this=0x9d7d880, e=0xb72a2bc8) at widgets/qabstractscrollarea.cpp:962
#29 0xb6d1aef1 in QAbstractItemView::viewportEvent (this=0x9d7d880, event=0xbfa84480) at itemviews/qabstractitemview.cpp:1476
#30 0xb6d54217 in QTreeView::viewportEvent (this=0x9d7d880, event=0xbfa84480) at itemviews/qtreeview.cpp:1266
#31 0xb6c7185c in QAbstractScrollAreaFilter::eventFilter (this=0x9d91f10, o=0x9d7dd30, e=0xbfa84480) at widgets/qabstractscrollarea_p.h:100
#32 0xb71b174a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9c88fd8, receiver=0x9d7dd30, event=0xbfa84480) at kernel/qcoreapplication.cpp:726
#33 0xb680f063 in QApplicationPrivate::notify_helper (this=0x9c88fd8, receiver=0x9d7dd30, e=0xbfa84480) at kernel/qapplication.cpp:4052
#34 0xb681768a in QApplication::notify (this=0xbfa88630, receiver=0x9d7dd30, e=0xbfa84480) at kernel/qapplication.cpp:4009
#35 0xb76eea05 in KApplication::notify (this=0xbfa88630, receiver=0x9d7dd30, event=0xbfa84480) at /DATI/SOFTWARE/BRANCH/tmp/kdelibs/kdeui/kernel/kapplication.cpp:302
#36 0xb71b241f in QCoreApplication::notifyInternal (this=0xbfa88630, receiver=0x9d7dd30, event=0xbfa84480) at kernel/qcoreapplication.cpp:610
#37 0xb688f0c8 in QX11Data::xdndHandleDrop (this=0x9c8ca28, xe=0xbfa8455c, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#38 0xb6893c27 in QDragManager::drop (this=0x9f5ad00) at kernel/qdnd_x11.cpp:1709
#39 0xb6893dcb in QDragManager::eventFilter (this=0x9f5ad00, o=0x9fe8f48, e=0xbfa84a7c) at kernel/qdnd_x11.cpp:1302
#40 0xb71b17f8 in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9c88fd8, receiver=0x9fe8f48, event=0xbfa84a7c) at kernel/qcoreapplication.cpp:707
#41 0xb680f009 in QApplicationPrivate::notify_helper (this=0x9c88fd8, receiver=0x9fe8f48, e=0xbfa84a7c) at kernel/qapplication.cpp:4031
#42 0xb6817898 in QApplication::notify (this=0xbfa88630, receiver=0x9fe8f48, e=0xbfa84a7c) at kernel/qapplication.cpp:3758
#43 0xb76eea05 in KApplication::notify (this=0xbfa88630, receiver=0x9fe8f48, event=0xbfa84a7c) at /DATI/SOFTWARE/BRANCH/tmp/kdelibs/kdeui/kernel/kapplication.cpp:302
#44 0xb71b241f in QCoreApplication::notifyInternal (this=0xbfa88630, receiver=0x9fe8f48, event=0xbfa84a7c) at kernel/qcoreapplication.cpp:610
#45 0xb6815e88 in QApplicationPrivate::sendMouseEvent (receiver=0x9fe8f48, event=0xbfa84a7c, alienWidget=0x0, nativeWidget=0x9fe8f48, buttonDown=0xb703c9c0, lastMouseReceiver=@0xb703c9c4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#46 0xb6881d6c in QETWidget::translateMouseEvent (this=0x9fe8f48, event=0xbfa85ffc) at kernel/qapplication_x11.cpp:4409
#47 0xb68811f8 in QApplication::x11ProcessEvent (this=0xbfa88630, event=0xbfa85ffc) at kernel/qapplication_x11.cpp:3428
#48 0xb68a9022 in x11EventSourceDispatch (s=0x9c8bcf0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#49 0xb6078ac8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#50 0xb607c163 in ?? () from /usr/lib/libglib-2.0.so.0
#51 0x09c8b290 in ?? ()
#52 0x00000000 in ?? ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-24 02:48:45 UTC
This is reported as bug 187892. Merging. Thanks

*** This bug has been marked as a duplicate of bug 187892 ***