Bug 195372

Summary: reproducable crash on exit after visiting 2 web sites
Product: konqueror Reporter: Bernhard Beschow <shentey>
Component: khtmlAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: SVN   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Bernhard Beschow 2009-06-05 20:49:07 UTC
Application that crashed: konqueror
Version of the application: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527))
KDE Version: 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527))
Qt Version: 4.5.1
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
To reproduce:
1) visit maps.google.de
2) visit www.google.de
3) close konqueor
-> crash

 -- Backtrace:
Application: Konqueror (kdeinit), signal: Aborted
[KCrash Handler]
#6  0xb80bb430 in __kernel_vsyscall ()
#7  0xb68eb6d0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb68ed098 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb68e45ce in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb30b4dd4 in KHTMLGlobal::finalCheck () at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/khtml/khtml_global.cpp:258
#11 0xb090b2cc in ~KHTMLFactory (this=0x8b9b668) at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/khtml/khtml_factory.cpp:35
#12 0xb7e3c931 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x8e00338}, end={i = 0x87c0850}) at /opt/project-neon/include/QtCore/qalgorithms.h:350
#13 0xb7e3c9a8 in qDeleteAll<FactoryHash> (c=@0x8976448) at /opt/project-neon/include/QtCore/qalgorithms.h:358
#14 0xb7e3cbd2 in ~FactoryHash (this=0x8976448) at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kdecore/util/klibrary.cpp:93
#15 0xb7e3b9bd in destroy () at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kdecore/util/klibrary.cpp:97
#16 0xb7d1169b in ~KCleanUpGlobalStatic (this=0xb7e8fe30) at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kdecore/kernel/kglobal.h:62
#17 0xb68eebb9 in exit () from /lib/tls/i686/cmov/libc.so.6
#18 0x0804e187 in launch (argc=2, _name=0x8363204 "/opt/kde-nightly/bin/konqueror", args=0x836322b "", cwd=0x0, envc=0, envs=0x8363230 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8363234 "Normandie;1244227288;230647;3632_TIME677519") at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kinit/kinit.cpp:671
#19 0x0804ed47 in handle_launcher_request (sock=7, who=<value optimized out>) at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kinit/kinit.cpp:1163
#20 0x0804f495 in handle_requests (waitForPid=0) at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kinit/kinit.cpp:1356
#21 0x0804fa2c in main (argc=2, argv=0xbffd92f4, envp=0xbffd9300) at /build/buildd/kde-nightly-kdelibs-20090602+svn976889/kinit/kinit.cpp:1783

This bug may be a duplicate of or related to bug 195133

Reported using DrKonqi
Comment 1 Bernhard Beschow 2009-06-10 00:54:29 UTC

*** This bug has been marked as a duplicate of bug 151453 ***