Bug 195237

Summary: crash after open terminal here
Product: [Frameworks and Libraries] kio Reporter: BRULE Herman <alpha.super-one>
Component: generalAssignee: David Faure <faure>
Status: RESOLVED DUPLICATE    
Severity: crash CC: dgdaniel_f, frank78ac, pfrederick1, pollywog, zahl
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Gentoo Packages   
OS: Unspecified   
Latest Commit: Version Fixed In:

Description BRULE Herman 2009-06-04 18:35:44 UTC
Version:            (using KDE 4.2.3)
Installed from:    Gentoo Packages

Crash after I right click and open terminal here, backtrace:
Application: Konqueror (konqueror), signal SIGSEGV
0x00007f9fd72e0881 in nanosleep () from /lib/libc.so.6
Current language:  auto; currently c
[Current thread is 0 (LWP 4572)]

Thread 2 (Thread 0x7f9fcabac910 (LWP 4689)):
#0  0x00007f9fd730abd2 in select () from /lib/libc.so.6
#1  0x00007f9fd9d74622 in QProcessManager::run (this=0x1c85480) at io/qprocess_unix.cpp:305
#2  0x00007f9fd9cb1ee9 in QThreadPrivate::start (arg=0x1c85480) at thread/qthread_unix.cpp:189
#3  0x00007f9fd9a3f2f7 in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00007f9fd73117ad in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9fdc7d7750 (LWP 4572)):
[KCrash Handler]
#5  KDirModelNode::rowNumber (this=0x0) at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kio/kio/kdirmodel.cpp:115
#6  0x00007f9fdb656d40 in KDirModelPrivate::indexForNode (this=0x284f6a0, node=0x0, rowNumber=-1) at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kio/kio/kdirmodel.cpp:279
#7  0x00007f9fdb65b4d5 in KDirModelPrivate::_k_slotNewItems (this=0x284f6a0, directoryUrl=<value optimized out>, items=@0x21fc0a0)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kio/kio/kdirmodel.cpp:372
#8  0x00007f9fdb65c7ca in KDirModel::qt_metacall (this=0x2772950, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd4f04d40)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3_build/kio/kdirmodel.moc:78
#9  0x00007f9fd9da6a80 in QMetaObject::activate (sender=0x28509b0, from_signal_index=<value optimized out>, to_signal_index=14, argv=0xffffffff) at kernel/qobject.cpp:3108
#10 0x00007f9fdb6400aa in KDirLister::itemsAdded (this=0x0, _t1=<value optimized out>, _t2=<value optimized out>)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3_build/kio/kdirlister.moc:268
#11 0x00007f9fdb641223 in KDirLister::Private::emitItems (this=0x2851800) at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kio/kio/kdirlister.cpp:2276
#12 0x00007f9fdb642e9b in KDirListerCache::emitRefreshItem (this=<value optimized out>, oldItem=@0x7fffd4f04fa0, fileitem=@0x2321fc8)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kio/kio/kdirlister.cpp:962
#13 0x00007f9fdb64daa4 in KDirListerCache::slotFilesChanged (this=0x204cfe0, fileList=@0x2247cb0) at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kio/kio/kdirlister.cpp:834
#14 0x00007f9fdb65214c in KDirListerCache::qt_metacall (this=0x204cfe0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd4f05150)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3_build/kio/kdirlister_p.moc:93
#15 0x00007f9fd9da6a80 in QMetaObject::activate (sender=0x205f390, from_signal_index=<value optimized out>, to_signal_index=8, argv=0xffffffff) at kernel/qobject.cpp:3108
#16 0x00007f9fdb65e265 in OrgKdeKDirNotifyInterface::FilesChanged (this=0x0, _t1=<value optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3_build/kio/kdirnotify.moc:118
#17 0x00007f9fdb65e3e4 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x205f390, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd4f05250)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3_build/kio/kdirnotify.moc:82
#18 0x00007f9fda094eb3 in QDBusConnectionPrivate::deliverCall (this=0x1d167c0, object=0x205f390, msg=@0x21cf488, metaTypes=@0x21cf490, slotIdx=8) at qdbusintegrator.cpp:891
#19 0x00007f9fda09b65f in QDBusCallDeliveryEvent::placeMetaCall (this=0x28c8900, object=0x284f6a0) at qdbusintegrator_p.h:101
#20 0x00007f9fd9da3389 in QObject::event (this=0x205f390, e=0x21cf440) at kernel/qobject.cpp:1106
#21 0x00007f9fd906451d in QApplicationPrivate::notify_helper (this=0x1c80d10, receiver=0x205f390, e=0x21cf440) at kernel/qapplication.cpp:4057
#22 0x00007f9fd906d15a in QApplication::notify (this=0x7fffd4f06000, receiver=0x205f390, e=0x21cf440) at kernel/qapplication.cpp:4022
#23 0x00007f9fdabd27ea in KApplication::notify (this=0x7fffd4f06000, receiver=0x205f390, event=0x21cf440)
    at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#24 0x00007f9fd9d9312b in QCoreApplication::notifyInternal (this=0x7fffd4f06000, receiver=0x205f390, event=0x21cf440) at kernel/qcoreapplication.cpp:606
#25 0x00007f9fd9d93aef in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1c69de0) at kernel/qcoreapplication.h:213
#26 0x00007f9fd9dbb853 in postEventSourceDispatch (s=<value optimized out>) at kernel/qcoreapplication.h:218
#27 0x00007f9fd5c05739 in IA__g_main_context_dispatch (context=0x1c83840) at gmain.c:2144
#28 0x00007f9fd5c090ad in g_main_context_iterate (context=0x1c83840, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2778
#29 0x00007f9fd5c0925d in IA__g_main_context_iteration (context=0x1c83840, may_block=1) at gmain.c:2841
#30 0x00007f9fd9dbb44f in QEventDispatcherGlib::processEvents (this=0x1c80f90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
#31 0x00007f9fd90f4768 in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x00007f9fd9d91732 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -722444976}) at kernel/qeventloop.cpp:149
#33 0x00007f9fd9d91915 in QEventLoop::exec (this=0x7fffd4f05d90, flags={i = -722444896}) at kernel/qeventloop.cpp:196
#34 0x00007f9fd9d93d5c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#35 0x00007f9fdc3d0007 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /var/tmp/portage/kde-base/konqueror-4.2.3/work/konqueror-4.2.3/konqueror/src/konqmain.cpp:257
#36 0x00007f9fd725da26 in __libc_start_main (main=0x400a40 <main>, argc=2, ubp_av=0x7fffd4f06a78, init=0x400aa0 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffd4f06a68) at libc-start.c:220
#37 0x0000000000400929 in _start () at ../sysdeps/x86_64/elf/start.S:113
Comment 1 Frank Reininghaus 2009-06-04 18:59:20 UTC
Thanks for the bug report. Is this crash reproducible for you? I could not reproduce it, but it looks related to some other crashes (like bug 192770, bug 190535), which are all not always reproducible.
Comment 2 BRULE Herman 2009-06-04 19:13:47 UTC
Yes it's reproducible, I have often this bug after some file manipulation (remove, move, copy).
I have not located how preciselly product this bug.
Comment 3 BRULE Herman 2009-06-04 19:14:33 UTC
And it seam work perfectly in dolphin.
Comment 4 A. Spehr 2009-06-05 10:57:39 UTC
right click where? exactly how are you opening it?
Comment 5 BRULE Herman 2009-06-05 12:20:33 UTC
That's bug for some folder.
Comment 6 Frank Reininghaus 2009-07-19 22:12:34 UTC
It's probably the same crash as your earlier report bug 182516 and some others (like bug 190535, bug 181536). It would help a lot if you could check if there is some error output before the crash, which starts with "Items emitted in directory", and paste it here. If you're not running Konqueror in a Konsole, that output is in ~/.xsession-errors. It seems that the output you've linked to in https://bugs.kde.org/show_bug.cgi?id=182516#c6 is not reachable any more, sorry for not looking at it earlier.

Thanks for your help!
Comment 7 Tommi Tervo 2009-09-14 08:08:20 UTC
*** Bug 207311 has been marked as a duplicate of this bug. ***
Comment 8 Frank Reininghaus 2009-10-08 14:49:34 UTC
*** Bug 201478 has been marked as a duplicate of this bug. ***
Comment 9 Frank Reininghaus 2009-10-14 15:01:18 UTC

*** This bug has been marked as a duplicate of bug 182516 ***
Comment 10 Frank Reininghaus 2010-04-08 16:59:17 UTC
*** Bug 232646 has been marked as a duplicate of this bug. ***