Bug 187347

Summary: Double click to select words
Product: okular Reporter: Mike <hlavaty.michal>
Component: generalAssignee: Okular developers <okular-devel>
Status: RESOLVED FIXED    
Severity: wishlist CC: aacid, payam.bagheri
Priority: NOR    
Version: 0.7.3   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Unspecified   
Latest Commit: Version Fixed In: 4.9.0

Description Mike 2009-03-16 23:32:23 UTC
Version:           0.7.3 (using KDE 4.2.1)
Installed from:    Ubuntu Packages

When some dictionary is in use (e. g. stardict) the better selection of text would be great. Double click on the world could indicate the whole word. Very nice indicating has evince. It would be great to indicate text more precisely too. Thanks.
Comment 1 Pino Toscano 2009-03-16 23:39:33 UTC
Give it a better title.
Comment 2 Mike 2009-03-16 23:45:28 UTC
(In reply to comment #1)
> Give it a better title.

I am sorry. This is my first bug here. How can I do it? Any idea for better title?
Comment 3 Pino Toscano 2009-03-16 23:57:04 UTC
Sorry, mistyped :) I wanted to say: "giving it a better title".
Don't worry, your report was good enough! Just gave it a sligtly clearer title, so it is easier (for me, at least) to look for it.
Comment 4 Pino Toscano 2010-02-26 18:51:07 UTC
*** Bug 228642 has been marked as a duplicate of this bug. ***
Comment 5 Felis 2011-08-22 16:55:26 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Albert Astals Cid 2012-03-25 21:49:05 UTC
Git commit 9d805df013a033aa995fda71201de10824fc0c79 by Albert Astals Cid.
Committed on 25/03/2012 at 23:48.
Pushed by aacid into branch 'master'.

Double click selects words
FIXED-IN: 4.9,0

M  +8    -0    core/page.cpp
M  +8    -0    core/page.h
M  +81   -0    core/textpage.cpp
M  +8    -0    core/textpage.h
M  +15   -1    ui/pageview.cpp

http://commits.kde.org/okular/9d805df013a033aa995fda71201de10824fc0c79