Bug 187201

Summary: encoding incorrectly, if filenames archive contains non-Latin charachers
Product: ark Reporter: Konstantin <ria.freelander>
Component: generalAssignee: Harald Hvaal <metellius>
Status: RESOLVED FIXED    
Severity: normal CC: aazaharov81, mkyral, rakuco
Priority: NOR    
Version: 2.12   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: file, that causes bug
Correct openig in file-roller
Incorrectly - in ARK
Dolphin do not see this names
Ark: Wrong file names inside the zip file
Another buggy file (Same issue)
Not buggy file
Same issue with krusader (2.0.0-built today from svn, tested on first file)

Description Konstantin 2009-03-15 10:00:22 UTC
Version:           2.12 (using 4.2.1 (KDE 4.2.1), Arch Linux)
Compiler:          gcc
OS:                Linux (i686) release 2.6.28-ARCH

In attachment file, that causes bug, in second attachment -Correct opening in file-roller
Comment 1 Konstantin 2009-03-15 10:02:59 UTC
Created attachment 32125 [details]
file, that causes bug
Comment 2 Konstantin 2009-03-15 10:04:56 UTC
Created attachment 32126 [details]
Correct openig in file-roller

Bug not depend on qt version (both 4.4.3 and 4.5.0)
Comment 3 Konstantin 2009-03-15 10:08:46 UTC
Created attachment 32127 [details]
Incorrectly - in ARK
Comment 4 Konstantin 2009-03-15 10:16:49 UTC
Created attachment 32128 [details]
Dolphin do not see this names
Comment 5 Marian Kyral 2009-04-03 10:42:30 UTC
Created attachment 32556 [details]
Ark: Wrong file names inside the zip file

I was able to open the file Х ЛТ русский язык-11.zip and I can see two files inside, but file names are destroyed. But looks like unzip or archive issue.

[10:40:14 marian@nbmkyral Desktop]$ unzip "Х ЛТ русский язык-11.zip"
Archive:  Х ЛТ русский язык-11.zip
  inflating: � �� ���߬�� ��٬-11.doc
  inflating: �����Ҭ���.doc

[10:40:33 marian@nbmkyral Desktop]$ ll
celkem 12588
drwx------  2 marian users    4096  3. dub 10.40 .
drwx------ 85 marian users    4096  3. dub 10.21 ..
-rw-r--r--  1 marian users   51712 14. bře 22.16 ?????Ҭ???.doc
-rw-r--r--  1 marian users  239104 12. bře 23.41 ? ?? ???߬?? ??٬-11.doc
-rw-r--r--  1 marian users  177942  3. dub 10.24 Х ЛТ русский язык-11.zip

Gentoo, KDE 4.2.2/Qt 4.5
Comment 6 Marian Kyral 2009-04-03 11:04:08 UTC
I created a zip archive containing files with non ascii characters in name and I have no problem to open it with Ark.

I think, It is character encoding issue. The names in zip are not encoded in utf8. Don't know, if there is any support for store file names charset in the zip archive.

Btw: in shell I was able to rename the ???.doc files and open them in openoffice. But I cannot rename files in dolphin.
Comment 7 Konstantin 2009-04-03 12:06:32 UTC
No. I think it is Ark issue< besause file-roller from both NOME 2.24 and 2.26 opens it correctly. See: https://bugs.kde.org/attachment.cgi?id=32126
Comment 8 Konstantin 2009-04-03 12:07:12 UTC
Sorry for mistakes and bad English
Comment 9 Konstantin 2009-04-03 12:08:38 UTC
you create archive in Ark?
Comment 10 Konstantin 2009-04-03 12:11:10 UTC
I see this bug with archives, wich not created in it...
Comment 11 Konstantin 2009-04-03 12:27:42 UTC
Created attachment 32563 [details]
Another buggy file (Same issue)
Comment 12 Konstantin 2009-04-03 12:31:30 UTC
Created attachment 32564 [details]
Not buggy file

Same folder zipped. Firs file created by WinRAR from WINE, second - in file-roller
Comment 13 Marian Kyral 2009-04-03 12:33:30 UTC
(In reply to comment #9)
> you create archive in Ark?

I made two archives. One packed by Dolphin and second packed by zip utility.

[I] app-arch/zip
     Available versions:  2.32-r1 (~)3.0 {bzip2 crypt unicode}
     Installed versions:  3.0(14:15:07 27.10.2008)(bzip2 crypt unicode)
     Homepage:            http://www.info-zip.org/
     Description:         Info ZIP (encryption support)

Both were correctly open in Ark.
Comment 14 Marian Kyral 2009-04-03 12:36:59 UTC
(In reply to comment #12)
> Created an attachment (id=32564) [details]
> Not buggy file
> 
> Same folder zipped. Firs file created by WinRAR from WINE, second - in
> file-roller

Some special WinRAR feature?
Comment 15 Konstantin 2009-04-03 12:58:03 UTC
No, I think. Windows archives packed not in UTF-8.... Linux is packed... I think, this issues will be wit all Windows-created archives.I think,encoding selection exists in file-roller sources...
Comment 16 Konstantin 2009-04-03 13:13:10 UTC
Trying open not buggy for ark file in WinRAR - has encoding issue:)
Comment 17 Raphael Kubo da Costa 2009-04-10 22:49:00 UTC
Let me try to summarize what's going on here, correct me if I'm wrong:

* Files created by WinRAR (probably not using UTF-8) aren't displayed/extracted correctly by Ark, even though file-roller does extract and display them
* Files created by Ark or the command-line zip utility (UTF-8) are displayed correctly in Ark, but WinRAR does not open them

I could not open the files Konstantin called buggy here in 4.2.2 either, but unzip -l in the command-line lists them fine.
Comment 18 Raphael Kubo da Costa 2009-04-10 22:51:52 UTC
Can you also confirm if it only happens to ZIP files?
Comment 19 Konstantin 2009-04-11 06:49:31 UTC
Yes, only zips from Windows (winrar and zip folders).
Comment 20 Raphael Kubo da Costa 2009-04-11 06:51:40 UTC
What encoding are you using on Windows to create those files?
Comment 21 Konstantin 2009-04-11 06:56:50 UTC
WinRRAR uses cp1251 encoding. Windows XP default - also:) Now my Windows XP not work:)
Comment 22 Konstantin 2009-04-12 17:47:13 UTC
Created attachment 32787 [details]
Same issue with krusader (2.0.0-built today from svn, tested on first file)
Comment 23 Raphael Kubo da Costa 2009-04-22 03:01:30 UTC
This actually seems to be a bug in libzip. The same files compacted with 
another file type are shown just fine. This may be yet another reason to move 
away from it.
Comment 24 Harald Hvaal 2009-06-06 02:25:20 UTC
*** Bug 195351 has been marked as a duplicate of this bug. ***
Comment 25 Harald Hvaal 2009-06-07 04:06:34 UTC
Fixed in trunk, will be in 4.3.