Bug 179663

Summary: Password for remote webdav share needs to be re-entered all the time
Product: kdelibs Reporter: Diederik van der Boor <vdboor>
Component: generalAssignee: kdelibs bugs <kdelibs-bugs>
Status: RESOLVED FIXED    
Severity: normal CC: bakatamas
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In: 4.7.4

Description Diederik van der Boor 2009-01-04 23:37:20 UTC
Version:           onbekend (using 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2)) "release 3.1", KDE:KDE4:UNSTABLE:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27.7-9-pae

I have to re-enter the password for a remote webdav:// share too often. I disabled "Remember password" because I don't want it to be stored forever (it's a server at work, while I'm working at home).

Example:
 * Open Kate
 * Open the webdav:// share
 * Enter password.

Now:
 * Select the file
 * Kate asks for the password again.

And:
 * Open a new file
 * Browse to a next directory
 * Enter passworwd again.

And:
 * Open a new file
 * Enter password again.

When "remember password" is not checked, I expected the application to remember the password for the session only (much like a session cookie which is lost when the application closes).
Comment 1 Dawit Alemayehu 2011-12-01 05:36:40 UTC
Git commit c30ee2b64f82a0cf09f50b765a29908efb8ebf05 by Dawit Alemayehu.
Committed on 24/11/2011 at 07:14.
Pushed by adawit into branch 'KDE/4.7'.

* In KIO::Scheduler attempt to find and use the window-id from the top most
  level window so that the ids used will not be from temporary short lived
  windows such as file dialogs.

* Set the window widget when calling KIO functions in KFileDialog and related
  classes so that password information is preserved for the entire life of the
  application from which the file dialog is launched instead of a short duration.

BUG: 179663
FIXED-IN: 4.7.4
REVIEW: 103226

M  +4    -4    kfile/kdiroperator.cpp
M  +5    -5    kfile/kdirselectdialog.cpp
M  +12   -12   kfile/kfilewidget.cpp
M  +12   -14   kfile/knewfilemenu.cpp
M  +24   -2    kio/kio/scheduler.cpp

http://commits.kde.org/kdelibs/c30ee2b64f82a0cf09f50b765a29908efb8ebf05
Comment 2 Aaron J. Seigo 2011-12-02 20:53:21 UTC
Git commit b39253a8f907a999500068c89f340907b9c96094 by Aaron Seigo, on behalf of Dawit Alemayehu.
Committed on 24/11/2011 at 07:14.
Pushed by aseigo into branch 'frameworks'.

* In KIO::Scheduler attempt to find and use the window-id from the top most
  level window so that the ids used will not be from temporary short lived
  windows such as file dialogs.

* Set the window widget when calling KIO functions in KFileDialog and related
  classes so that password information is preserved for the entire life of the
  application from which the file dialog is launched instead of a short duration.

BUG: 179663
FIXED-IN: 4.7.4
REVIEW: 103226

M  +4    -4    kfile/kdiroperator.cpp
M  +5    -5    kfile/kdirselectdialog.cpp
M  +12   -12   kfile/kfilewidget.cpp
M  +1    -3    kfile/knewfilemenu.cpp
M  +24   -2    kio/kio/scheduler.cpp

http://commits.kde.org/kdelibs/b39253a8f907a999500068c89f340907b9c96094
Comment 3 Dawit Alemayehu 2012-05-12 15:41:52 UTC
*** Bug 195535 has been marked as a duplicate of this bug. ***