Bug 176932

Summary: Xorg takes 100% cpu when idle for more than two minutes
Product: [Frameworks and Libraries] solid Reporter: Dorin Scutarașu <dorin.scutarasu>
Component: powermanagement-daemonAssignee: Dario Freddi <drf>
Status: RESOLVED DUPLICATE    
Severity: normal CC: dorin.scutarasu, michalodstrcil
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Dorin Scutarașu 2008-12-04 23:44:21 UTC
Version:            (using Devel)
Compiler:          gcc (Ubuntu 4.3.2-1ubuntu11) 4.3.2 
OS:                Linux
Installed from:    Compiled sources

I use a two days old kde SVN build. Xorg takes 100% cpu when idle for more than two minutes. If I move the mouse or press a key, it goes away. Also, if I disable powerdevil service, Xorg doesn't hog the cpu anymore. I'm not sure when this started happening - maybe since a couple of weeks. 

I tried fiddling with the powerdevil options and profile, but I couldn't get rid of this problem; it always happens after 2 minutes.

I'm running kubuntu 8.10 and xserver-xorg 7.4.

Here's more info, just in case it helps:

Kded output when I restart the powerdevil service:
----BEGIN-------------------------------------
kded(25032)/kded4 Kded::unloadModule: Unloading module "powerdevil"
kded(25032) XSyncBasedPoller::XSyncBasedPoller: XSync Inited       
kded(25032) XSyncBasedPoller::XSyncBasedPoller: XSync Inited       
kded(25032)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kded(25032) PowerDevilDaemon::profileFirstLoad: Profile initialization 
kded(25032) PowerDevilDaemon::poll: Polling started, idle time is 0 seconds
kded(25032) PowerDevilDaemon::poll: Minimum time is 120 seconds            
kded(25032) PowerDevilDaemon::poll: Nothing to do, next event in 120 seconds
kded(25032) PowerDevilDaemon::poll: Polling started, idle time is 0 seconds 
kded(25032) PowerDevilDaemon::poll: Minimum time is 120 seconds             
kded(25032) PowerDevilDaemon::poll: Nothing to do, next event in 120 seconds
kded(25032) KDEDModule::setModuleName: registerObject() successful for  "powerdevil"
kded(25032)/kded4 Kded::loadModule: Successfully loaded module "powerdevil"
------END-----------------------------------------------

This is the profile that I I'm using:
[green]
DPMSEnabled=false
DPMSPowerOff=3
DPMSPowerOffEnabled=false
DPMSStandby=0
DPMSStandbyEnabled=false
DPMSSuspend=2
DPMSSuspendEnabled=true
brightness=68
cpuPolicy=1
dimOnIdle=true
dimOnIdleTime=4
disableCompositing=false
disabledCPUs=
iconname=flag-green
idleAction=0
idleTime=50
lidAction=2
powerButtonAction=0
scheme=powersaving
scriptpath=
sleepButtonAction=0
turnOffIdle=true
turnOffIdleTime=50

Please let me know if there's anyway I can help debug this.
Comment 1 Dario Freddi 2008-12-04 23:49:08 UTC

*** This bug has been marked as a duplicate of bug 174897 ***
Comment 2 Dorin Scutarașu 2008-12-05 00:51:30 UTC

*** This bug has been marked as a duplicate of bug 174897 ***
Comment 3 Dario Freddi 2008-12-07 17:17:43 UTC
*** Bug 175353 has been marked as a duplicate of this bug. ***