Bug 171866

Summary: Not all settings in new profile are applied after the 'change profile' action is triggered
Product: konsole Reporter: Emmanuel Surleau <emmanuel.surleau>
Component: generalAssignee: Konsole Developer <konsole-devel>
Status: RESOLVED FIXED    
Severity: normal CC: adaptee, dhruvshekhar.garg2016, hein, mh+kde-bugs, robertknight, wrar
Priority: NOR    
Version: 2.1   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In: 4.9.0

Description Emmanuel Surleau 2008-09-29 21:35:54 UTC
Version:           2.1 (using 4.1.1 (KDE 4.1.1), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.26-5.slh.6-sidux-686

The 'Change profile' action in the menu doesn't seem to do anything.
Comment 1 Robert Knight 2008-09-29 23:10:11 UTC
The 'Change Profile' action will change most properties of the session, such as color scheme, keyboard layout, font size and terminal settings to those from the new profile but it won't change the current directory or the program since those have to be set before the session is started.
Comment 2 Emmanuel Surleau 2008-09-29 23:49:28 UTC
It should be able to hide the tab bar and the menu, IMHO.
Comment 3 Robert Knight 2008-09-30 00:23:43 UTC
We tried that.  Although it was useful for certain purposes it turned out to be pretty confusing.  Especially when different tabs had different profiles with different tab and menu bar settings and the user saw the tab bar change visibility when switching between them.


Comment 4 Emmanuel Surleau 2008-10-01 22:14:20 UTC
I hadn't realized that the 'profile' was tab-specific (sort of). Then it starts to make sense. However, I think the real issue is that you have tab-specific profiles, which also contain window-wide settings. Some ideas to improve the situation:

a) Split profiles into window-wide profiles and tab-wide profiles. Sounds like lots of work and potentially confusing.
b) Add a checkbox 'Apply to whole window' - the profile would then apply to the existing tabs and honour 'Show/hide menubar' and 'Show/hide tabbar' upon switching.
c) Add a warning upon saving, explaining that you need to start the application with --profile <profile> in order to have window-wide settings applied

In addition (I can make a separate bug for it), it'd be nice to have in the menu View -> Show tab bar (the way we already have 'Show menu bar').

Thoughts?
Comment 5 Robert Knight 2008-10-02 00:24:39 UTC
> a) Split profiles into window-wide profiles and tab-wide profiles.
> Sounds like lots of work and potentially confusing. 

Alternatively I could have just one set of window and tab bar settings which are accessed through a different menu item.  This would be less flexible than the current setup but probably easier to understand.
Comment 6 Eike Hein 2008-10-02 11:21:03 UTC
Finally moving those settings out of the tab profiles would also avoid some confusion for users of KPart-hosting apps (that e.g. may have their own tabbing that the profile doesn't have any means to affect).
Comment 7 Marc Haber 2009-11-17 11:24:11 UTC
Please consider implementing this change. I have _one_ window which needs to be as small as possible (no border, no menu bar, no tab bar, no scroll bar), and I currently can either choose whether to turn-off all those on _every_ _login_, or do have the single window open as I want it but then to enable all those for every console window I open.

KDE 3.5 didn't have this annoying behavior.

Greetings
Marc
Comment 8 Marc Haber 2010-03-31 15:01:48 UTC
This is still present in konsole 2.4.2
Comment 9 Jekyll Wu 2011-08-16 07:19:09 UTC
*** Bug 188107 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2012-01-22 06:23:33 UTC
Well, I know this report is quite old, but still..

I have just pushed some commits onto the master branch. Options for menubar and tabbar have been moved out of profile and now live in the newly added "Configure Konsole" dialog. They are global settings now.

(In reply to comment #4)

> In addition (I can make a separate bug for it), it'd be nice to have in the
> menu View -> Show tab bar (the way we already have 'Show menu bar').
> 
> Thoughts?

That sounds like going back to the KDE3 konsole's way of organizing and controlling various options. I prefer the KDE4 konsole's way. It takes two or three more clicks, but I wonder how many users have the need or habit of changing tabbar  settings frequently.

(In reply to comment #7)
> Please consider implementing this change. I have _one_ window which needs to be
> as small as possible (no border, no menu bar, no tab bar, no scroll bar), and I
> currently can either choose whether to turn-off all those on _every_ _login_,
> or do have the single window open as I want it but then to enable all those for
> every console window I open.
> 
> KDE 3.5 didn't have this annoying behavior.
> 
> Greetings
> Marc

If I understand it correctly, you are missing the --nomenubar, --notabbar and --noscrollbar command line options from KDE3 konsole. It is better to open another report dedicated for that problem.

Actually, your need was achievable when those options lived in profiles. Try 'konsole -p ShowMenuBar=0 -p TabBarMode=0  -p ScrollBarPosition=2'. Of course, that does not work any more using the latest code.