Bug 167278

Summary: it's not possible to position widgets on the panel where I want to
Product: [Plasma] plasma4 Reporter: Janet <bugzilla>
Component: panelAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal CC: sebas
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Janet 2008-07-23 10:00:00 UTC
Version:           Unbekannt (using 4.1.00 (KDE 4.0.99 (4.1 RC1+)), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.25-11.slh.2-sidux-686

I removed the taskbar widget from the main panel at the bottom to put it into a separate panel at the top of the screen. After that I wanted to arrange the other widgets: clock strictly to the right, tray left of it and pager (one row) in the exact middle of the panel (the panel itself is centered too). But alas that's not possible, there always remains an unused space at the right side of the panel and when I drag the tray to the left side of the clock the pager wanders to the left side of the panel and clings itself right to the menu button.

It seems that some panel widgets have a fixed space around them that orientates on the size of the other widgets in the panel and are centered within this space, no matter how wide they are actually. When I set the pager to two rows its "aura" shrinks but the that of the tray and the clock increases.

Panel widgets should be freely positionable as it is in KDE3's kicker and in other panels. Or maybe there should be extra spacers for positioning to get e.g. symmetric views etc.
Comment 1 Janet 2008-07-23 14:59:35 UTC
Seems to be a duplicate of Bug 164317.
Comment 2 Sebastian K├╝gler 2008-11-18 03:43:44 UTC

*** This bug has been marked as a duplicate of bug 164317 ***